summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rwxr-xr-xPKGBUILD5
-rwxr-xr-xmakerbot-desktop.install7
3 files changed, 8 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8203538577df..e30647acc3a0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -10,7 +10,7 @@ pkgbase = makerbot-desktop
depends = qt5-base
depends = qt5-multimedia
depends = qt5-webkit
- depends = jsoncpp
+ depends = jsoncpp=0.6.0rc2
depends = postgresql-libs
depends = python2
depends = libjpeg6
diff --git a/PKGBUILD b/PKGBUILD
index c75ec3e8a2d4..3432f1231353 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ pkgdesc="A complete, free 3D printing solution for discovering, managing, and sh
arch=('x86_64')
url="https://www.makerbot.com/desktop"
license=('GPL')
-depends=('qt5-base' 'qt5-multimedia' 'qt5-webkit' 'jsoncpp' 'postgresql-libs' 'python2'
+depends=('qt5-base' 'qt5-multimedia' 'qt5-webkit' 'jsoncpp=0.6.0rc2' 'postgresql-libs' 'python2'
'libjpeg6' 'yajl' 'qt4' 'libmariadbclient' 'shared-mime-info' 'opencv' 'gl2ps' 'hdf5' 'tcl' 'zenity')
makedepends=('rpmextract')
options=('!strip')
@@ -80,6 +80,5 @@ package() {
msg2 "Creating log files"
touch var/log/conveyor/conveyord.log
- chmod g+w var/log/conveyor/conveyord.log
-
+ chmod g+w var/log/conveyor/conveyord.log
}
diff --git a/makerbot-desktop.install b/makerbot-desktop.install
index d35b6b82d1d3..0d8811ad0351 100755
--- a/makerbot-desktop.install
+++ b/makerbot-desktop.install
@@ -47,11 +47,14 @@ post_install() {
gpasswd -a conveyor root
+ chown /var/log/conveyor/conveyord.log
+
## Enable and start conveyor service
echo -e "Enabling and starting conveyor.service"
systemctl enable conveyor
systemctl start conveyor
}
-
-
+post_upgrade() {
+ chown conveyor /var/log/conveyor/conveyord.log
+} \ No newline at end of file