summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD45
-rw-r--r--README.en32
-rwxr-xr-xmkconfig.expect50
4 files changed, 147 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e6ef654d01da
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = man-pages-ja
+ pkgdesc = Man pages for Japanese
+ pkgver = 0.5.0.0.20150805
+ pkgrel = 1
+ url = http://sourceforge.jp/projects/linuxjm/
+ arch = any
+ license = custom
+ makedepends = git
+ makedepends = expect
+ provides = man-pages-ja
+ conflicts = man-pages-ja
+ source = git+git://git.sourceforge.jp/gitroot/linuxjm/jm.git
+ source = mkconfig.expect
+ source = README.en
+ md5sums = SKIP
+ md5sums = d9ef996a4bb92abd7dfc7bb19013ce95
+ md5sums = eb138d945bba86fbc8c83768581178c8
+
+pkgname = man-pages-ja
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4ae1378a77ab
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Tatsunori Aoki <ginjiro.135 at gmail dot com>
+# Contributor: kuina <kuinanein at gmail dot com>
+pkgname=man-pages-ja
+pkgver=0.5.0.0.20150805
+pkgrel=1
+pkgdesc="Man pages for Japanese"
+arch=('any')
+url="http://sourceforge.jp/projects/linuxjm/"
+license=('custom')
+makedepends=('git' 'expect')
+provides=('man-pages-ja')
+conflicts=('man-pages-ja')
+source=('git+git://git.sourceforge.jp/gitroot/linuxjm/jm.git'
+ 'mkconfig.expect'
+ 'README.en')
+md5sums=('SKIP'
+ 'd9ef996a4bb92abd7dfc7bb19013ce95'
+ 'eb138d945bba86fbc8c83768581178c8')
+
+pkgver() {
+ cd $srcdir/jm
+ echo 0.5.0.0.$(git log --pretty=format:%ci -n1 | cut -f 1 -d " " | sed "s/-//g")
+}
+
+prepare() {
+ cp $srcdir/jm/JM.rules $srcdir/jm/JM.rules.orig
+ sed -e "s!JMHOME\=.*\$!JMHOME\=$srcdir/jm/pkgbuild!g" \
+ -e "s!POD2MAN\=.*\$!POD2MAN=$(which pod2man)!g" \
+ $srcdir/jm/JM.rules.orig > $srcdir/jm/JM.rules
+}
+
+build() {
+ cd $srcdir/jm
+ make tarball
+}
+
+package() {
+ install -D -m644 $srcdir/README.en "${pkgdir}/usr/share/licenses/${pkgname}/README.en"
+ install -D -m644 $srcdir/jm/dist/README "${pkgdir}/usr/share/licenses/${pkgname}/README"
+ cd $srcdir/jm/pkgbuild/tmp
+ cd $(ls | egrep "man-pages-ja-[0-9]+$")
+ cp $srcdir/mkconfig.expect ./
+ env PKGDIR="$pkgdir" ./mkconfig.expect
+ make install
+}
diff --git a/README.en b/README.en
new file mode 100644
index 000000000000..3b1f45ace99c
--- /dev/null
+++ b/README.en
@@ -0,0 +1,32 @@
+This file is a partial *UNOFFICIAL* translation
+by the AUR package mainteiner
+on 2013-06-19.
+----
+
+Linux Japanes man pages
+Jun 19, 2013
+JM Project <linuxjm-discuss@lists.sourceforge.jp>
+http://linuxjm.sourceforge.jp/
+----
+
+6. Copyright and Distribution
+
+ Each man page has different licenses and distribution terms.
+ Please refer to comments in the roff files of the man pages.
+
+ Just for reference: most of the man pages are allowed to be distributed
+ in nroff format, but cannot be distributed as cat pages
+ without the roff files. Basically, JM Project does not add
+ additional restrictions besides the original terms.
+
+ JM project owns the compilation copyright of this package.
+ You can distribute this freely as long as you follow the above instructions.
+
+
+7. Contributed Man Pages
+
+ This archive includes manual pages translated by third parties.
+ More specifically, in "translation_list" files, the contributed pages
+ are marked with something along the lines of "C" or "c".
+ The "translation_list" files are placed in directories of packages
+ under "manual/". The copyrihts of those pages belong to the contributors.
diff --git a/mkconfig.expect b/mkconfig.expect
new file mode 100755
index 000000000000..28042391db2f
--- /dev/null
+++ b/mkconfig.expect
@@ -0,0 +1,50 @@
+#!/usr/bin/expect
+
+if { 0 == [info exists env(PKGDIR)] } {
+ puts "PKGDIR environment variable must be set"
+ exit 1
+}
+
+set timeout -1
+spawn make
+
+expect "Install directory *\/usr\/share\/man\/$env(LANG)"
+send "$env(PKGDIR)\/usr\/share\/man\/ja_JP\.UTF\-8\n"
+
+expect "compress manual with"
+expect "0: none"
+expect "select"
+send "0\n"
+
+expect "uname of page owner *root"
+send "\n"
+
+expect "group of page owner *root"
+send "\n"
+
+expect "All OK?"
+send "y\n"
+
+expect "INSTALL PACKAGE SELECTION"
+while { true } {
+ expect "Y/n" {
+ send "\n"
+ } "y/N" {
+ send "\n"
+ } "All OK?" {
+ send "y\n"
+ break
+ }
+}
+
+expect "RESOLVE CONFLICTS"
+while { true } {
+ expect "Which to install?" {
+ send "\n"
+ } "All OK?" {
+ send "y\n"
+ break
+ }
+}
+
+interact