summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD41
-rw-r--r--README.en32
-rw-r--r--man-pages-ja.install13
-rwxr-xr-xmkconfig.expect50
5 files changed, 37 insertions, 118 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f5fd4f27f229..52d3c6d17d6d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,17 @@
# Generated by mksrcinfo v8
-# Wed Dec 16 04:52:25 UTC 2015
+# Wed May 10 03:22:37 UTC 2017
pkgbase = man-pages-ja
pkgdesc = Man pages for Japanese
- pkgver = 20151216
+ pkgver = 20170415
pkgrel = 1
- url = http://osdn.jp/projects/linuxjm/
+ url = https://linuxjm.osdn.jp
+ install = man-pages-ja.install
arch = any
license = custom
- makedepends = git
- makedepends = expect
- provides = man-pages-ja-git
+ makedepends = perl
conflicts = man-pages-ja-git
- source = git+http://scm.osdn.jp/gitroot/linuxjm/jm.git
- source = mkconfig.expect
- source = README.en
- md5sums = SKIP
- md5sums = d9ef996a4bb92abd7dfc7bb19013ce95
- md5sums = eb138d945bba86fbc8c83768581178c8
+ source = https://linuxjm.osdn.jp/man-pages-ja-20170415.tar.gz
+ md5sums = 6ec32f9f2c70ea39e945dac06d0ca582
pkgname = man-pages-ja
diff --git a/PKGBUILD b/PKGBUILD
index 25c30d899edd..d24969f25d43 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,40 +1,33 @@
# Maintainer: Tatsunori Aoki <ginjiro.135 at gmail dot com>
-# Contributor: kuina <kuinanein at gmail dot com>
pkgname=man-pages-ja
-pkgver=20151216
+pkgver=20170415
pkgrel=1
pkgdesc="Man pages for Japanese"
arch=('any')
-url="http://osdn.jp/projects/linuxjm/"
+url="https://linuxjm.osdn.jp"
license=('custom')
-makedepends=('git' 'expect')
-provides=('man-pages-ja-git')
+makedepends=('perl')
conflicts=('man-pages-ja-git')
-source=('git+http://scm.osdn.jp/gitroot/linuxjm/jm.git'
- 'mkconfig.expect'
- 'README.en')
-md5sums=('SKIP'
- 'd9ef996a4bb92abd7dfc7bb19013ce95'
- 'eb138d945bba86fbc8c83768581178c8')
+install="${pkgname}.install"
+source=("https://linuxjm.osdn.jp/man-pages-ja-${pkgver}.tar.gz")
+md5sums=('6ec32f9f2c70ea39e945dac06d0ca582')
prepare() {
- cp $srcdir/jm/JM.rules $srcdir/jm/JM.rules.orig
- sed -e "s!JMHOME\=.*\$!JMHOME\=$srcdir/jm/pkgbuild!g" \
- -e "s!POD2MAN\=.*\$!POD2MAN=$(which pod2man)!g" \
- $srcdir/jm/JM.rules.orig > $srcdir/jm/JM.rules
+ cd ${srcdir}/${pkgname}-${pkgver}
+ sed -i '/until/i$ans = "y";' script/configure.perl
+ sed -i "/usr[/]share[/]man[/]/s@/@${pkgdir}/@1" script/configure.perl
}
build() {
- cd $srcdir/jm
- make tarball
+ cd ${srcdir}/${pkgname}-${pkgver}
+ yes '' | make config
}
package() {
- install -D -m644 $srcdir/README.en "${pkgdir}/usr/share/licenses/${pkgname}/README.en"
- install -D -m644 $srcdir/jm/dist/README "${pkgdir}/usr/share/licenses/${pkgname}/README"
- cd $srcdir/jm/pkgbuild/tmp
- cd $(ls | egrep "man-pages-ja-[0-9]+$")
- cp $srcdir/mkconfig.expect ./
- env PKGDIR="$pkgdir" ./mkconfig.expect
- make install
+ mkdir -p ${pkgdir}/usr/share/man/${LANG}
+ cd ${srcdir}/${pkgname}-${pkgver}
+ make install
+
+# makewhatis
+# mandb
}
diff --git a/README.en b/README.en
deleted file mode 100644
index 3b1f45ace99c..000000000000
--- a/README.en
+++ /dev/null
@@ -1,32 +0,0 @@
-This file is a partial *UNOFFICIAL* translation
-by the AUR package mainteiner
-on 2013-06-19.
-----
-
-Linux Japanes man pages
-Jun 19, 2013
-JM Project <linuxjm-discuss@lists.sourceforge.jp>
-http://linuxjm.sourceforge.jp/
-----
-
-6. Copyright and Distribution
-
- Each man page has different licenses and distribution terms.
- Please refer to comments in the roff files of the man pages.
-
- Just for reference: most of the man pages are allowed to be distributed
- in nroff format, but cannot be distributed as cat pages
- without the roff files. Basically, JM Project does not add
- additional restrictions besides the original terms.
-
- JM project owns the compilation copyright of this package.
- You can distribute this freely as long as you follow the above instructions.
-
-
-7. Contributed Man Pages
-
- This archive includes manual pages translated by third parties.
- More specifically, in "translation_list" files, the contributed pages
- are marked with something along the lines of "C" or "c".
- The "translation_list" files are placed in directories of packages
- under "manual/". The copyrihts of those pages belong to the contributors.
diff --git a/man-pages-ja.install b/man-pages-ja.install
new file mode 100644
index 000000000000..029a8b4ecc63
--- /dev/null
+++ b/man-pages-ja.install
@@ -0,0 +1,13 @@
+post_install() {
+ set -x
+ makewhatis -v
+ mandb
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}
diff --git a/mkconfig.expect b/mkconfig.expect
deleted file mode 100755
index 28042391db2f..000000000000
--- a/mkconfig.expect
+++ /dev/null
@@ -1,50 +0,0 @@
-#!/usr/bin/expect
-
-if { 0 == [info exists env(PKGDIR)] } {
- puts "PKGDIR environment variable must be set"
- exit 1
-}
-
-set timeout -1
-spawn make
-
-expect "Install directory *\/usr\/share\/man\/$env(LANG)"
-send "$env(PKGDIR)\/usr\/share\/man\/ja_JP\.UTF\-8\n"
-
-expect "compress manual with"
-expect "0: none"
-expect "select"
-send "0\n"
-
-expect "uname of page owner *root"
-send "\n"
-
-expect "group of page owner *root"
-send "\n"
-
-expect "All OK?"
-send "y\n"
-
-expect "INSTALL PACKAGE SELECTION"
-while { true } {
- expect "Y/n" {
- send "\n"
- } "y/N" {
- send "\n"
- } "All OK?" {
- send "y\n"
- break
- }
-}
-
-expect "RESOLVE CONFLICTS"
-while { true } {
- expect "Which to install?" {
- send "\n"
- } "All OK?" {
- send "y\n"
- break
- }
-}
-
-interact