summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD31
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..717bdc4176de
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+# Generated by mksrcinfo v8
+# Fri Jan 15 05:12:40 UTC 2016
+pkgbase = man-pages-samba-ja
+ pkgdesc = Man pages for the Samba4
+ pkgver = 4.1.8
+ pkgrel = 1
+ url = http://wiki.samba.gr.jp/
+ arch = any
+ license = GPLv3
+ source = https://osdn.jp/projects/samba-jp/downloads/61467/samba-ja-docs-manpages-4.1.8-1.tar.gz
+ md5sums = 54318965992018a41b1ad4da7e94f52f
+
+pkgname = man-pages-samba-ja
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4dec2d952740
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Your Name <youremail@domain.com>
+pkgname=man-pages-samba-ja
+pkgver=4.1.8
+pkgrel=1
+pkgdesc="Man pages for the Samba4"
+arch=("any")
+url="http://wiki.samba.gr.jp/"
+license=("GPL3" "custom")
+source=("http://osdn.jp/frs/redir.php?m=jaist&f=%2Fsamba-jp%2F61467%2Fsamba-ja-docs-manpages-${pkgver}-1.tar.gz")
+md5sums=('bf873a17313148a5aeddd7a139d5d803')
+
+package() {
+ install -D -m644 ${srcdir}/docs-xml/README "${pkgdir}/usr/share/licenses/${pkgname}/README"
+ install -D -m644 ${srcdir}/docs-xml/COPYING "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
+ cd $srcdir/docs-xml/output/manpages
+ for i in *.[1-9] ; do
+ tar cvfz ${i}.gz ${i}
+ done
+ for f in 1 5 7 8; do
+ mkdir -p "${pkgdir}/usr/share/man/ja_JP.UTF-8/man${f}/"
+ chmod -R 755 "${pkgdir}/usr/share/man/ja_JP.UTF-8/man${f}/"
+ cp *.${f}.gz "${pkgdir}/usr/share/man/ja_JP.UTF-8/man${f}/"
+ chmod 644 *.${f}.gz
+ done
+
+}