summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD56
2 files changed, 44 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 31c13d470f77..2b39b7991cc9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,24 @@
-pkgbase = mandoc
+pkgbase = mandoc-cvs
pkgdesc = A suite of tools compiling mdoc from the OpenBSD project
- pkgver = 1.14.5
+ pkgver = 20190314
pkgrel = 1
- url = https://mdocml.bsd.lv/
+ url = https://mandoc.bsd.lv
arch = i686
arch = x86_64
+ arch = armv6h
+ arch = armv7h
license = custom: ISC
+ makedepends = cvs
+ makedepends = openssh
depends = zlib
provides = man
conflicts = man
- source = https://mdocml.bsd.lv/snapshots/mandoc-1.14.5.tar.gz
source = configure.local
source = mandoc.service
source = mandoc.timer
- sha256sums = 8219b42cb56fc07b2aa660574e6211ac38eefdbf21f41b698d3348793ba5d8f7
sha256sums = f0e8ddb61d063bec02a6a1f73f5d979bb548e7aabcf0a27c0d5c29c4194bfc8e
sha256sums = 2091411d5f87a3c371a5ba74b4773d1e454046446fa2cb045485979e52419bb6
sha256sums = 74d6a02b97a17fffddcc0a3dc830e811348b1f6c6b84f867882c776d50f00ea4
-pkgname = mandoc
+pkgname = mandoc-cvs
diff --git a/PKGBUILD b/PKGBUILD
index ef96ef63e888..c39b2fb5fca0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,42 +1,58 @@
-# Maintainer: Jakub Klinkovský <j.l.k@gmx.com>
+# Maintainer: Stephen Gregoratto <dev@sgregoratto.me>
+# Contributor: Jakub Klinkovský <j.l.k@gmx.com>
# Contributor: Matheus de Alcantara <matheus.de.alcantara@gmail.com>
-pkgname=mandoc
-pkgver=1.14.5
+pkgname=mandoc-cvs
+pkgver=20190314
pkgrel=1
pkgdesc='A suite of tools compiling mdoc from the OpenBSD project'
-arch=('i686' 'x86_64')
-url='https://mdocml.bsd.lv/'
license=('custom: ISC')
+arch=('i686' 'x86_64' 'armv6h' 'armv7h')
+url='https://mandoc.bsd.lv'
depends=('zlib')
+makedepends=('cvs' 'openssh')
provides=('man')
conflicts=('man')
-source=("https://mdocml.bsd.lv/snapshots/$pkgname-$pkgver.tar.gz"
- 'configure.local'
+source=('configure.local'
'mandoc.service'
'mandoc.timer')
-sha256sums=('8219b42cb56fc07b2aa660574e6211ac38eefdbf21f41b698d3348793ba5d8f7'
- 'f0e8ddb61d063bec02a6a1f73f5d979bb548e7aabcf0a27c0d5c29c4194bfc8e'
+sha256sums=('f0e8ddb61d063bec02a6a1f73f5d979bb548e7aabcf0a27c0d5c29c4194bfc8e'
'2091411d5f87a3c371a5ba74b4773d1e454046446fa2cb045485979e52419bb6'
'74d6a02b97a17fffddcc0a3dc830e811348b1f6c6b84f867882c776d50f00ea4')
prepare() {
- cp "$srcdir"/configure.local $pkgname-$pkgver
+ msg2 "Checking out sources using anonymous CVS over SSH."
+ msg2 "As of 2019-03, the fingerprint of mandoc.bsd.lv is zj94mkQU15j7Hh4YalZHbEO2m4jm2ZVW0cuva+OpKvg."
+ msg2 "Do NOT continue connecting if these do not match."
+ CVS_RSH=ssh cvs -d anoncvs@mandoc.bsd.lv:/cvs checkout -d "$pkgname" -P mandoc
+ cp "${srcdir}/configure.local" $pkgname
+}
+
+pkgver() {
+ cd "$pkgname"
+ # CVS does not save the latest tag/revision of the tree.
+ # The only reliable way to get the latest version is to
+ # use the date of the last modified file.
+ # Exclude the CVS files as they are autogenerated.
+ lmod="$(find "$PWD" -type f -not -path "*CVS*" -exec stat -c '%Y' {} \; | sort -rn | sed 1q)"
+ date -d "@$lmod" "+%Y%m%d"
}
build() {
- cd $pkgname-$pkgver
- ./configure
- make
+ cd $pkgname
+ ./configure
+ make
}
package() {
- cd $pkgname-$pkgver
- DESTDIR="$pkgdir" make install
- install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+ cd $pkgname
+ DESTDIR="$pkgdir" make install
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
- install -Dm644 "$srcdir"/mandoc.timer "$pkgdir"/usr/lib/systemd/system/mandoc.timer
- install -Dm644 "$srcdir"/mandoc.service "$pkgdir"/usr/lib/systemd/system/mandoc.service
- install -dm755 "$pkgdir"/usr/lib/systemd/system/multi-user.target.wants
- ln -s ../mandoc.timer "$pkgdir"/usr/lib/systemd/system/multi-user.target.wants/mandoc.timer
+ install -Dm644 "$srcdir"/mandoc.timer "$pkgdir"/usr/lib/systemd/system/mandoc.timer
+ install -Dm644 "$srcdir"/mandoc.service "$pkgdir"/usr/lib/systemd/system/mandoc.service
+ install -dm755 "$pkgdir"/usr/lib/systemd/system/multi-user.target.wants
+ ln -s ../mandoc.timer "$pkgdir"/usr/lib/systemd/system/multi-user.target.wants/mandoc.timer
}
+
+# vim: tw=0