summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO46
-rw-r--r--PKGBUILD57
-rw-r--r--mapnik.install11
3 files changed, 114 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8edb9c37b3d5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,46 @@
+pkgbase = mapnik-git
+ pkgdesc = Free Toolkit for developing mapping applications. Above all Mapnik is about rendering beautiful maps (git version)
+ pkgver = 3.0.0.rc1.105.g569a539
+ pkgrel = 1
+ url = http://mapnik.org/
+ install = mapnik.install
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = scons
+ makedepends = boost
+ makedepends = git
+ depends = boost-libs
+ depends = icu
+ depends = libpng
+ depends = libjpeg
+ depends = libtiff
+ depends = freetype2
+ depends = libxml2
+ depends = python2
+ depends = proj
+ depends = cairo
+ depends = cairomm
+ depends = pycairo
+ depends = postgresql-libs
+ depends = postgis
+ depends = gdal
+ depends = curl
+ depends = libltdl
+ depends = libwebp
+ optdepends = libxslt: Web Map Service
+ optdepends = python2-lxml: Web Map Service
+ optdepends = python2-pillow: Web Map Service
+ optdepends = python-nose: Web Map Service
+ optdepends = apache: Web Map Service
+ optdepends = mod_fastcgi: Web Map Service - or:
+ optdepends = mod_fcgid: Web Map Service - or:
+ optdepends = mod_wsgi2: Web Map Service
+ provides = mapnik=3.0.0
+ conflicts = mapnik
+ options = staticlibs
+ source = git://github.com/mapnik/mapnik.git
+ md5sums = SKIP
+
+pkgname = mapnik-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9effdbff0e53
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,57 @@
+# $Id$
+# Maintainer: Balló György <ballogyor+arch at gmail dot com>
+# Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Contributor: David Dent <thewinch@gmail.com>
+# Contributor: orbisvicis <orbisvicis@gmail.com>
+
+pkgname=mapnik-git
+_pkgname=mapnik
+pkgver=3.0.0.rc1.105.g569a539
+pkgrel=1
+pkgdesc="Free Toolkit for developing mapping applications. Above all Mapnik is about rendering beautiful maps (git version)"
+arch=('i686' 'x86_64')
+url="http://mapnik.org/"
+license=('LGPL')
+depends=('boost-libs' 'icu' 'libpng' 'libjpeg' 'libtiff' 'freetype2'
+ 'libxml2' 'python2' 'proj' 'cairo' 'cairomm' 'pycairo'
+ 'postgresql-libs' 'postgis' 'gdal' 'curl' 'libltdl' 'libwebp')
+optdepends=('libxslt: Web Map Service'
+ 'python2-lxml: Web Map Service'
+ 'python2-pillow: Web Map Service'
+ 'python-nose: Web Map Service'
+ 'apache: Web Map Service'
+ 'mod_fastcgi: Web Map Service - or:'
+ 'mod_fcgid: Web Map Service - or:'
+ 'mod_wsgi2: Web Map Service')
+makedepends=('scons' 'boost' 'git')
+conflicts=('mapnik')
+provides=('mapnik=3.0.0')
+options=(staticlibs)
+install="mapnik.install"
+source=("git://github.com/mapnik/mapnik.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+
+ git describe --long | cut -c2- | sed 's/-/./g'
+}
+
+build() {
+ cd "$srcdir/$_pkgname"
+
+ sed -i 's|lib64|lib|g' SConstruct
+ sed -i 's|python|python2|' \
+ utils/performance/mapnik-speed-check \
+ utils/upgrade_map_xml/*.py
+ scons configure \
+ PREFIX="/usr" \
+ INPUT_PLUGINS=all \
+ DESTDIR="$pkgdir"
+ scons $MAKEFLAGS
+}
+
+package(){
+ cd "$srcdir/$_pkgname"
+ scons install
+}
diff --git a/mapnik.install b/mapnik.install
new file mode 100644
index 000000000000..46f265d5b51f
--- /dev/null
+++ b/mapnik.install
@@ -0,0 +1,11 @@
+post_install() {
+ /sbin/ldconfig
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}