summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD19
-rw-r--r--mapnik-use-system-sparsehash.patch13
3 files changed, 31 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6ad59aa6c212..3a3edf7adf6c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mapnik-git
pkgdesc = Free Toolkit for developing mapping applications. Above all Mapnik is about rendering beautiful maps (git version)
pkgver = 4.0.0.r13808.g2e1b325
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/mapnik/mapnik
arch = i686
arch = x86_64
@@ -12,6 +12,7 @@ pkgbase = mapnik-git
makedepends = mapbox-geometry.hpp
makedepends = mapbox-polylabel
makedepends = mapbox-variant
+ makedepends = sparsehash
depends = boost-libs
depends = cairo
depends = freetype2
@@ -33,9 +34,11 @@ pkgbase = mapnik-git
conflicts = mapnik
source = git+https://github.com/mapnik/mapnik.git
source = mapnik-datasource-ogr-test.patch
+ source = mapnik-use-system-sparsehash.patch
source = git+https://github.com/mapnik/test-data.git
sha256sums = SKIP
sha256sums = 3fcf178e646df526e9a5c278f56ad16e4f75d2f27108e7b33419649a46b92f52
+ sha256sums = dabb1b99540a6df86b34511d0d94ef505f706419b7e6d1d69314797ebcdce72f
sha256sums = SKIP
pkgname = mapnik-git
diff --git a/PKGBUILD b/PKGBUILD
index 30aa427e9c75..cdd3a05ff819 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgname=mapnik-git
pkgver=4.0.0.r13808.g2e1b325
-pkgrel=2
+pkgrel=3
pkgdesc='Free Toolkit for developing mapping applications. Above all Mapnik is about rendering beautiful maps (git version)'
arch=('i686' 'x86_64')
url='https://github.com/mapnik/mapnik'
@@ -34,14 +34,17 @@ makedepends=('boost'
'git'
'mapbox-geometry.hpp'
'mapbox-polylabel'
- 'mapbox-variant')
+ 'mapbox-variant'
+ 'sparsehash')
conflicts=('mapnik')
provides=('mapnik')
source=('git+https://github.com/mapnik/mapnik.git'
'mapnik-datasource-ogr-test.patch'
+ 'mapnik-use-system-sparsehash.patch'
'git+https://github.com/mapnik/test-data.git')
sha256sums=('SKIP'
'3fcf178e646df526e9a5c278f56ad16e4f75d2f27108e7b33419649a46b92f52'
+ 'dabb1b99540a6df86b34511d0d94ef505f706419b7e6d1d69314797ebcdce72f'
'SKIP')
pkgver() {
@@ -52,6 +55,7 @@ pkgver() {
prepare() {
cd mapnik || exit
patch -Np1 < ../mapnik-datasource-ogr-test.patch
+ patch -Np1 < ../mapnik-use-system-sparsehash.patch
git submodule init \
test/data
git config submodule.test/data.url "$srcdir"/test-data
@@ -61,6 +65,8 @@ prepare() {
build() {
cmake -B mapnik_build -S mapnik \
+ -DBUILD_BENCHMARK:BOOL=OFF \
+ -DBUILD_DEMO_CPP:BOOL=OFF \
-DBUILD_DEMO_VIEWER:BOOL=OFF \
-DCMAKE_BUILD_TYPE:STRING=Release \
-DCMAKE_INSTALL_PREFIX:PATH=/usr \
@@ -77,11 +83,14 @@ check() {
}
package(){
+ # Remove bundled dejavu fonts from cmake_install.cmake in favor of 'ttf-dejavu' package
+ sed -i '/dejavu-fonts-ttf-2.37/d' "$srcdir"/mapnik_build/cmake_install.cmake
+
+ # Remove bundled sparsehash directory in favor of 'sparsehash' package
+ rm -rf "$srcdir"/mapnik/deps/mapnik/sparsehash
+
DESTDIR="$pkgdir" cmake --install mapnik_build --strip
# License
install -Dm644 "$srcdir"/mapnik/COPYING "$pkgdir"/usr/share/licenses/"$pkgname"/LICENSE
-
- # Remove bundled fonts in favor of those from 'ttf-dejavu'
- rm -rf "$pkgdir"/usr/share/fonts
}
diff --git a/mapnik-use-system-sparsehash.patch b/mapnik-use-system-sparsehash.patch
new file mode 100644
index 000000000000..647e304745e3
--- /dev/null
+++ b/mapnik-use-system-sparsehash.patch
@@ -0,0 +1,13 @@
+diff --git a/include/mapnik/palette.hpp b/include/mapnik/palette.hpp
+index 0a0216041..dda682020 100644
+--- a/include/mapnik/palette.hpp
++++ b/include/mapnik/palette.hpp
+@@ -34,7 +34,7 @@
+ MAPNIK_DISABLE_WARNING_PUSH
+ #include <mapnik/warning_ignore.hpp>
+ #ifdef USE_DENSE_HASH_MAP
+-#include <mapnik/sparsehash/dense_hash_map>
++#include <google/dense_hash_map>
+ using rgba_hash_table = google::dense_hash_map<unsigned int, unsigned char>;
+ #else
+ #include <unordered_map>