summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-x[-rw-r--r--].SRCINFO15
-rwxr-xr-x[-rw-r--r--]PKGBUILD60
-rw-r--r--cmake-3.12.patch73
3 files changed, 33 insertions, 115 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c931a277683e..4b81f8c73d7f 100644..100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mapserver
pkgdesc = Platform for publishing spatial data and interactive mapping applications to the web
- pkgver = 7.2.1
- pkgrel = 2
+ pkgver = 8.0.1
+ pkgrel = 1
url = http://www.mapserver.org
arch = i686
arch = x86_64
@@ -19,16 +19,13 @@ pkgbase = mapserver
depends = geos
depends = agg
depends = apache
+ depends = protobuf-c
depends = fcgi
depends = mod_fcgid
- depends = python2
- depends = swig
+ depends = python
depends = libsvg-cairo
depends = fribidi
- source = http://download.osgeo.org/mapserver/mapserver-7.2.1.tar.gz
- source = cmake-3.12.patch
- md5sums = 03cd2532df9def0011c2f586e2e615fd
- md5sums = 4f336526a3a0b20ef784d8c8c88e38df
+ source = http://download.osgeo.org/mapserver/mapserver-8.0.1.tar.gz
+ md5sums = c85b9b734471da431958b6331aae0803
pkgname = mapserver
-
diff --git a/PKGBUILD b/PKGBUILD
index 2f181f90035b..b2f4942639bb 100644..100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,29 +3,22 @@
# Original Maintainer:: Jonathan Hudson <jh+arch@daria.co.uk>
pkgname=mapserver
-pkgver=7.2.1
-pkgrel=2
+pkgver=8.0.1
+pkgrel=1
pkgdesc="Platform for publishing spatial data and interactive mapping applications to the web"
arch=(i686 x86_64)
license=('MIT')
url="http://www.mapserver.org"
-depends=('libpng' 'freetype2' 'zlib' 'gdal' 'proj' 'libjpeg-turbo' 'libxml2' 'libpqxx' 'pdflib-lite' 'geos' 'agg' 'apache'
-'fcgi' 'mod_fcgid' 'python2' 'swig' 'libsvg-cairo' 'fribidi' )
+depends=('libpng' 'freetype2' 'zlib' 'gdal' 'proj' 'libjpeg-turbo' 'libxml2' 'libpqxx' 'pdflib-lite' 'geos' 'agg' 'apache' 'protobuf-c'
+'fcgi' 'mod_fcgid' 'python' 'libsvg-cairo' 'fribidi' )
## For v8 support require v8-3.20; for PHP mapscript require php, php-pear, php-apache
makedepends=('cfitsio')
options=()
-source=("http://download.osgeo.org/mapserver/mapserver-${pkgver}.tar.gz" cmake-3.12.patch)
-md5sums=('03cd2532df9def0011c2f586e2e615fd'
- '4f336526a3a0b20ef784d8c8c88e38df')
-
-prepare() {
- cd ${startdir}/src/${pkgname}-${pkgver}
-
- patch -p1 < ../cmake-3.12.patch
-}
+source=("http://download.osgeo.org/mapserver/mapserver-${pkgver}.tar.gz")
+md5sums=('c85b9b734471da431958b6331aae0803')
build() {
- cd ${startdir}/src/${pkgname}-${pkgver}
+ cd ${srcdir}/${pkgname}-${pkgver}
if [ -f CMakeCache.txt ]
then
@@ -33,27 +26,28 @@ build() {
fi
rm -rf build && mkdir build
cd build
-
+
+ ## Compile with python
+ ## -DPYTHON_LIBRARIES=/usr/lib/python2.7 \
+ ## -DPYTHON_INCLUDE_PATH=/usr/include/python2.7 \
+
cmake .. \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib \
- -DPYTHON_EXECUTABLE=/usr/bin/python2 \
- -DPYTHON_LIBRARIES=/usr/lib/python2.7 \
- -DPYTHON_INCLUDE_PATH=/usr/include/python2.7 \
- -DFRIBIDI_INCLUDE_DIR="/usr/include/glib-2.0;/usr/lib/glib-2.0/include;/usr/include/fribidi" \
- -DCMAKE_PREFIX_PATH=/opt/v8 \
- -DWITH_CAIRO=ON \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DFRIBIDI_INCLUDE_DIR="/usr/include/glib-2.0;/usr/lib/glib-2.0/include;/usr/include/fribidi" \
+ -DCMAKE_PREFIX_PATH=/opt/v8 \
+ -DWITH_CAIRO=ON \
-DWITH_CLIENT_WFS=ON \
+ -DWITH_OGCAPI=ON \
-DWITH_CLIENT_WMS=ON \
-DWITH_CSHARP=OFF \
-DWITH_CURL=ON \
-DWITH_EXEMPI=OFF \
-DWITH_FCGI=ON \
-DWITH_FRIBIDI=ON \
- -DWITH_GDAL=ON \
-DWITH_GENERIC_NINT=OFF \
-DWITH_GEOS=ON \
- -DWITH_GIF=OFF \
+ -DWITH_GIF=ON \
-DWITH_ICONV=ON \
-DWITH_JAVA=OFF \
-DWITH_KML=ON \
@@ -61,14 +55,11 @@ build() {
-DWITH_LIBXML2=ON \
-DWITH_MSSQL2008=OFF \
-DWITH_MYSQL=OFF \
- -DWITH_OGR=ON \
-DWITH_ORACLESPATIAL=OFF \
-DWITH_ORACLE_PLUGIN=OFF \
-DWITH_PERL=OFF \
- -DWITH_PHP=OFF \
- -DWITH_POINT_Z_M=ON \
-DWITH_POSTGIS=ON \
- -DWITH_PROJ=ON \
+ -DWITH_GIF=ON \
-DWITH_PYTHON=ON \
-DWITH_RSVG=OFF \
-DWITH_RUBY=OFF \
@@ -81,9 +72,8 @@ build() {
-DWITH_XMLMAPFILE=OFF \
-DFREETYPE_INCLUDE_DIR=/usr/include/freetype2 \
- make clean
- make -j2
-
+ make clean
+ make -j$(nproc)
}
package() {
@@ -94,7 +84,11 @@ package() {
make DESTDIR=${pkgdir} install
#Copy the headers a include for ZooWPS project
- install -d "$pkgdir"/usr/include/mapserver
+ install -d "$pkgdir"/usr/include/mapserver
+ install -d "$pkgdir"/usr/share/mapserver
+ install -d "$pkgdir"/opt/mapserver/test/
install -Dm644 "${srcdir}/${pkgname}-${pkgver}"/build/*.h "$pkgdir"/usr/include/mapserver/
install -Dm644 "${srcdir}/${pkgname}-${pkgver}"/*.h "$pkgdir"/usr/include/mapserver/
+ cp -rfv "${srcdir}/${pkgname}-${pkgver}"/share/ogcapi "$pkgdir"/usr/share/mapserver
+ cp -rfv "${srcdir}/${pkgname}-${pkgver}"/tests/* "$pkgdir"/opt/mapserver/test
}
diff --git a/cmake-3.12.patch b/cmake-3.12.patch
deleted file mode 100644
index 7f139ded4a6b..000000000000
--- a/cmake-3.12.patch
+++ /dev/null
@@ -1,73 +0,0 @@
-Description: Fix errors with CMake 3.12 for get_target_property commands.
-Author: Bas Couwenberg <sebastic@debian.org>
-Bug: https://github.com/mapserver/mapserver/issues/5646
-Bug-Debian: https://bugs.debian.org/906605
-
---- a/mapscript/java/CMakeLists.txt
-+++ b/mapscript/java/CMakeLists.txt
-@@ -42,6 +42,14 @@ ADD_CUSTOM_COMMAND(TARGET javamapscript
- COMMENT "Compiling java source files, creating mapscript.jar"
- )
-
-+# Workaround for CMake 3.12 error:
-+#
-+# The LOCATION property may not be read from target "foo". Use
-+# the target name directly with add_custom_command, or use the generator
-+# expression $<TARGET_FILE>, as appropriate.
-+
-+cmake_policy(SET CMP0026 OLD)
-+
- get_target_property(LOC_MAPSCRIPT_LIB ${SWIG_MODULE_javamapscript_REAL_NAME} LOCATION)
- install(FILES ${LOC_MAPSCRIPT_LIB} DESTINATION lib/jni)
- install(FILES ${CMAKE_CURRENT_BINARY_DIR}/mapscript.jar DESTINATION share/java)
---- a/mapscript/perl/CMakeLists.txt
-+++ b/mapscript/perl/CMakeLists.txt
-@@ -18,6 +18,14 @@ if(APPLE)
- set_target_properties(perlmapscript PROPERTIES SUFFIX ".bundle")
- endif(APPLE)
-
-+# Workaround for CMake 3.12 error:
-+#
-+# The LOCATION property may not be read from target "foo". Use
-+# the target name directly with add_custom_command, or use the generator
-+# expression $<TARGET_FILE>, as appropriate.
-+
-+cmake_policy(SET CMP0026 OLD)
-+
- get_target_property(LOC_MAPSCRIPT_LIB ${SWIG_MODULE_perlmapscript_REAL_NAME} LOCATION)
- set(mapscript_files ${LOC_MAPSCRIPT_LIB} ${CMAKE_CURRENT_BINARY_DIR}/mapscript.pm)
- install(FILES ${LOC_MAPSCRIPT_LIB} DESTINATION ${CUSTOM_PERL_VENDOR_ARCH_DIR}/auto/mapscript)
---- a/mapscript/python/CMakeLists.txt
-+++ b/mapscript/python/CMakeLists.txt
-@@ -39,6 +39,14 @@ set_target_properties(${SWIG_MODULE_pyth
-
- execute_process ( COMMAND ${PYTHON_EXECUTABLE} -c "from distutils.sysconfig import get_python_lib; print(get_python_lib(True))" OUTPUT_VARIABLE PYTHON_SITE_PACKAGES OUTPUT_STRIP_TRAILING_WHITESPACE)
-
-+# Workaround for CMake 3.12 error:
-+#
-+# The LOCATION property may not be read from target "foo". Use
-+# the target name directly with add_custom_command, or use the generator
-+# expression $<TARGET_FILE>, as appropriate.
-+
-+cmake_policy(SET CMP0026 OLD)
-+
- get_target_property(LOC_MAPSCRIPT_LIB ${SWIG_MODULE_pythonmapscript_REAL_NAME} LOCATION)
- set(mapscript_files ${LOC_MAPSCRIPT_LIB} ${CMAKE_CURRENT_BINARY_DIR}/mapscript.py)
- install(FILES ${mapscript_files} DESTINATION ${PYTHON_SITE_PACKAGES})
---- a/mapscript/ruby/CMakeLists.txt
-+++ b/mapscript/ruby/CMakeLists.txt
-@@ -32,6 +32,14 @@ if(APPLE)
- set_target_properties(${SWIG_MODULE_rubymapscript_REAL_NAME} PROPERTIES SUFFIX ".bundle")
- endif(APPLE)
-
-+# Workaround for CMake 3.12 error:
-+#
-+# The LOCATION property may not be read from target "foo". Use
-+# the target name directly with add_custom_command, or use the generator
-+# expression $<TARGET_FILE>, as appropriate.
-+
-+cmake_policy(SET CMP0026 OLD)
-+
- get_target_property(LOC_MAPSCRIPT_LIB ${SWIG_MODULE_rubymapscript_REAL_NAME} LOCATION)
- execute_process(COMMAND ${RUBY_EXECUTABLE} -r rbconfig -e "puts RbConfig::CONFIG['vendorarchdir']" OUTPUT_VARIABLE RUBY_VENDORARCHDIR OUTPUT_STRIP_TRAILING_WHITESPACE)
- install(FILES ${LOC_MAPSCRIPT_LIB} DESTINATION ${RUBY_VENDORARCHDIR})