summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD12
-rwxr-xr-x[-rw-r--r--]marionnet_from_scratch-Downloader24
3 files changed, 22 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e70c42426338..e258544db7c9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,6 +7,8 @@ pkgbase = marionnet
arch = i686
arch = x86_64
license = LGPL
+ makedepends = wget
+ makedepends = bc
makedepends = optipng
depends = xorg-server
depends = xorg-xinit
@@ -32,7 +34,7 @@ pkgbase = marionnet
sha256sums = 39cc4cc100124b8363c9760494d7e285803ca22ff8409f79038f3fb4a146a96c
sha256sums = 3a571a2cb4724b50eb52e33191d42a6b8396889e728bc974bc396395c9ce03ac
sha256sums = 1fd697ff5f7055bcd6da2b6b5233d58bf79a2d4fc59b36eb79fb3c0d63265d3c
- sha256sums = 5d8ddf6e5c5b726e892bae2b55eb5eb01f43bd47fa2855ec38797d0598a6ea24
+ sha256sums = f0f93f30424da231357c3d7698229ba1fbdaa41737c954b71ede44d5e57cd50a
pkgname = marionnet
diff --git a/PKGBUILD b/PKGBUILD
index b8a9be776e77..8e8ace7da970 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@ users to define, configure and run complex computer networks without any need
for physical setup. Very old version."
arch=('i686' 'x86_64')
url="https://www.marionnet.org/"
-makedepends=('bc' 'optipng')
+makedepends=('wget' 'bc' 'optipng')
license=('LGPL')
depends=('xorg-server' 'xorg-xinit' 'xorg-server-utils' 'gtksourceview2' 'libglademm' 'graphviz' 'xterm' 'vde2' 'uml_utilities' 'net-tools' 'bridge-utils')
if test "$CARCH" == x86_64; then
@@ -29,7 +29,7 @@ sha256sums=('83008744c0ba1e3460651b86d0900916edae38813eb9a0300e8eaa861c3e921e'
'39cc4cc100124b8363c9760494d7e285803ca22ff8409f79038f3fb4a146a96c'
'3a571a2cb4724b50eb52e33191d42a6b8396889e728bc974bc396395c9ce03ac'
'1fd697ff5f7055bcd6da2b6b5233d58bf79a2d4fc59b36eb79fb3c0d63265d3c'
- '5d8ddf6e5c5b726e892bae2b55eb5eb01f43bd47fa2855ec38797d0598a6ea24')
+ 'f0f93f30424da231357c3d7698229ba1fbdaa41737c954b71ede44d5e57cd50a')
install=marionnet-legacy.install
# ################
@@ -75,8 +75,8 @@ build () {
if type uname 1>&2 && [[ $(uname -m) = "${CARCH}" ]]; then
local BUGFIX_FILE="bugfix-5237.diff"
echo "Downloading the ocaml 3.11 patch ($BUGFIX_FILE) for ${CARCH}"
- curl -L -o $BUGFIX_FILE "$OUR_MIRROR/$BUGFIX_FILE" || \
- curl -L -o $BUGFIX_FILE 'http://caml.inria.fr/mantis/file_download.php?file_id=415&type=bug' || \
+ wget --no-check-certificate -O $BUGFIX_FILE "$OUR_MIRROR/$BUGFIX_FILE" || \
+ wget --no-check-certificate -O $BUGFIX_FILE 'http://caml.inria.fr/mantis/file_download.php?file_id=415&type=bug' || \
return 1
echo "Applying the ocaml 3.11 patch ($BUGFIX_FILE) for ${CARCH}"
patch -p1 < $BUGFIX_FILE
@@ -85,8 +85,8 @@ build () {
elif type ld 1>&2 && ld -v | \grep -q '[ ]2[.]2[1-9]'; then
local BUGFIX_FILE="bugfix-5237-i386.diff"
echo "Downloading the ocaml 3.11 patch ($BUGFIX_FILE) for i386"
- curl -L -o $BUGFIX_FILE "$OUR_MIRROR/$BUGFIX_FILE" || \
- curl -L -o $BUGFIX_FILE 'http://caml.inria.fr/mantis/file_download.php?file_id=418&type=bug' || \
+ wget --no-check-certificate -O $BUGFIX_FILE "$OUR_MIRROR/$BUGFIX_FILE" || \
+ wget -O $BUGFIX_FILE 'http://caml.inria.fr/mantis/file_download.php?file_id=418&type=bug' || \
return 1
echo "Applying the ocaml 3.11 patch ($BUGFIX_FILE) for i386"
patch -p1 < $BUGFIX_FILE
diff --git a/marionnet_from_scratch-Downloader b/marionnet_from_scratch-Downloader
index c363d74d3ab1..9e92d34b0630 100644..100755
--- a/marionnet_from_scratch-Downloader
+++ b/marionnet_from_scratch-Downloader
@@ -52,9 +52,8 @@ trap_custom
# @todo
-# FOR UPDATE THIS SCRIPT, PLEASE MAINTAINS TUNNING SECTION
-# FOR UPDATE THIS SCRIPT, PLEASE MAINTAINS TUNNING SECTION
-# FOR UPDATE THIS SCRIPT, PLEASE MAINTAINS TUNNING SECTION
+# sha256sums (ask to Lodo to but them onto this webpage) + calculate weight with
+# http headers + use dictionnary with weight URL and weight
# =============================================================
# PARSING COMMAND LINE {{{1
@@ -316,11 +315,14 @@ fi 1>&2
# FUNCTIONS FOR DOWNLOAD OUR KERNELS AND FILESYSTEMS {{{1
# =============================================================
+# Support https:
+alias wget='wget --no-check-certificate'
+
function download_our_kernels {
# global $OUR_BASE_URL
# parameters : file-weight $1
local KERNELS
-KERNELS=$(curl -L --silent --show-error "$OUR_BASE_URL" \
+KERNELS=$(wget -O - "$OUR_BASE_URL" \
| grep -o 'href="kernels_[^"]*"' \
| grep -o "kernels_[^\"]*[.]tar[.]gz"\
)
@@ -346,7 +348,7 @@ function download_our_big_filesystems {
# global $OUR_BASE_URL
# parameters : file-weight $1
local FILESYSTEMS
-FILESYSTEMS=$(curl -L --silent --show-error "$OUR_BASE_URL" \
+FILESYSTEMS=$(wget -O - "$OUR_BASE_URL" \
| grep -o 'href="filesystems_[^"]*"' \
| grep -o "filesystems_[^\"]*[.]tar[.]gz"\
| grep -v "filesystems_pinocchio.*[.]tar[.]gz"\
@@ -366,7 +368,7 @@ function download_our_pinocchio_filesystems {
# global $OUR_BASE_URL
# parameters : file-weight $1
local KERNELS
-KERNELS=$(curl -L --silent --show-error "$OUR_BASE_URL" \
+KERNELS=$(wget -O - "$OUR_BASE_URL" \
| grep -o 'href="kernels_[^"]*"' \
| grep -o "kernels_[^\"]*[.]tar[.]gz"\
)
@@ -380,7 +382,7 @@ function download_our_v1_kernels {
# global $OUR_TRUNK_SPECIFIC_URL
# parameters : file-weight $1
local KERNELS
-KERNELS=$(curl -L --silent --show-error "$OUR_TRUNK_SPECIFIC_URL" \
+KERNELS=$(wget -O - "$OUR_TRUNK_SPECIFIC_URL" \
| grep -o 'href="kernels_[^"]*"' \
| grep -o "kernels_[^\"]*[.]tar[.]gz"\
)
@@ -394,7 +396,7 @@ function download_our_v1_tiny_filesystems {
# global $OUR_TRUNK_SPECIFIC_URL
# parameters : file-weight $1
local FILESYSTEMS
-FILESYSTEMS=$(curl -L --silent --show-error "$OUR_TRUNK_SPECIFIC_URL" \
+FILESYSTEMS=$(wget -O - "$OUR_TRUNK_SPECIFIC_URL" \
| grep -o 'href="filesystems_guignol[^"]*"' \
| grep -o "filesystems_[^\"]*[.]tar[.]gz"\
)
@@ -408,7 +410,7 @@ function download_our_v1_big_filesystems {
# global $OUR_TRUNK_SPECIFIC_URL
# parameters : file-weight $1
local FILESYSTEMS
-FILESYSTEMS=$(curl -L --silent --show-error "$OUR_TRUNK_SPECIFIC_URL" \
+FILESYSTEMS=$(wget -O - "$OUR_TRUNK_SPECIFIC_URL" \
| grep -o 'href="filesystems_[^"]*"' \
| grep -o "filesystems_[^\"]*[.]tar[.]gz"\
| grep -v "filesystems_guignol.*[.]tar[.]gz"\
@@ -427,12 +429,12 @@ local restPerCent=$(echo "scale=2;$rest/$total_weight*100"|bc)
echo -e "We are going to download $3 Mo ($currentPercentDownloading% of the $total_weight Mo). \
After this stage this is still $rest Mo to download (or \
$restPerCent%) "
-curl -L -O -C - $1 # -C - => resume download if any ; -L => follow redirections
+wget --continue $1 # -C - => resume download if any ; -L => follow redirections
# @todo sha256sums
echo "Decompressing : "
# tar -xvf ${2}
rm -f ${2}
-echo -e "Success…\n\n\n———"
+echo -e "Success…\n———"
}