summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD8
2 files changed, 9 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1eba8ef5cdaa..150d4ab65a1f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = markdown-to-standalone-html
pkgdesc = Create a standalone HTML file from Markdown with basic CSS, table of contents and source code highlighting
- pkgver = 0.4.3
+ pkgver = 0.5.0
pkgrel = 1
url = https://github.com/EdJoPaTo/markdown-to-standalone-html
arch = x86_64
@@ -12,8 +12,7 @@ pkgbase = markdown-to-standalone-html
optdepends = monolith: inline assets like images or CSS
provides = markdown-to-standalone-html
conflicts = markdown-to-standalone-html
- source = markdown-to-standalone-html-0.4.3.tar.gz::https://github.com/EdJoPaTo/markdown-to-standalone-html/archive/v0.4.3.tar.gz
- sha256sums = 4f977febc28558f913cab7f4971be14a2d9c442f89a5e0778b9e4f1d2a80967c
+ source = markdown-to-standalone-html-0.5.0.tar.gz::https://github.com/EdJoPaTo/markdown-to-standalone-html/archive/v0.5.0.tar.gz
+ sha256sums = d65f119ac4db6294f5ee5d124b621d868457ec69874cbe42fcc2d72ad23c6ac0
pkgname = markdown-to-standalone-html
-
diff --git a/PKGBUILD b/PKGBUILD
index 25993ca771a1..3881debbf8ae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=markdown-to-standalone-html
-pkgver=0.4.3
+pkgver=0.5.0
pkgrel=1
pkgdesc="Create a standalone HTML file from Markdown with basic CSS, table of contents and source code highlighting"
arch=('x86_64' 'aarch64' 'armv6h' 'armv7h')
@@ -12,7 +12,7 @@ provides=("markdown-to-standalone-html")
conflicts=("markdown-to-standalone-html")
source=($pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz)
-sha256sums=('4f977febc28558f913cab7f4971be14a2d9c442f89a5e0778b9e4f1d2a80967c')
+sha256sums=('d65f119ac4db6294f5ee5d124b621d868457ec69874cbe42fcc2d72ad23c6ac0')
build() {
cd $pkgname-$pkgver
@@ -24,4 +24,8 @@ package() {
install -Dm 755 target/release/$pkgname -t "$pkgdir"/usr/bin
install -Dm 644 README.md -t "$pkgdir"/usr/share/doc/$pkgname
install -Dm 644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname
+
+ install -Dm644 "completions/${pkgname}.bash" "${pkgdir}/usr/share/bash-completion/completions/${pkgname}.bash"
+ install -Dm644 "completions/${pkgname}.fish" "${pkgdir}/usr/share/fish/vendor_completions.d/${pkgname}.fish"
+ install -Dm644 "completions/_${pkgname}" "${pkgdir}/usr/share/zsh/site-functions/_${pkgname}"
}