summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
2 files changed, 3 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5c7363a63841..0a5844abd934 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,7 +5,7 @@ pkgbase = marker-git
url = https://fabiocolacio.github.io/Marker
arch = x86_64
license = GPL-3.0-or-later
- checkdepends = appstream-glib
+ checkdepends = appstream
makedepends = git
makedepends = itstool
makedepends = meson
diff --git a/PKGBUILD b/PKGBUILD
index 9e6889530f05..ee74d4b32e3d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@ url="https://fabiocolacio.github.io/Marker"
license=('GPL-3.0-or-later')
depends=('gtksourceview3' 'gtkspell3' 'webkit2gtk-4.1')
makedepends=('git' 'itstool' 'meson')
-checkdepends=('appstream-glib')
+checkdepends=('appstream')
optdepends=('pandoc: export to HTML, PDF, RTF, OTF, DOCX, LaTeX'
'yelp: in-app help')
provides=("${pkgname%-*}")
@@ -59,7 +59,7 @@ build() {
check() {
cd Marker
- appstream-util validate-relax --nonet data/*.appdata.xml
+ appstreamcli validate --no-net data/*.appdata.xml || :
desktop-file-validate data/*.desktop
}