summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD28
-rw-r--r--marytts.sh1
3 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6c7e5a45fb58
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = marytts
+ pkgdesc = An open-source, multilingual Text-to-Speech Synthesis platform written in Java
+ pkgver = 5.1.2
+ pkgrel = 1
+ url = http://mary.dfki.de/
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ depends = java-runtime
+ depends = log4j
+ source = https://github.com/marytts/marytts/releases/download/v5.1.2/marytts-5.1.2.zip
+ source = marytts.sh
+ md5sums = 99e774dd4c6e791ad916ae76351522f0
+ md5sums = 78f9ee795d5a14d27ae6d5a6b2b507c3
+
+pkgname = marytts
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..37f7995194dc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: M0Rf30
+pkgname=marytts
+pkgver=5.1.2
+pkgrel=1
+pkgdesc="An open-source, multilingual Text-to-Speech Synthesis platform written in Java"
+arch=('i686' 'x86_64')
+url="http://mary.dfki.de/"
+license=('LGPL')
+depends=('java-runtime' 'log4j')
+source=("https://github.com/marytts/marytts/releases/download/v$pkgver/$pkgname-$pkgver.zip"
+ marytts.sh)
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ install -dm755 ${pkgdir}/opt/${pkgname}/log
+ touch ${pkgdir}/opt/${pkgname}/log/server.log
+ chmod 777 ${pkgdir}/opt/${pkgname}/log/server.log
+ cp -r * ${pkgdir}/opt/${pkgname}
+ rm ${pkgdir}/opt/${pkgname}/bin/*.bat
+ install -dm755 ${pkgdir}/etc/profile.d
+ install -m755 "${srcdir}"/${pkgname}.sh ${pkgdir}/etc/profile.d/
+
+}
+
+md5sums=('c7e74cec8b16a3046a37407e267c036a'
+ '78f9ee795d5a14d27ae6d5a6b2b507c3')
+md5sums=('99e774dd4c6e791ad916ae76351522f0'
+ '78f9ee795d5a14d27ae6d5a6b2b507c3')
diff --git a/marytts.sh b/marytts.sh
new file mode 100644
index 000000000000..b24154c96fe9
--- /dev/null
+++ b/marytts.sh
@@ -0,0 +1 @@
+export PATH=$PATH:/opt/marytts/bin