summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD37
-rw-r--r--boost1.67.patch27
3 files changed, 27 insertions, 45 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8834109c730a..b17f82143e0d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = masari
pkgdesc = Masari: cryptonote currency daemon, wallet, and miner
- pkgver = 0.2.4.0
+ pkgver = 0.2.4.3
pkgrel = 1
url = https://github.com/masari-project/masari
arch = x86_64
@@ -21,8 +21,6 @@ pkgbase = masari
optdepends = graphviz
optdepends = ldns
checkdepends = gtest
- source = https://github.com/masari-project/masari/archive/v0.2.4.0.tar.gz
- source = boost1.67.patch
- md5sums = 0842be0b301b068c9cb714f5ce04312c
- md5sums = 499c24532d596d4f94110a0a6e952718
+ source = https://github.com/masari-project/masari/archive/v0.2.4.3.tar.gz
+ md5sums = 5054dc3ff60b0526f9e7f1d3ba28bafd
pkgname = masari
diff --git a/PKGBUILD b/PKGBUILD
index cc1e36cf2521..b4190b5f5479 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,14 @@
# Maintainer: Chris Magyar <c.magyar.ec@gmail.com>
+
pkgname=masari
-pkgver=0.2.4.0
+pkgver=0.2.4.3
+_gituser=masari-project
+_gitrepo=masari
+_gitver=v0.2.4.3
pkgrel=1
pkgdesc="Masari: cryptonote currency daemon and wallet"
arch=('x86_64' 'i686')
-url="https://github.com/masari-project/$pkgname"
+url="https://github.com/$_gituser/$_gitrepo"
license=('custom:Cryptonote')
makedepends=( 'boost' 'cmake' 'git' )
depends=( 'boost-libs' 'libunwind' 'miniupnpc' 'openssl' 'readline'
@@ -14,19 +18,22 @@ optdepends=( 'doxygen: documentation'
'graphviz: documentation'
'ldns: SSL toolkit' )
checkdepends=('gtest')
-source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz"
- 'boost1.67.patch')
-md5sums=('0842be0b301b068c9cb714f5ce04312c'
- '499c24532d596d4f94110a0a6e952718')
-
+source=("$pkgname-$pkgver.tar.gz::$url/archive/$_gitver.tar.gz")
+md5sums=('5054dc3ff60b0526f9e7f1d3ba28bafd')
prepare() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- patch -p1 -i ../boost1.67.patch
+ if [ ! -d "$srcdir/$pkgname-$pkgver" ]; then
+ if [ -d "$srcdir/$_gitrepo-$_gitver" ]; then
+ mv "$srcdir/$_gitrepo-$_gitver" "$srcdir/$pkgname-$pkgver"
+ elif [ -d "$srcdir/$pkgname-$_gitver" ]; then
+ mv "$srcdir/$pkgname-$_gitver" "$srcdir/$pkgname-$pkgver"
+ fi
+ fi
+ cd "$srcdir/$pkgname-$pkgver"
}
build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd "$srcdir/$pkgname-$pkgver"
mkdir build && cd build
CXXFLAGS="-Wno-error=class-memaccess"
cmake ..
@@ -35,20 +42,24 @@ build() {
package() {
cd "${pkgname}-${pkgver}"
+ install -Dm755 "./build/bin/masari-blockchain-blackball" \
+ "${pkgdir}/usr/bin/masari-blockchain-blackball"
install -Dm755 "./build/bin/masari-blockchain-export" \
"${pkgdir}/usr/bin/masari-blockchain-export"
install -Dm755 "./build/bin/masari-blockchain-import" \
"${pkgdir}/usr/bin/masari-blockchain-import"
+ install -Dm755 "./build/bin/masari-blockchain-usage" \
+ "${pkgdir}/usr/bin/masari-blockchain-usage"
+ install -Dm755 "./build/bin/masarid" \
+ "${pkgdir}/usr/bin/masarid"
install -Dm755 "./build/bin/masari-gen-trusted-multisig" \
"${pkgdir}/usr/bin/masari-gen-trusted-multisig"
install -Dm755 "./build/bin/masari-wallet-cli" \
"${pkgdir}/usr/bin/masari-wallet-cli"
install -Dm755 "./build/bin/masari-wallet-rpc" \
"${pkgdir}/usr/bin/masari-wallet-rpc"
- install -Dm755 "./build/bin/masarid" \
- "${pkgdir}/usr/bin/masarid"
install -Dm644 ./utils/conf/masarid.conf \
"${pkgdir}/etc/masarid.conf"
- install -Dm644 LICENSE \
+ install -Dm644 LICENSE \
"${pkgdir}/usr/share/licenses/$pkgname/LICENSE"
}
diff --git a/boost1.67.patch b/boost1.67.patch
deleted file mode 100644
index f13c86639c8c..000000000000
--- a/boost1.67.patch
+++ /dev/null
@@ -1,27 +0,0 @@
---- masari/contrib/epee/include/net/abstract_tcp_server2.inl
-+++ masari/contrib/epee/include/net/abstract_tcp_server2.inl
-@@ -41,7 +41,8 @@
- #include <boost/utility/value_init.hpp>
- #include <boost/asio/deadline_timer.hpp>
- #include <boost/date_time/posix_time/posix_time.hpp> // TODO
--#include <boost/thread/v2/thread.hpp> // TODO
-+#include <boost/thread/thread.hpp> // TODO
-+#include <boost/thread/condition_variable.hpp> // TODO
- #include "misc_language.h"
- #include "pragma_comp_defs.h"
-
---- masari/contrib/epee/include/syncobj.h
-+++ masari/contrib/epee/include/syncobj.h
-@@ -31,10 +31,11 @@
- #define __WINH_OBJ_H__
-
- #include <boost/chrono/duration.hpp>
-+#include <boost/thread/condition_variable.hpp>
- #include <boost/thread/locks.hpp>
- #include <boost/thread/mutex.hpp>
- #include <boost/thread/recursive_mutex.hpp>
--#include <boost/thread/v2/thread.hpp>
-+#include <boost/thread/thread.hpp>
-
- namespace epee
- {