summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--CMakeLists.txt.patch8
-rw-r--r--PKGBUILD18
-rw-r--r--boost.patch10
4 files changed, 24 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4d9a6cb515e3..d77bb8c0a1ea 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = masari
pkgdesc = Masari: cryptonote currency daemon, wallet, and miner
- pkgver = 0.3.0.0
+ pkgver = 0.3.1.2
pkgrel = 1
url = https://github.com/masari-project/masari
arch = x86_64
@@ -8,7 +8,9 @@ pkgbase = masari
makedepends = boost
makedepends = cmake
makedepends = git
+ makedepends = openssl
depends = boost-libs
+ depends = libsodium
depends = libunwind
depends = miniupnpc
depends = openssl
@@ -19,8 +21,8 @@ pkgbase = masari
optdepends = expat
optdepends = graphviz
optdepends = ldns
- source = https://github.com/masari-project/masari/archive/v0.3.0.0.tar.gz
- source = boost.patch
- md5sums = 7efd2602db7862b34264e105a8182edd
- md5sums = 5f84a2b83dd85e4e791b93dbb8b703eb
+ source = https://github.com/masari-project/masari/archive/v0.3.1.2.tar.gz
+ source = CMakeLists.txt.patch
+ md5sums = deb1679c8f8c051242aa13e18b696ceb
+ md5sums = de1a927fa3d54babf66cb7cc3d0e2fd6
pkgname = masari
diff --git a/CMakeLists.txt.patch b/CMakeLists.txt.patch
new file mode 100644
index 000000000000..5648397cf505
--- /dev/null
+++ b/CMakeLists.txt.patch
@@ -0,0 +1,8 @@
+--- masari-0.3.1.2/CMakeLists.txt
++++ masari-0.3.1.2/CMakeLists.txt
+@@ -504,1 +504,1 @@
+- set(WARNINGS_AS_ERRORS_FLAG "-Werror")
++ set(WARNINGS_AS_ERRORS_FLAG "-Wno-error")
+@@ -809,1 +809,1 @@
+- if (Boost_VERSION VERSION_LESS 106200 AND NOT (OPENSSL_VERSION VERSION_LESS 1.1))
++ if (Boost_VERSION VERSION_LESS 1.62 AND NOT (OPENSSL_VERSION VERSION_LESS 1.1))
diff --git a/PKGBUILD b/PKGBUILD
index 877f9c6803ab..e1fe0d8f3ae1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,30 @@
# Maintainer: Chris Magyar <c.magyar.ec@gmail.com>
pkgname=masari
-pkgver=0.3.0.0
+pkgver=0.3.1.2
pkgrel=1
_gitrepo=masari
_gituser=masari-project
-_gitver=v0.3.0.0
+_gitver=v0.3.1.2
pkgdesc="Masari: cryptonote currency daemon and wallet"
arch=('x86_64')
url="https://github.com/$_gituser/$_gitrepo"
license=('custom:Cryptonote')
-makedepends=('boost' 'cmake' 'git')
-depends=('boost-libs' 'libunwind' 'miniupnpc' 'openssl' 'readline'
- 'unbound' 'zeromq')
+makedepends=('boost' 'cmake' 'git' 'openssl')
+depends=('boost-libs' 'libsodium' 'libunwind' 'miniupnpc'
+ 'openssl' 'readline' 'unbound' 'zeromq')
optdepends=('doxygen: documentation'
'expat: XML parsing'
'graphviz: documentation'
'ldns: SSL toolkit')
source=("$pkgname-$pkgver.tar.gz::$url/archive/$_gitver.tar.gz"
- boost.patch)
-md5sums=('7efd2602db7862b34264e105a8182edd'
- '5f84a2b83dd85e4e791b93dbb8b703eb')
+ 'CMakeLists.txt.patch')
+md5sums=('deb1679c8f8c051242aa13e18b696ceb'
+ 'de1a927fa3d54babf66cb7cc3d0e2fd6')
prepare() {
cd "$pkgname-$pkgver"
- patch -p1 -i ../boost.patch
+ patch -p1 -i ../CMakeLists.txt.patch
}
build() {
diff --git a/boost.patch b/boost.patch
deleted file mode 100644
index d579ea22e380..000000000000
--- a/boost.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- masari-0.3.0.0/src/cryptonote_basic/miner.cpp
-+++ masari-0.3.0.0/src/cryptonote_basic/miner.cpp
-@@ -630,7 +630,7 @@
- boost::tribool battery_powered(on_battery_power());
- if(!indeterminate( battery_powered ))
- {
-- on_ac_power = !battery_powered;
-+ on_ac_power = !(bool)battery_powered;
- }
- }