summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore8
-rw-r--r--PKGBUILD32
3 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..323131be1e8f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Thu Oct 19 15:27:25 UTC 2017
+pkgbase = mathcomp-git
+ pkgdesc = The Mathematical Components Library for the Coq system.
+ pkgver = 20170913
+ pkgrel = 1
+ url = https://math-comp.github.io/math-comp/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = camlp5>=7.02
+ makedepends = ocaml-findlib
+ depends = coq>=8.5
+ provides = mathcomp
+ conflicts = mathcomp
+ source = mathcomp-git::git://github.com/math-comp/math-comp.git
+ md5sums = SKIP
+
+pkgname = mathcomp-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..a6289c1c9dbb
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+/pkg
+/src
+*-git/
+*.bz2
+*.gz
+*.tar
+*.xz
+*.zip
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b19fb1ec11bf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Mort Yao <soi@mort.ninja>
+
+pkgname=mathcomp-git
+pkgver=20170913
+pkgrel=1
+pkgdesc="The Mathematical Components Library for the Coq system."
+url="https://math-comp.github.io/math-comp/"
+arch=('i686' 'x86_64')
+license=('GPL')
+depends=('coq>=8.5')
+makedepends=('camlp5>=7.02' 'ocaml-findlib')
+provides=('mathcomp')
+conflicts=('mathcomp')
+source=("${pkgname}::git://github.com/math-comp/math-comp.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ git log -1 --pretty=format:%cd --date=short | sed 's/-//g'
+}
+
+build() {
+ cd "$srcdir/$pkgname/mathcomp"
+
+ make -j 3
+}
+
+package() {
+ cd "$srcdir/$pkgname/mathcomp"
+
+ make DSTROOT="$pkgdir/usr/lib/coq/" install
+}