summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD17
2 files changed, 10 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 108ab84e7923..76c664f519f6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mathpix-snipping-tool
pkgdesc = Mathpix Snipping Tool
- pkgver = 03.00.0074
+ pkgver = 03.00.0091
pkgrel = 1
url = https://mathpix.com/
arch = x86_64
@@ -11,7 +11,7 @@ pkgbase = mathpix-snipping-tool
depends = qt5-imageformats
optdepends = wayland: Wayland support.
options = !strip
- source = mathpix-snipping-tool-03.00.0074-x86_64.AppImage::https://download.mathpix.com/linux/Mathpix_Snipping_Tool-x86_64.v03.00.0074.AppImage
- sha512sums = ecd555699f80ece9a21646142483392929c8058a9ffe01b969e5c91b40f90e625aaf20c1343615d865a0f5412eb10907c224ad925b38c26efeafdb4b039374b4
+ source = mathpix-snipping-tool-03.00.0091-x86_64.AppImage::https://download.mathpix.com/linux/Mathpix_Snipping_Tool-x86_64.v03.00.0091.AppImage
+ sha512sums = 807583a7e1345bf022b6c570b9e9c045c24e415598ca2d60b4082a7201210ba43216ab8e6d213d6ae1c4115533c167b5fd988416a5960b21474f940beab70d21
pkgname = mathpix-snipping-tool
diff --git a/PKGBUILD b/PKGBUILD
index 1c34067a9c67..28790bb0c6e7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,18 @@
# Maintainer: sukanka <su975853527 at gmail.com>
# Contributor: HRKo <ootaharuki99 at gmail.com>
pkgname=mathpix-snipping-tool
-pkgver=03.00.0074
-# _snapver=195
+pkgver=03.00.0091
pkgrel=1
pkgdesc="Mathpix Snipping Tool"
arch=('x86_64')
url="https://mathpix.com/"
license=('unknown')
-depends=('qt5-x11extras' 'qt5-webengine' 'qt5-svg' 'qt5-imageformats'
-# 'libxtst' 'libxrender' 'libxrandr' 'libxkbcommon' 'libxi' 'libxinerama' 'libxfixes' 'libxext'
-# 'libsasl'
+depends=('qt5-x11extras' 'qt5-webengine' 'qt5-svg' 'qt5-imageformats'
)
options=(!strip)
optdepends=('wayland: Wayland support.')
source=("${pkgname}-${pkgver}-${arch}.AppImage::https://download.mathpix.com/linux/Mathpix_Snipping_Tool-${arch}.v${pkgver}.AppImage")
-sha512sums=('ecd555699f80ece9a21646142483392929c8058a9ffe01b969e5c91b40f90e625aaf20c1343615d865a0f5412eb10907c224ad925b38c26efeafdb4b039374b4')
+sha512sums=('807583a7e1345bf022b6c570b9e9c045c24e415598ca2d60b4082a7201210ba43216ab8e6d213d6ae1c4115533c167b5fd988416a5960b21474f940beab70d21')
prepare() {
@@ -27,11 +24,11 @@ prepare() {
package() {
cd $srcdir/squashfs-root
install -Dm755 usr/bin/${pkgname} ${pkgdir}/usr/bin/${pkgname}
- install -Dm755 usr/lib/libsentry.so ${pkgdir}/usr/lib/libsentry.so
-# install -Dm755 usr/plugins/position/libqtposition_serialnmea.so ${pkgdir}/usr/lib/qt/plugins/position/libqtposition_serialnmea.so
-
+ install -Dm755 usr/lib/libsentry.so ${pkgdir}/usr/lib/libsentry.so
cp -r usr/share ${pkgdir}/usr
chmod 0755 -R ${pkgdir}/usr/share
-
+
rm -rf ${pkgdir}/usr/share/doc
+ # manually strip excutable here.
+ strip ${pkgdir}/usr/bin/${pkgname}
}