summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore1
-rw-r--r--LICENSE23
-rw-r--r--PKGBUILD60
4 files changed, 52 insertions, 46 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 96bb0edd9334..1c782d466331 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,31 +1,29 @@
-# Generated by mksrcinfo v8
-# Fri Oct 27 00:30:50 UTC 2017
pkgbase = mattercontrol
pkgdesc = Software solution for 3D printers
- pkgver = 1.7.5
+ pkgver = 2.19.10.10370
pkgrel = 1
url = http://www.mattercontrol.com
install = mattercontrol.install
arch = i386
arch = x86_64
license = custom
- makedepends = git
- makedepends = nuget
depends = mono
depends = lib32-glibc
depends = gtk-sharp-2
- optdepends = mattercontrol-plugins: Closed source plugins for cloud functionality
provides = mattercontrol
- source = git://github.com/MatterHackers/MatterControl.git
+ conflicts = mattercontrol-plugins
+ source = MatterControlSetup-2.19.10.10370.deb::https://mattercontrol.appspot.com/downloads/development/ag9zfm1hdHRlcmNvbnRyb2xyQQsSB1Byb2plY3QYgICAiOCSzAsMCxINUHVibGljUmVsZWFzZRiAgIDg1_GcCgwLEgZVcGxvYWQYgIDQiJunnQsM
source = mattercontrol
source = mattercontrol.desktop
source = mattercontrol.png
source = mattercontrol.install
- sha256sums = SKIP
+ source = LICENSE
+ sha256sums = 9f3163cb9b96c3a9803aec416ba28d51e5f6adcb88a07b585a23a8a0f60a1e9c
sha256sums = 4954c0de00d6701d37c15c73d3509d0d91e67339c08afa3b273e9343dfd5cc61
sha256sums = 89854894868127bdb8d7ebdef8cccf1c528b0a07e526380dcc0e1024a15c033c
sha256sums = 6470dfabd982109638c2e9fc01acca51dc1109ce07aec261dbc4c86ead9f9927
sha256sums = 41e907de000d6b57c7788229a36ff4b247de928597401631e2b1036fdf97aa77
+ sha256sums = 2731cdbc5d3916af68c1d5ffa2d3e3a3cfae6817ce5561d91f8bc565a3401982
pkgname = mattercontrol
diff --git a/.gitignore b/.gitignore
index d3443ca8d5b1..51987b7263eb 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,5 @@
*.pkg.tar*
+*.deb
pkg/
src/
MatterControl/
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..e1332d5d6d8f
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,23 @@
+Copyright (c) 2014, MatterHackers, Inc.
+All rights reserved.
+
+Redistribution and use in source and binary forms, with or without modification,
+are permitted provided that the following conditions are met:
+
+* Redistributions of source code must retain the above copyright notice, this
+ list of conditions and the following disclaimer.
+
+* Redistributions in binary form must reproduce the above copyright notice, this
+ list of conditions and the following disclaimer in the documentation and/or
+ other materials provided with the distribution.
+
+THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND
+ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
+WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
+DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE FOR
+ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
+(INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
+LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON
+ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
+SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE. \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index 8c43074aa594..994dd3fa7dfe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,69 +1,53 @@
# Maintainer: Tyler Anderson <unlimitedbacon@gmail.com>
+# This script simply downloads the MatterControl .deb release, unpacks it,
+# and copies all necessary files.
+
+# To update the package, change pkgver and _buildtoken.
+# Get _buildtoken from MCWS download URL.
+# Afterwards, run updpkgsums and mksrcinfo.
+
pkgname=mattercontrol
_pkgname=MatterControl
-pkgver=1.7.5
+pkgver=2.19.10.10370
pkgrel=1
pkgdesc="Software solution for 3D printers"
arch=("i386" "x86_64")
license=('custom')
url="http://www.mattercontrol.com"
depends=('mono' 'lib32-glibc' 'gtk-sharp-2')
-optdepends=('mattercontrol-plugins: Closed source plugins for cloud functionality')
-makedepends=('git' 'nuget')
provides=('mattercontrol')
+conflicts=('mattercontrol-plugins')
install="mattercontrol.install"
-_buildver=1.7.5.9487
_projecttoken=ag9zfm1hdHRlcmNvbnRyb2xyFAsSB1Byb2plY3QYgICAiOCSzAsM
-_buildtoken=ag9zfm1hdHRlcmNvbnRyb2xyQQsSB1Byb2plY3QYgICAiOCSzAsMCxINUHVibGljUmVsZWFzZRiAgIDg8dSdCgwLEgZVcGxvYWQYgICA4NfmjQoM
-source=(git://github.com/MatterHackers/MatterControl.git
+_buildtoken=ag9zfm1hdHRlcmNvbnRyb2xyQQsSB1Byb2plY3QYgICAiOCSzAsMCxINUHVibGljUmVsZWFzZRiAgIDg1_GcCgwLEgZVcGxvYWQYgIDQiJunnQsM
+source=("MatterControlSetup-$pkgver.deb::https://mattercontrol.appspot.com/downloads/development/$_buildtoken"
'mattercontrol'
'mattercontrol.desktop'
'mattercontrol.png'
- 'mattercontrol.install')
-sha256sums=('SKIP'
+ 'mattercontrol.install'
+ 'LICENSE')
+sha256sums=('9f3163cb9b96c3a9803aec416ba28d51e5f6adcb88a07b585a23a8a0f60a1e9c'
'4954c0de00d6701d37c15c73d3509d0d91e67339c08afa3b273e9343dfd5cc61'
'89854894868127bdb8d7ebdef8cccf1c528b0a07e526380dcc0e1024a15c033c'
'6470dfabd982109638c2e9fc01acca51dc1109ce07aec261dbc4c86ead9f9927'
- '41e907de000d6b57c7788229a36ff4b247de928597401631e2b1036fdf97aa77')
+ '41e907de000d6b57c7788229a36ff4b247de928597401631e2b1036fdf97aa77'
+ '2731cdbc5d3916af68c1d5ffa2d3e3a3cfae6817ce5561d91f8bc565a3401982')
build() {
- cd "${srcdir}"/${_pkgname}
-
- git checkout tags/Releases/${pkgver}
- git submodule update --init --recursive
- #mozroots --import --sync
- nuget restore MatterControl.sln
-
- xbuild /p:Configuration=Release MatterControl.sln
- #mdtool build -c:Release MatterControl.sln
-
- # GTK File Dialogs
- xbuild /p:Configuration=Release Submodules/agg-sharp/GtkFileDialogs/GtkFileDialogs.csproj
- cp Submodules/agg-sharp/GtkFileDialogs/obj/Release/GtkFileDialogs.dll* bin/Release/
- rm bin/Release/WindowsFileDialogs.dll*
-
- # Serial Helper
- cd Submodules/agg-sharp/SerialPortCommunication/SerialHelper
- ./build.sh
- cd "${srcdir}"/${_pkgname}
-
- # Build Info
- cd StaticData
- echo "{\"BuildVersion\": \"${_buildver}\", \"ProjectToken\": \"${_projecttoken}\", \"ReleaseVersion\": \"${pkgver}\", \"BuildToken\": \"${_buildtoken}\"}" > BuildInfo.txt
+ cd "${srcdir}"
+ ar -x "MatterControlSetup-$pkgver.deb"
+ tar -xvf data.tar.xz
}
package() {
- cd "${srcdir}"/${_pkgname}
-
+ cd "${srcdir}/usr/lib/mattercontrol"
install -d "$pkgdir/usr/lib/mattercontrol/"
- cp -r bin/Release/* "$pkgdir/usr/lib/mattercontrol/"
- install -d "$pkgdir/usr/lib/mattercontrol/StaticData/"
- cp -r StaticData/* "$pkgdir/usr/lib/mattercontrol/StaticData"
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/mattercontrol/LICENSE"
+ cp -r * "$pkgdir/usr/lib/mattercontrol/"
cd "${srcdir}"
install -Dm755 mattercontrol "$pkgdir/usr/bin/mattercontrol"
install -Dm644 mattercontrol.desktop "$pkgdir/usr/share/applications/mattercontrol.desktop"
install -Dm644 mattercontrol.png "$pkgdir/usr/share/icons/mattercontrol.png"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/mattercontrol/LICENSE"
}