summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD23
3 files changed, 18 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c79eff88daeb..632bd7f7de7c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,18 @@
pkgbase = matterhorn-bin
pkgdesc = A terminal-based chat client for MatterMost
- pkgver = 50200.4.0
+ pkgver = 90000.0.0
pkgrel = 1
url = https://github.com/matterhorn-chat/matterhorn
arch = x86_64
license = BSD
depends = gmp
- depends = libffi
depends = ncurses5-compat-libs
depends = zlib
- provides = matterhorn-bin
+ provides = matterhorn
conflicts = matterhorn
- conflicts = matterhorn-git
- source = https://github.com/matterhorn-chat/matterhorn/releases/download/50200.4.0/matterhorn-50200.4.0-ubuntu-18.04-bionic-x86_64.tar.bz2
- source = LICENSE::https://github.com/matterhorn-chat/matterhorn/raw/master/LICENSE
- sha1sums = 3a806502c2f17ce7306abd9ec6e8e186eeca4966
- sha1sums = 42e13363365a1fed1318f9e7fadd8d1760e7ba95
+ source = https://github.com/matterhorn-chat/matterhorn/releases/download/90000.0.0/matterhorn-90000.0.0-ubuntu-22.04-jammy-x86_64.tar.bz2
+ source = LICENSE::https://raw.githubusercontent.com/matterhorn-chat/matterhorn/master/LICENSE
+ sha1sums = edf0e5e0a53d41ccc1ab4aa11076684a8da763a1
+ sha1sums = 41bd788816973ea1340759da722bac169d6dc746
pkgname = matterhorn-bin
-
diff --git a/.gitignore b/.gitignore
index a681121d3664..037ff38839df 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,6 +1,7 @@
*.tar.xz
*.tar.gz
*.tar.bz2
+*.tar.zst
pkg/
src/
LICENSE
diff --git a/PKGBUILD b/PKGBUILD
index 2503140fc37e..70dfec7e5aba 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,21 @@
# Maintainer: Alex J. Malozemoff <amaloz@galois.com>
pkgname=matterhorn-bin
-pkgver=50200.4.0
+pkgver=90000.0.0
pkgrel=1
pkgdesc="A terminal-based chat client for MatterMost"
arch=('x86_64')
url="https://github.com/matterhorn-chat/matterhorn"
license=('BSD')
-provides=('matterhorn-bin')
-conflicts=('matterhorn' 'matterhorn-git')
-depends=('gmp' 'libffi' 'ncurses5-compat-libs' 'zlib')
-source=("https://github.com/matterhorn-chat/matterhorn/releases/download/${pkgver}/matterhorn-${pkgver}-ubuntu-18.04-bionic-x86_64.tar.bz2"
- "LICENSE::https://github.com/matterhorn-chat/matterhorn/raw/master/LICENSE")
-sha1sums=('3a806502c2f17ce7306abd9ec6e8e186eeca4966'
- '42e13363365a1fed1318f9e7fadd8d1760e7ba95')
+provides=('matterhorn')
+conflicts=('matterhorn')
+depends=('gmp' 'ncurses5-compat-libs' 'zlib')
+source=("https://github.com/matterhorn-chat/matterhorn/releases/download/${pkgver}/matterhorn-${pkgver}-ubuntu-22.04-jammy-$CARCH.tar.bz2"
+ "LICENSE::https://raw.githubusercontent.com/matterhorn-chat/matterhorn/master/LICENSE")
+sha1sums=('edf0e5e0a53d41ccc1ab4aa11076684a8da763a1'
+ '41bd788816973ea1340759da722bac169d6dc746')
package() {
- install -m644 -D LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
- cd ${srcdir}/matterhorn-${pkgver}-ubuntu-18.04-bionic-${arch}
- install -m755 -D matterhorn ${pkgdir}/usr/bin/matterhorn
-
+ install -m644 -D LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+ cd ${srcdir}/matterhorn-${pkgver}-ubuntu-22.04-jammy-${arch}
+ install -m755 -D matterhorn ${pkgdir}/usr/bin/matterhorn
}