summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--02-fix-weston-1.12-build.patch70
-rw-r--r--PKGBUILD13
3 files changed, 9 insertions, 81 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 738c2b8f1e9a..ab185caa423f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = maynard-git
pkgdesc = Lightweight desktop environment based on Weston compositor for use with Wayland
- pkgver = r121.a191e5c
- pkgrel = 2
+ pkgver = r123.b23c2a8
+ pkgrel = 1
url = https://github.com/raspberrypi/maynard
install = maynard.install
arch = x86_64
@@ -13,13 +13,12 @@ pkgbase = maynard-git
depends = weston
depends = gnome-desktop
depends = gnome-menus
+ optdepends = xorg-server-xwayland: For running X11 applications
provides = maynard
source = maynard::git+https://github.com/raspberrypi/maynard.git
source = 01-maynard.patch
- source = 02-fix-weston-1.12-build.patch
sha256sums = SKIP
sha256sums = 939a16eb6b50343059f7bb0afa89eff9831ae67ea561101620e7dab009883f60
- sha256sums = ced975edb39a089debcadb76f9b0f67d4c1ec90fc1ce42b7560e9edb61b96cc9
pkgname = maynard-git
diff --git a/02-fix-weston-1.12-build.patch b/02-fix-weston-1.12-build.patch
deleted file mode 100644
index 50b124234cb7..000000000000
--- a/02-fix-weston-1.12-build.patch
+++ /dev/null
@@ -1,70 +0,0 @@
-diff --git a/shell/shell-helper.c b/shell/shell-helper.c
-index 31118ad..ad9d0fa 100644
---- a/shell/shell-helper.c
-+++ b/shell/shell-helper.c
-@@ -22,7 +22,7 @@
- #include <stdio.h>
- #include <assert.h>
-
--#include <weston/compositor.h>
-+#include <libweston-1/compositor.h>
-
- #include "shell-helper-server-protocol.h"
-
-@@ -71,7 +71,7 @@ shell_helper_move_surface(struct wl_client *client,
- static void
- configure_surface(struct weston_surface *es, int32_t sx, int32_t sy)
- {
-- struct weston_view *existing_view = es->configure_private;
-+ struct weston_view *existing_view = es->committed_private;
- struct weston_view *new_view;
-
- new_view = container_of(es->views.next, struct weston_view, surface_link);
-@@ -97,7 +97,7 @@ shell_helper_add_surface_to_layer(struct wl_client *client,
- struct weston_view *new_view, *existing_view, *next;
- struct wl_layer *layer;
-
-- if (new_surface->configure) {
-+ if (new_surface->committed) {
- wl_resource_post_error(new_surface_resource,
- WL_DISPLAY_ERROR_INVALID_OBJECT,
- "surface role already assigned");
-@@ -112,15 +112,15 @@ shell_helper_add_surface_to_layer(struct wl_client *client,
- weston_view_destroy(new_view);
- new_view = weston_view_create(new_surface);
-
-- new_surface->configure = configure_surface;
-- new_surface->configure_private = existing_view;
-+ new_surface->committed = configure_surface;
-+ new_surface->committed_private = existing_view;
- new_surface->output = existing_view->output;
- }
-
- static void
- configure_panel(struct weston_surface *es, int32_t sx, int32_t sy)
- {
-- struct shell_helper *helper = es->configure_private;
-+ struct shell_helper *helper = es->committed_private;
- struct weston_view *view;
-
- view = container_of(es->views.next, struct weston_view, surface_link);
-@@ -147,7 +147,7 @@ shell_helper_set_panel(struct wl_client *client,
- * it hasn't yet been defined because the original surface configure
- * function hasn't yet been called. if we call it here we will have
- * access to the layer. */
-- surface->configure(surface, 0, 0);
-+ surface->committed(surface, 0, 0);
-
- helper->panel_layer = container_of(view->layer_link.link.next,
- struct weston_layer,
-@@ -155,8 +155,8 @@ shell_helper_set_panel(struct wl_client *client,
-
- /* set new configure functions that only ensure the surface is in the
- * correct layer. */
-- surface->configure = configure_panel;
-- surface->configure_private = helper;
-+ surface->committed = configure_panel;
-+ surface->committed_private = helper;
- }
-
- enum SlideState {
diff --git a/PKGBUILD b/PKGBUILD
index 490e7ed0808a..835de9329597 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,21 @@
# Maintainer: alive4ever <alive4ever at live.com>
pkgname=maynard-git
-pkgver=r121.a191e5c
-pkgrel=2
+pkgver=r123.b23c2a8
+pkgrel=1
pkgdesc="Lightweight desktop environment based on Weston compositor for use with Wayland"
arch=('x86_64' 'i686')
url="https://github.com/raspberrypi/maynard"
license=('custom:MIT' 'GPL')
provides=("maynard")
depends=("weston" "gnome-desktop" "gnome-menus")
+optdepends=("xorg-server-xwayland: For running X11 applications")
makedepends=("git" "intltool")
install=maynard.install
source=("${pkgname%-git}::git+https://github.com/raspberrypi/maynard.git"
- "01-maynard.patch"
- "02-fix-weston-1.12-build.patch")
+ "01-maynard.patch")
+
sha256sums=('SKIP'
- '939a16eb6b50343059f7bb0afa89eff9831ae67ea561101620e7dab009883f60'
- 'ced975edb39a089debcadb76f9b0f67d4c1ec90fc1ce42b7560e9edb61b96cc9')
+ '939a16eb6b50343059f7bb0afa89eff9831ae67ea561101620e7dab009883f60')
pkgver() {
cd "$srcdir/${pkgname%-git}"
@@ -27,7 +27,6 @@ pkgver() {
prepare() {
cd "$srcdir/${pkgname%-git}"
patch -p1 < "$srcdir/01-maynard.patch"
- patch -p1 < "$srcdir/02-fix-weston-1.12-build.patch"
}
build() {