summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD51
-rw-r--r--maynard.install19
4 files changed, 91 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8a3022575c1d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = maynard-git
+ pkgdesc = Lightweight desktop environment based on Weston compositor for use with Wayland
+ pkgver = r121.a191e5c
+ pkgrel = 1
+ url = https://github.com/raspberrypi/maynard
+ install = maynard.install
+ arch = x86_64
+ arch = i686
+ license = custom:MIT
+ license = GPL
+ makedepends = git
+ depends = weston
+ source = maynard-git::git+https://github.com/raspberrypi/maynard.git
+ sha256sums = SKIP
+
+pkgname = maynard-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e903f1bf2bc8
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+maynard-git*
+pkg
+src
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..43c63d634cb5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: alive4ever <alive4ever at live.com>
+pkgname=maynard-git
+pkgver=r121.a191e5c
+pkgrel=1
+pkgdesc="Lightweight desktop environment based on Weston compositor for use with Wayland"
+arch=('x86_64' 'i686')
+url="https://github.com/raspberrypi/maynard"
+license=('custom:MIT' 'GPL')
+provides=("maynard")
+depends=("weston")
+makedepends=('git')
+install=maynard.install
+source=("${pkgname%-VCS}::git+https://github.com/raspberrypi/maynard.git")
+sha256sums=('SKIP')
+
+# Please refer to the 'USING VCS SOURCES' section of the PKGBUILD man page for
+# a description of each element in the source array.
+
+pkgver() {
+ cd "$srcdir/${pkgname%-VCS}"
+
+# The examples below are not absolute and need to be adapted to each repo. The
+# primary goal is to generate version numbers that will increase according to
+# pacman's version comparisons with later commits to the repo. The format
+# VERSION='VER_NUM.rREV_NUM.HASH', or a relevant subset in case VER_NUM or HASH
+# are not available, is recommended.
+
+# Git, tags available
+ #printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+
+# Git, no tags available
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+
+}
+
+build() {
+ cd "$srcdir/${pkgname%-VCS}"
+ ./autogen.sh
+ ./configure --prefix=/usr --libexecdir=/usr/lib/maynard --sysconfdir=/etc --bindir=/usr/bin --libdir=/usr/lib
+ make
+}
+
+check() {
+ cd "$srcdir/${pkgname%-VCS}"
+ make -k check
+}
+
+package() {
+ cd "$srcdir/${pkgname%-VCS}"
+ make DESTDIR="$pkgdir/" install
+}
diff --git a/maynard.install b/maynard.install
new file mode 100644
index 000000000000..c70d00990ea7
--- /dev/null
+++ b/maynard.install
@@ -0,0 +1,19 @@
+post_install() {
+printf "Before starting maynard, create a ~/.config/weston.ini with the following content.\n"
+cat <<-EOF
+[core]
+modules=shell-helper.so,xwayland.so
+backend=drm-backend.so
+
+[shell]
+client=/usr/lib/maynard/maynard
+focus-animation=dim-layer
+animation=zoom
+EOF
+printf "After creating initial configuration, launch maynard\nsession using /usr/bin/maynard or /usr/bin/weston-launch\n"
+printf "Maynard is just a shell for weston(1). Configurations are mostly\n\
+done via weston.ini(5)."
+printf "For more information, read weston.ini(5) manual page.\n"
+printf "Maynard is still experimental. Crashes are to be expected.\nReport bugs to https://github.com/raspberrypi/maynard\n"
+}
+