summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD48
2 files changed, 47 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 865c0f30a1f3..e42f4351c71e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,25 @@
pkgbase = mbrola-voices-id1
pkgdesc = An Indonesian male voice for the MBROLA synthesizer
- pkgver = 001010
+ pkgver = 15.6fa9693
pkgrel = 1
- url = http://tcts.fpms.ac.be/synthesis/mbrola.html
+ epoch = 1
+ url = https://github.com/numediart/MBROLA-voices/
arch = any
- groups = mbrola-voices-id
groups = mbrola-voices
- groups = gespeaker-mbrola-voices
license = custom
depends = mbrola
- source = http://tcts.fpms.ac.be/synthesis/mbrola/dba/id1/id1-001010.zip
- md5sums = 33cd63ec6d231ac91b8156485a381207
+ source = https://github.com/numediart/MBROLA-voices/raw/6fa9693c09bc98f21a519dd9460340db964bacab/data/id1/id1
+ source = https://github.com/numediart/MBROLA-voices/raw/6fa9693c09bc98f21a519dd9460340db964bacab/data/id1/license.txt
+ source = https://github.com/numediart/MBROLA-voices/raw/6fa9693c09bc98f21a519dd9460340db964bacab/data/id1/README.txt
+ source = https://github.com/numediart/MBROLA-voices/raw/6fa9693c09bc98f21a519dd9460340db964bacab/data/id1/Test/mbroli.ini
+ source = https://github.com/numediart/MBROLA-voices/raw/6fa9693c09bc98f21a519dd9460340db964bacab/data/id1/Test/i_am_working.pho
+ source = https://github.com/numediart/MBROLA-voices/raw/6fa9693c09bc98f21a519dd9460340db964bacab/data/id1/Test/welcome_to_indonesia.pho
+ sha256sums = ef0254a32f632468b799c95ff9256bd6f81aa8900f619262618959ad68fa75d0
+ sha256sums = 89a85157d9b5112788e501456970bed6cabd980e8016fc1cd33d02a3de9fef29
+ sha256sums = d63a88b3afa1372ac9138ed5082687a0c00f2cd2987ee0cbf0eb59f65f828803
+ sha256sums = e8ce5047b79c902d32a138f4ede71c7dc683aa0df614b524fd74bfb0158a285a
+ sha256sums = d4f0dd82fdeae6162485727a0d24410e32f80100e64a7fd77ac7168f70741ede
+ sha256sums = dffe2902bdbbf68ce0173fec22c8ae9354cd7caf6c5f286ffb5314cec17e34b3
pkgname = mbrola-voices-id1
diff --git a/PKGBUILD b/PKGBUILD
index 315eb579dcf3..41798427fa67 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,40 @@
-# Maintainer: Muflone <webreg@vbsimple.net>
+# Maintainer: Muflone http://www.muflone.com/contacts/english/
+
pkgname=mbrola-voices-id1
-pkgver=001010
+pkgver=15.6fa9693
pkgrel=1
-_pkgfile=id1
+epoch=1
+_pkgfile="${pkgname/mbrola-voices-/}"
+_commit=6fa9693c09bc98f21a519dd9460340db964bacab
pkgdesc="An Indonesian male voice for the MBROLA synthesizer"
-arch=(any)
-url="http://tcts.fpms.ac.be/synthesis/mbrola.html"
-groups=(mbrola-voices-id mbrola-voices gespeaker-mbrola-voices)
-depends=(mbrola)
-license=(custom)
-source=("http://tcts.fpms.ac.be/synthesis/mbrola/dba/${_pkgfile}/${_pkgfile}-${pkgver}.zip")
-md5sums=('33cd63ec6d231ac91b8156485a381207')
+arch=('any')
+url="https://github.com/numediart/MBROLA-voices/"
+groups=('mbrola-voices')
+depends=('mbrola')
+license=('custom')
+source=("https://github.com/numediart/MBROLA-voices/raw/${_commit}/data/${_pkgfile}/${_pkgfile}"
+ "https://github.com/numediart/MBROLA-voices/raw/${_commit}/data/${_pkgfile}/license.txt"
+ "https://github.com/numediart/MBROLA-voices/raw/${_commit}/data/${_pkgfile}/README.txt"
+ "https://github.com/numediart/MBROLA-voices/raw/${_commit}/data/${_pkgfile}/Test/mbroli.ini"
+ "https://github.com/numediart/MBROLA-voices/raw/${_commit}/data/${_pkgfile}/Test/i_am_working.pho"
+ "https://github.com/numediart/MBROLA-voices/raw/${_commit}/data/${_pkgfile}/Test/welcome_to_indonesia.pho")
+sha256sums=('ef0254a32f632468b799c95ff9256bd6f81aa8900f619262618959ad68fa75d0'
+ '89a85157d9b5112788e501456970bed6cabd980e8016fc1cd33d02a3de9fef29'
+ 'd63a88b3afa1372ac9138ed5082687a0c00f2cd2987ee0cbf0eb59f65f828803'
+ 'e8ce5047b79c902d32a138f4ede71c7dc683aa0df614b524fd74bfb0158a285a'
+ 'd4f0dd82fdeae6162485727a0d24410e32f80100e64a7fd77ac7168f70741ede'
+ 'dffe2902bdbbf68ce0173fec22c8ae9354cd7caf6c5f286ffb5314cec17e34b3')
package(){
- cd "${srcdir}"
# Install license file
- install -D -m 644 "license.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -m 755 -d "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -m 644 -D "license.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
# Install files
- for file in id1 id1.txt Test/*
- do
- install -D -m 644 "${file}" "${pkgdir}/usr/share/mbrola/${_pkgfile}/${file}"
- done
+ install -m 755 -d "${pkgdir}/usr/share/mbrola/${_pkgfile}"
+ install -m 644 -t "${pkgdir}/usr/share/mbrola/${_pkgfile}" \
+ "${_pkgfile}" README.txt
+ # Install test files
+ install -m 755 -d "${pkgdir}/usr/share/mbrola/${_pkgfile}/Test"
+ install -m 644 -t "${pkgdir}/usr/share/mbrola/${_pkgfile}/Test" \
+ mbroli.ini i_am_working.pho welcome_to_indonesia.pho
}