summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD25
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9baf1cb9aa59
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = mbrola-voices-pl1
+ pkgdesc = A Polish female voice for the MBROLA synthesizer
+ pkgver = 1
+ pkgrel = 3
+ url = http://tcts.fpms.ac.be/synthesis/mbrola.html
+ arch = any
+ groups = mbrola-voices-pl
+ groups = mbrola-voices
+ groups = gespeaker-mbrola-voices
+ license = custom
+ depends = mbrola
+ source = http://tcts.fpms.ac.be/synthesis/mbrola/dba/pl1/pl1.zip
+ md5sums = 2e67625c2d10da642466f6290bdecb8d
+
+pkgname = mbrola-voices-pl1
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6a831f58aab8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Muflone <webreg@vbsimple.net>
+# Contributor: Changaco <me@changaco.net>
+pkgname=mbrola-voices-pl1
+pkgver=1
+pkgrel=3
+_pkgfile=pl1
+pkgdesc="A Polish female voice for the MBROLA synthesizer"
+arch=(any)
+url="http://tcts.fpms.ac.be/synthesis/mbrola.html"
+groups=(mbrola-voices-pl mbrola-voices gespeaker-mbrola-voices)
+depends=(mbrola)
+license=(custom)
+source=("http://tcts.fpms.ac.be/synthesis/mbrola/dba/${_pkgfile}/${_pkgfile}.zip")
+md5sums=('2e67625c2d10da642466f6290bdecb8d')
+
+package(){
+ cd "${srcdir}"
+ # Install license file
+ install -D -m 644 "license.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ # Install files
+ for file in pl1 pl1.txt test/*
+ do
+ install -D -m 644 "${file}" "${pkgdir}/usr/share/mbrola/${_pkgfile}/${file}"
+ done
+}