summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO42
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD60
-rw-r--r--mc-python3.patch61
4 files changed, 122 insertions, 46 deletions
diff --git a/.SRCINFO b/.SRCINFO
index eb886db3e2d1..60baba1af899 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,50 +1,47 @@
-# Generated by mksrcinfo v8
-# Tue Dec 27 14:37:08 UTC 2016
pkgbase = mc-git
- pkgdesc = a text based filemanager
- pkgver = 4.8.16.r44.g51d0783
+ pkgdesc = A file manager that emulates Norton Commander
+ pkgver = 4.8.31.r19.g293e534f3
pkgrel = 1
- url = http://www.midnight-commander.org/
- arch = i686
+ url = https://www.midnight-commander.org/
arch = x86_64
- license = GPL
+ license = GPL-3.0-or-later
+ makedepends = aspell
makedepends = git
makedepends = libxt
makedepends = libx11
+ makedepends = unzip
depends = e2fsprogs
depends = glib2
+ depends = glibc
depends = gpm
depends = libssh2
+ depends = sh
depends = slang
- depends = perl
- depends = aspell
+ depends = which
+ optdepends = aspell: spelling corrections
optdepends = cabextract: ucab extfs
optdepends = cdparanoia: audio extfs
optdepends = cdrkit: iso9660 extfs
- optdepends = gawk: hp48+ extfs
- optdepends = aspell: spelling corrections
optdepends = cvs: CVS support
+ optdepends = gawk: hp48+ extfs
optdepends = mtools: a+ extfs
- optdepends = python2-boto: s3+ extfs
- optdepends = python2-pytz: s3+ extfs
- optdepends = smb: VFS support
+ optdepends = p7zip: support for 7zip archives
+ optdepends = perl: needed by several ext2fs scripts
+ optdepends = python: to access uc1541 or s3 storage
+ optdepends = python-boto: s3+ extfs
+ optdepends = python-pytz: s3+ extfs
optdepends = unace: uace extfs
optdepends = unarj: uarj extfs
optdepends = unrar: urar extfs
+ optdepends = unzip: open zip archives
optdepends = zip: uzip extfs
- optdepends = p7zip: support for 7zip archives
- provides = mc=4.8.16
+ provides = mc
conflicts = mc
- conflicts = mc-cvs
- conflicts = mc-fork-svn
- conflicts = mc-mp
- conflicts = mc-slavz
- conflicts = mc-suse
options = !emptydirs
backup = etc/mc/edit.indent.rc
backup = etc/mc/filehighlight.ini
backup = etc/mc/mcedit.menu
- backup = etc/mc/mc.ext
+ backup = etc/mc/mc.ext.ini
backup = etc/mc/mc.keymap
backup = etc/mc/mc.menu
backup = etc/mc/sfs.ini
@@ -52,4 +49,3 @@ pkgbase = mc-git
sha256sums = SKIP
pkgname = mc-git
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..adf036023497
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+!.SRCINFO
+!PKGBUILD
+!.gitignore
+!*.patch
diff --git a/PKGBUILD b/PKGBUILD
index be46377caa4f..23da748364bd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,40 +1,44 @@
-# Maintainer: Alad Wenter <nynq@nepuyvahk.vasb> (rot13)
+# Maintainer: a821
+# Contributor: Alad Wenter <nynq@nepuyvahk.vasb> (rot13)
# Contributor: Chris Severance aur.severach aATt spamgourmet dott com
# Contributor: Chirantan Ekbote <chirantan.ekbote@gmail.com>
# Contributor: Sébastien Luttringer <seblu@aur.archlinux.org>
# Contributor: Tsekhovoy Eugene aka Krash <8552246@gmail.com>
pkgname=mc-git
-pkgver=4.8.16.r44.g51d0783
+pkgver=4.8.31.r19.g293e534f3
pkgrel=1
-pkgdesc='a text based filemanager'
-arch=('i686' 'x86_64')
-url='http://www.midnight-commander.org/'
-license=('GPL')
-depends=('e2fsprogs' 'glib2' 'gpm' 'libssh2' 'slang' 'perl' 'aspell')
+pkgdesc='A file manager that emulates Norton Commander'
+arch=('x86_64')
+url='https://www.midnight-commander.org/'
+license=('GPL-3.0-or-later')
+depends=('e2fsprogs' 'glib2' 'glibc' 'gpm' 'libssh2' 'sh' 'slang' 'which')
+makedepends=('aspell' 'git' 'libxt' 'libx11' 'unzip')
optdepends=(
+ 'aspell: spelling corrections'
'cabextract: ucab extfs'
'cdparanoia: audio extfs'
'cdrkit: iso9660 extfs'
- 'gawk: hp48+ extfs'
- 'aspell: spelling corrections'
'cvs: CVS support'
+ 'gawk: hp48+ extfs'
'mtools: a+ extfs'
- 'python2-boto: s3+ extfs'
- 'python2-pytz: s3+ extfs'
- 'smb: VFS support'
+ 'p7zip: support for 7zip archives'
+ 'perl: needed by several ext2fs scripts'
+ 'python: to access uc1541 or s3 storage'
+ 'python-boto: s3+ extfs'
+ 'python-pytz: s3+ extfs'
'unace: uace extfs'
'unarj: uarj extfs'
'unrar: urar extfs'
+ 'unzip: open zip archives'
'zip: uzip extfs'
- 'p7zip: support for 7zip archives')
-makedepends=('git' 'libxt' 'libx11')
-provides=("mc=${pkgver%%.r*}")
-conflicts=(mc{,-cvs,-fork-svn,-mp,-slavz,-suse})
+)
+provides=('mc')
+conflicts=('mc')
backup=('etc/mc/edit.indent.rc'
'etc/mc/filehighlight.ini'
'etc/mc/mcedit.menu'
- 'etc/mc/mc.ext'
+ 'etc/mc/mc.ext.ini'
'etc/mc/mc.keymap'
'etc/mc/mc.menu'
'etc/mc/sfs.ini')
@@ -47,25 +51,35 @@ pkgver() {
git describe --long | sed -e 's/\([^-]*-g\)/r\1/' -e 's/-/./g'
}
+prepare() {
+ cd mc
+ ./autogen.sh
+}
+
build() {
- export PYTHON=/usr/bin/python2
cd mc
- ./autogen.sh
./configure \
--prefix=/usr \
--libexecdir=/usr/lib \
--sysconfdir=/etc \
- --enable-vfs-smb \
- --with-x \
- --enable-aspell
+ --enable-aspell \
+ --with-screen=slang \
+ --with-x
make
}
package() {
cd mc
- make DESTDIR="${pkgdir}" install
+ make DESTDIR="$pkgdir" install
+
+ # FS#50889: Replace mc.keymap symlink with target file to fix backup mechanism.
+ rm "$pkgdir/etc/mc/mc.keymap"
+ cp "$pkgdir"/etc/mc/mc{.default,}.keymap
+ # remove s3 support until it no longer depends on deprecated python-boto:
+ # https://midnight-commander.org/ticket/3904
+ rm -v "$pkgdir/usr/lib/mc/extfs.d/s3+"
}
# vim:set ts=2 sw=2 ft=sh et:
diff --git a/mc-python3.patch b/mc-python3.patch
new file mode 100644
index 000000000000..43c11e06207b
--- /dev/null
+++ b/mc-python3.patch
@@ -0,0 +1,61 @@
+--- a/src/vfs/extfs/helpers/s3+.in
++++ b/src/vfs/extfs/helpers/s3+.in
+@@ -153,16 +153,16 @@
+ Propagates exception safely.
+ """
+ from threading import Thread
+- import Queue
++ import queue
+
+ items = list(iterable)
+ nitems = len(items)
+ if nitems < 2:
+- return map(fun, items)
++ return list(map(fun, items))
+
+ # Create and fill input queue
+- input = Queue.Queue()
+- output = Queue.Queue()
++ input = queue.Queue()
++ output = queue.Queue()
+
+ for i,item in enumerate(items):
+ input.put( (i,item) )
+@@ -181,7 +181,7 @@
+ output.put( (i,result) )
+ except:
+ output.put( (None,sys.exc_info()) )
+- except Queue.Empty:
++ except queue.Empty:
+ return
+
+ # Start threads
+@@ -196,8 +196,8 @@
+ try:
+ i,res = output.get()
+ if i == None:
+- raise res[0],res[1],res[2]
+- except Queue.Empty:
++ raise res[0](res[1]).with_traceback(res[2])
++ except queue.Empty:
+ break
+ ret.append(res)
+
+@@ -241,7 +241,7 @@
+ b = s3.get_bucket(name, validate=False)
+ b.get_location() # just to raise an exception on error
+ return b
+- except boto.exception.S3ResponseError, e:
++ except boto.exception.S3ResponseError as e:
+ # Seems this is the only proper way to switch to the bucket's region.
+ # Requesting of the default region for "?location" does not work unfortunately.
+ m = re.search(r'<Region>(.*?)</Region>', e.body)
+@@ -340,7 +340,7 @@
+ expr = re.compile(r'^(\d{4})-(\d{2})-(\d{2})T(\d{2}):(\d{2}):(\d{2})\.\d{3}Z$')
+ def convDate(awsdatetime):
+ m = expr.match(awsdatetime)
+- ye,mo,da,ho,mi,se = map(int,m.groups())
++ ye,mo,da,ho,mi,se = list(map(int,m.groups()))
+
+ dt = datetime.datetime(ye,mo,da,ho,mi,se, tzinfo=pytz.utc)
+ return dt.astimezone(tz).strftime('%m-%d-%Y %H:%M')