summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD3
-rwxr-xr-xprepare_update.sh2
3 files changed, 4 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8d1484bf87ae..352a0f29a935 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mcsctl-git
pkgdesc = Manage multiple minecraft servers with a simple bash script and systemd unit templates.
- pkgver = 3.0.0.r0.g9f1b8b7
+ pkgver = 3.0.0.r4.gff820fd
pkgrel = 1
url = https://github.com/Hetsh/mcsctl
install = mcsctl-git.install
diff --git a/PKGBUILD b/PKGBUILD
index 86a18eb86cad..83f9c1167941 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: peterfab9845 <archlinux@peterfab.com>
pkgname=mcsctl-git
-pkgver=3.0.0.r0.g9f1b8b7
+pkgver=3.0.0.r4.gff820fd
pkgrel=1
pkgdesc='Manage multiple minecraft servers with a simple bash script and systemd unit templates.'
arch=('any')
@@ -27,6 +27,7 @@ package() {
install -Dm 755 "$work_dir/mcsctl.sh" "$pkgdir/usr/bin/mcsctl"
install -Dm 644 "$work_dir/mcs-update@.timer" "$pkgdir/usr/lib/systemd/system/mcs-update@.timer"
install -Dm 644 "$work_dir/mcs-update@.service" "$pkgdir/usr/lib/systemd/system/mcs-update@.service"
+ install -Dm 644 "$work_dir/mcsctl-completion.bash" "$pkgdir/usr/share/bash-completion/completions/mcsctl"
# Generate an example config file from default options inside the mcsctl script
sed -n '/\# Mutable config/,/\# \/Mutable config/p' "$work_dir/mcsctl.sh" | head -n -1 | tail -n +2 > "$work_dir/mcsctl.conf.bak"
diff --git a/prepare_update.sh b/prepare_update.sh
index 554d496050fc..31aec902d5ba 100755
--- a/prepare_update.sh
+++ b/prepare_update.sh
@@ -21,7 +21,7 @@ then
else
sed -i "s|pkgrel\=.*|pkgrel\=1|" "$BUILD_FILE"
# Have makepkg update the version using pkgver()
- makepkg -o
+ makepkg --nodeps --nobuild
fi
makepkg --printsrcinfo > .SRCINFO