summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD25
2 files changed, 17 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8fab275720c3..f6e73120116c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,16 @@
pkgbase = mcstatus
pkgdesc = Provides an easy way to query Minecraft servers for any information they can expose.
- pkgver = 9.0.4
+ pkgver = 9.4.2
pkgrel = 1
url = https://github.com/py-mine/mcstatus
arch = any
license = Apache
- makedepends = python-setuptools
- makedepends = python-poetry
- makedepends = python-dephell
depends = python
depends = python-six
depends = python-click
depends = python-dnspython
depends = python-asyncio-dgram
- source = https://github.com/py-mine/mcstatus/archive/v9.0.4.tar.gz
- sha256sums = e113bde1aaa8756c507501668d2513651b470771b736a1a9bcae63f403c5d560
+ source = https://github.com/py-mine/mcstatus/archive/v9.4.2.tar.gz
+ sha256sums = 8c4e2534d384f904eef797a8d787be360754df03dd0b5859ab65163caedfd11a
pkgname = mcstatus
diff --git a/PKGBUILD b/PKGBUILD
index bc22fb91da88..2329bf555807 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,31 +2,34 @@
# Contributor: Stephanie Wilde-Hobbs (RX14) <steph@rx14.co.uk>
pkgname=mcstatus
-pkgver=9.0.4
+pkgver=9.4.2
pkgrel=1
pkgdesc="Provides an easy way to query Minecraft servers for any information they can expose."
arch=(any)
url="https://github.com/py-mine/mcstatus"
license=('Apache')
depends=(python python-six python-click python-dnspython python-asyncio-dgram)
-makedepends=(python-setuptools python-poetry python-dephell)
+makedepends=()
source=("${url}/archive/v${pkgver}.tar.gz")
-sha256sums=('e113bde1aaa8756c507501668d2513651b470771b736a1a9bcae63f403c5d560')
+sha256sums=('8c4e2534d384f904eef797a8d787be360754df03dd0b5859ab65163caedfd11a')
+
+python_version () {
+ python --version | cut -d' ' -f2 | cut -d'.' -f1,2
+}
prepare () {
cd "${srcdir}/mcstatus-${pkgver}"
-
- dephell deps convert --from pyproject.toml --to setup.py --envs main
}
build () {
- cd "${srcdir}/mcstatus-${pkgver}"
-
- python setup.py build
+ cd "${srcdir}/mcstatus-${pkgver}"
}
package () {
- cd "${srcdir}/mcstatus-${pkgver}"
-
- python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ cd "${srcdir}/mcstatus-${pkgver}"
+ mkdir -p "${pkgdir}/usr/lib/python$(python_version)/site-packages/"
+ mkdir -p "${pkgdir}/usr/bin/"
+ cp -r mcstatus/ "${pkgdir}/usr/lib/python$(python_version)/site-packages/"
+ printf '#!/bin/sh\npython -m mcstatus $@\n' >> "${pkgdir}/usr/bin/mcstatus"
+ chmod +x "${pkgdir}/usr/bin/mcstatus"
}