summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD10
3 files changed, 11 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 28787ebd177a..496616f74f63 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mcstatus
pkgdesc = Provides an easy way to query Minecraft servers for any information they can expose.
- pkgver = 4.1.0
- pkgrel = 2
+ pkgver = 5.1.1
+ pkgrel = 1
url = https://github.com/Dinnerbone/mcstatus
arch = any
license = Apache
@@ -12,8 +12,9 @@ pkgbase = mcstatus
depends = python-six
depends = python-click
depends = python-dnspython
- source = https://github.com/Dinnerbone/mcstatus/archive/release-4.1.0.tar.gz
- sha256sums = 21c3415ab1a0f68db3f8909566a945f6eeeca5ca8d0811dc5b4f2af3ee98c0b5
+ depends = python-asyncio-dgram
+ source = https://github.com/Dinnerbone/mcstatus/archive/release-5.1.1.tar.gz
+ sha256sums = 20de89e1ec19ae3310c315702582392b99b3b9a83b0c8eee2637670ebbe16a7c
pkgname = mcstatus
diff --git a/.gitignore b/.gitignore
index 4a362d1f70e1..45bb53f2bf2e 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,3 +1,4 @@
/*
!/PKGBUILD
!/.gitignore
+!/.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
index 3d12076e5851..23896d179dee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,22 @@
# Maintainer: Stephanie Wilde-Hobbs (RX14) <steph@rx14.co.uk>
pkgname=mcstatus
-pkgver=4.1.0
-pkgrel=2
+pkgver=5.1.1
+pkgrel=1
pkgdesc="Provides an easy way to query Minecraft servers for any information they can expose."
arch=(any)
url="https://github.com/Dinnerbone/mcstatus"
license=('Apache')
-depends=(python python-six python-click python-dnspython)
+depends=(python python-six python-click python-dnspython python-asyncio-dgram)
makedepends=(python-setuptools)
checkdepends=(python-mock python-nose)
source=("https://github.com/Dinnerbone/mcstatus/archive/release-${pkgver}.tar.gz")
-sha256sums=('21c3415ab1a0f68db3f8909566a945f6eeeca5ca8d0811dc5b4f2af3ee98c0b5')
+sha256sums=('20de89e1ec19ae3310c315702582392b99b3b9a83b0c8eee2637670ebbe16a7c')
prepare() {
cd "${srcdir}/mcstatus-release-${pkgver}"
- sed -i 's/dnspython3/dnspython/' setup.py
+ sed -i 's/dnspython3/dnspython/' requirements.txt
}