summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD13
3 files changed, 15 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 806d796f2cd9..864d0be5d469 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = med-openmpi
pkgdesc = Modelisation et Echanges de Donnees, i.e. Data Modelization and Exchanges - code-aster exchange module linked to hdf5
pkgver = 4.0.0
- pkgrel = 2
+ pkgrel = 3
url = https://www.salome-platform.org/downloads
arch = x86_64
license = LGPL
@@ -13,7 +13,9 @@ pkgbase = med-openmpi
depends = tk
depends = python
source = http://files.salome-platform.org/Salome/other/med-4.0.0.tar.gz
+ source = https://gist.githubusercontent.com/jedbrown/527ef81ff59a0dccf833da40fdd15a47/raw/7482f9a42fdd277f5f9cf0167ea7a3381032ca7a/hdf5-1.12.patch
sha256sums = a474e90b5882ce69c5e9f66f6359c53b8b73eb448c5f631fa96e8cd2c14df004
+ sha256sums = 82d28b6ae2ee6ceb3c6de9acb861a49741e2e759c7c556217f7d284216788206
pkgname = med-openmpi
provides = med
diff --git a/.gitignore b/.gitignore
index 67f8c18f0637..a68a0ca69370 100644
--- a/.gitignore
+++ b/.gitignore
@@ -7,4 +7,5 @@
*.sig
*.jar
pkg/
-src/ \ No newline at end of file
+src/
+hdf5-1.12.patch
diff --git a/PKGBUILD b/PKGBUILD
index 2a9e54296f4d..2226e7d34bc8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,15 +10,22 @@
_pkgname='med'
pkgname=('med-openmpi' 'med-openmpi-docs')
pkgver=4.0.0
-pkgrel=2
+pkgrel=3
pkgdesc="Modelisation et Echanges de Donnees, i.e. Data Modelization and Exchanges - code-aster exchange module linked to hdf5"
url="https://www.salome-platform.org/downloads"
license=('LGPL')
depends=('hdf5-openmpi' 'tk' 'python')
makedepends=('gcc-fortran' 'swig' 'openmpi' 'cmake')
arch=('x86_64')
-source=("http://files.salome-platform.org/Salome/other/${_pkgname}-${pkgver}.tar.gz")
-sha256sums=('a474e90b5882ce69c5e9f66f6359c53b8b73eb448c5f631fa96e8cd2c14df004')
+source=("http://files.salome-platform.org/Salome/other/${_pkgname}-${pkgver}.tar.gz"
+ "https://gist.githubusercontent.com/jedbrown/527ef81ff59a0dccf833da40fdd15a47/raw/7482f9a42fdd277f5f9cf0167ea7a3381032ca7a/hdf5-1.12.patch")
+sha256sums=('a474e90b5882ce69c5e9f66f6359c53b8b73eb448c5f631fa96e8cd2c14df004'
+ '82d28b6ae2ee6ceb3c6de9acb861a49741e2e759c7c556217f7d284216788206')
+
+prepare() {
+ cd ${_pkgname}-${pkgver}
+ patch -p1 -i "$srcdir/hdf5-1.12.patch"
+}
build() {
cd ${_pkgname}-${pkgver}