summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD32
-rw-r--r--patch-include_2.3.6_med.h.in14
-rw-r--r--patch-include_med.h.in15
-rw-r--r--patch-int2long108
-rw-r--r--patch-src_2.3.6_ci_MEDequivInfo.c11
6 files changed, 13 insertions, 185 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5c368d8b1470..dcf2db6b81cc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Thu Mar 23 21:42:00 UTC 2017
+# Mon May 29 11:00:22 UTC 2017
pkgbase = med-salome
pkgdesc = MED stands for Modelisation et Echanges de Donnees, i.e. Data Modelization and Exchanges - This version is built to be linked against salome-med on x86_64
- pkgver = 3.2.0
- pkgrel = 5
+ pkgver = 3.2.1
+ pkgrel = 1
url = http://www.code-aster.org/outils/med/
arch = i686
arch = x86_64
@@ -19,16 +19,8 @@ pkgbase = med-salome
conflicts = med
replaces = med_fichier
replaces = med
- source = http://files.salome-platform.org/Salome/other/med-3.2.0.tar.gz
- source = patch-include_2.3.6_med.h.in
- source = patch-include_med.h.in
- source = patch-src_2.3.6_ci_MEDequivInfo.c
- source = patch-int2long
- md5sums = eb61df92f0624feb6328f517cd756a23
- md5sums = b83949326d7ae0ca77a06822b754a329
- md5sums = 14a151cea108388d7a3b4c62887169f6
- md5sums = 8f0cbf6f08783a6ba68ff5ab240dd62e
- md5sums = 08c436aee7cf573ff28463cc2e88ec1b
+ source = http://files.salome-platform.org/Salome/other/med-3.2.1.tar.gz
+ md5sums = 4965899bb578229ba27c9bc5293c651e
pkgname = med-salome
diff --git a/PKGBUILD b/PKGBUILD
index f91319ab46a8..ae510c15bfd8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,8 +6,8 @@
pkgname=med-salome
_pkgname=med
-pkgver=3.2.0
-pkgrel=5
+pkgver=3.2.1
+pkgrel=1
pkgdesc="MED stands for Modelisation et Echanges de Donnees, i.e. Data Modelization and Exchanges - This version is built to be linked against salome-med on x86_64"
url="http://www.code-aster.org/outils/med/"
license=('LGPL')
@@ -19,18 +19,11 @@ conflicts=("med_fichier" "med")
replaces=("med_fichier" "med")
backup=()
arch=('i686' 'x86_64')
-source=("http://files.salome-platform.org/Salome/other/${_pkgname}-${pkgver}.tar.gz"
- "patch-include_2.3.6_med.h.in"
- "patch-include_med.h.in"
- "patch-src_2.3.6_ci_MEDequivInfo.c"
- "patch-int2long")
-md5sums=('eb61df92f0624feb6328f517cd756a23'
- 'b83949326d7ae0ca77a06822b754a329'
- '14a151cea108388d7a3b4c62887169f6'
- '8f0cbf6f08783a6ba68ff5ab240dd62e'
- '08c436aee7cf573ff28463cc2e88ec1b')
+source=("http://files.salome-platform.org/Salome/other/${_pkgname}-${pkgver}.tar.gz")
+md5sums=('4965899bb578229ba27c9bc5293c651e')
+_basesrcdir=${_pkgname}-${pkgver}_SRC
# _installdir=/opt/${pkgname}
_installdir=/usr
_sharedir=${_installdir}/share/${pkgname}
@@ -43,7 +36,7 @@ prepare() {
# rm -rf build
# fi
- cd ${srcdir}/${_pkgname}-${pkgver}
+ cd ${srcdir}/${_basesrcdir}
# uncomment if using cmake
# sed -e "s|\${CMAKE_INSTALL_PREFIX}/\${PYFILELOC}/\${inputname}|\\\\\$ENV{DESTDIR}\${CMAKE_INSTALL_PREFIX}/\${PYFILELOC}/\${inputname}|" \
@@ -52,15 +45,6 @@ prepare() {
# comment if using cmake
sed -e "s|\$hdf5home/include|\$hdf5home/include/hdf5_18|" -i configure
sed -e "s|\$hdf5home/lib|\$hdf5home/lib/hdf5_18|" -i configure
-
- # patch H5public_extract.h.in
- sed -i -e '/^#typedef/ s/#/\/\//' ./include/H5public_extract.h.in
-
- #patch for hdf5-1.10
- patch -p0 < ${srcdir}/patch-include_2.3.6_med.h.in
- patch -p0 < ${srcdir}/patch-include_med.h.in
- patch -p0 < ${srcdir}/patch-src_2.3.6_ci_MEDequivInfo.c
- patch -p0 < ${srcdir}/patch-int2long
}
build() {
@@ -85,7 +69,7 @@ build() {
# export F77=$MPIF77
# comment if using cmake
- cd ${srcdir}/${_pkgname}-${pkgver}
+ cd ${srcdir}/${_basesrcdir}
./configure --prefix=${_installdir} --with-med_int=int --datadir=${_sharedir} --with-swig=yes --with-hdf5=/usr
# uncomment if using cmake
@@ -121,7 +105,7 @@ package() {
# cd "${srcdir}/build"
# comment if using cmake
- cd ${srcdir}/${_pkgname}-${pkgver}
+ cd ${srcdir}/${_basesrcdir}
make DESTDIR=${pkgdir} install
}
diff --git a/patch-include_2.3.6_med.h.in b/patch-include_2.3.6_med.h.in
deleted file mode 100644
index 2602df9f7b9d..000000000000
--- a/patch-include_2.3.6_med.h.in
+++ /dev/null
@@ -1,14 +0,0 @@
---- include/2.3.6/med.h.in.orig 2014-10-09 08:12:57 UTC
-+++ include/2.3.6/med.h.in
-@@ -25,11 +25,7 @@ extern "C" {
- #endif
-
- #define HDF5_VERSION (H5_VERS_MAJOR * 10000 + H5_VERS_MINOR * 100 + H5_VERS_RELEASE )
--#if HDF5_VERSION < 10607
--#define HDF5_SELECT_BUG (const hsize_t **)
--#else
- #define HDF5_SELECT_BUG
--#endif
-
-
- #define MED_NUM_MAJEUR 2
diff --git a/patch-include_med.h.in b/patch-include_med.h.in
deleted file mode 100644
index c47a57c26967..000000000000
--- a/patch-include_med.h.in
+++ /dev/null
@@ -1,15 +0,0 @@
---- include/med.h.in.orig 2014-10-09 08:12:57 UTC
-+++ include/med.h.in
-@@ -27,12 +27,7 @@ extern "C" {
-
- #define HDF5_VERSION (H5_VERS_MAJOR * 10000 + H5_VERS_MINOR * 100 + H5_VERS_RELEASE )
-
--#if HDF5_VERSION < 10607
--/*TODO : A enlever après MAJ complète api hdf5-1.8 */
--#define HDF5_SELECT_BUG (const hsize_t **)
--#else
- #define HDF5_SELECT_BUG
--#endif
-
- /*Le symbole H5F_LIBVER_18 n'existe pas dans hdf5-1.8.4 (uniquement à partir de la version 1.8.6)
- Pour rester dans le modèle interne hdf introduit en 1.8 quelque soit les futurs modèles internes hdf
diff --git a/patch-int2long b/patch-int2long
deleted file mode 100644
index 496dc048c76d..000000000000
--- a/patch-int2long
+++ /dev/null
@@ -1,108 +0,0 @@
-diff -Nur src.orig/2.3.6/hdfi/MEDattrNumEcrire.c src/2.3.6/hdfi/MEDattrNumEcrire.c
---- src.orig/2.3.6/hdfi/MEDattrNumEcrire.c 2015-09-07 18:55:34.000000000 +0200
-+++ src/2.3.6/hdfi/MEDattrNumEcrire.c 2016-05-24 02:15:27.450098778 +0200
-@@ -36,7 +36,7 @@
- {
- med_idt aid,attr;
- med_err ret;
-- int type_hdf;
-+ long type_hdf;
- med_mode_acces MED_MODE_ACCES;
-
- if ( (MED_MODE_ACCES = _MEDmodeAcces(pere) ) == MED_UNDEF_MODE_ACCES ) {
-diff -Nur src.orig/hdfi/_MEDattributeNumRdByName.c src/hdfi/_MEDattributeNumRdByName.c
---- src.orig/hdfi/_MEDattributeNumRdByName.c 2015-09-07 18:55:16.000000000 +0200
-+++ src/hdfi/_MEDattributeNumRdByName.c 2016-05-24 02:15:27.443432111 +0200
-@@ -27,7 +27,7 @@
- {
- med_idt _attid=0;
- med_err _ret=-1;
-- int type_hdf;
-+ long type_hdf;
-
- switch(type)
- {
-diff -Nur src.orig/hdfi/_MEDattributeNumWrByName.c src/hdfi/_MEDattributeNumWrByName.c
---- src.orig/hdfi/_MEDattributeNumWrByName.c 2015-09-07 18:55:17.000000000 +0200
-+++ src/hdfi/_MEDattributeNumWrByName.c 2016-05-24 02:15:27.443432111 +0200
-@@ -32,7 +32,7 @@
- {
- med_idt _attid=0,aid=0;
- med_err _ret=-1;
-- int type_hdf;
-+ long type_hdf;
- med_access_mode MED_ACCESS_MODE;
- H5O_info_t _oinfo;
-
-diff -Nur src.orig/hdfi/_MEDattributeNumWr.c src/hdfi/_MEDattributeNumWr.c
---- src.orig/hdfi/_MEDattributeNumWr.c 2015-09-07 18:55:16.000000000 +0200
-+++ src/hdfi/_MEDattributeNumWr.c 2016-05-24 02:15:27.443432111 +0200
-@@ -32,7 +32,7 @@
- {
- med_idt _attid=0,aid=0;
- med_err _ret=-1;
-- int type_hdf;
-+ long type_hdf;
- med_access_mode MED_ACCESS_MODE;
- H5O_info_t _oinfo;
-
-diff -Nur src.orig/hdfi/_MEDattributeStringRdByName.c src/hdfi/_MEDattributeStringRdByName.c
---- src.orig/hdfi/_MEDattributeStringRdByName.c 2015-09-07 18:55:15.000000000 +0200
-+++ src/hdfi/_MEDattributeStringRdByName.c 2016-05-24 02:15:27.443432111 +0200
-@@ -29,7 +29,7 @@
- {
- med_err _ret=-1;
- med_idt _attid=0;
-- int type_hdf=0;
-+ long type_hdf=0;
-
- if ( (type_hdf = H5Tcopy(H5T_C_S1)) < 0) {
- MED_ERR_(_ret,MED_ERR_CREATE,MED_ERR_HDFTYPE, MED_ERR_NAME_MSG );
-diff -Nur src.orig/hdfi/_MEDattributeStringWrByName.c src/hdfi/_MEDattributeStringWrByName.c
---- src.orig/hdfi/_MEDattributeStringWrByName.c 2015-09-07 18:55:16.000000000 +0200
-+++ src/hdfi/_MEDattributeStringWrByName.c 2016-05-24 02:15:27.443432111 +0200
-@@ -31,7 +31,7 @@
- med_access_mode MED_ACCESS_MODE;
- med_idt _attid=0,aid=0;
- med_err _ret=-1;
-- int type_hdf=0;
-+ long type_hdf=0;
- med_bool _attmustbecreated= MED_FALSE;
- hsize_t _attsize=0;
- med_size _valsize=0;
-diff -Nur src.orig/hdfi/_MEDattributeStringWr.c src/hdfi/_MEDattributeStringWr.c
---- src.orig/hdfi/_MEDattributeStringWr.c 2015-09-07 18:55:17.000000000 +0200
-+++ src/hdfi/_MEDattributeStringWr.c 2016-05-24 02:15:27.443432111 +0200
-@@ -30,7 +30,7 @@
- med_access_mode MED_ACCESS_MODE;
- med_idt _attid=0,aid=0;
- med_err _ret=-1;
-- int type_hdf=0;
-+ long type_hdf=0;
- med_bool _attmustbecreated= MED_FALSE;
- hsize_t _attsize=0;
- med_size _valsize=0;
-diff -Nur src.orig/hdfi/_MEDdatasetRd.c src/hdfi/_MEDdatasetRd.c
---- src.orig/hdfi/_MEDdatasetRd.c 2015-09-07 18:55:15.000000000 +0200
-+++ src/hdfi/_MEDdatasetRd.c 2016-05-24 02:15:27.443432111 +0200
-@@ -32,7 +32,7 @@
- med_idt _dataset=0, _dataspace=0;
- med_size _datasetsize[1]={0};
- med_err _ret=-1;
-- int _hdftype=0;
-+ long _hdftype=0;
- int _datasetsizeEqualTosizespace = 0;
- med_access_mode _MED_ACCESS_MODE;
- med_int _nvaluesperentity=0,_nconstituentpervalue=0;
-diff -Nur src.orig/hdfi/_MEDdatasetWr.c src/hdfi/_MEDdatasetWr.c
---- src.orig/hdfi/_MEDdatasetWr.c 2015-09-07 18:55:15.000000000 +0200
-+++ src/hdfi/_MEDdatasetWr.c 2016-05-24 02:15:27.443432111 +0200
-@@ -30,7 +30,7 @@
- med_idt _dataset=0, _dataspace=0,_datadiskspace=0;
- med_size _datasetsize[1]={0};
- med_err _ret=-1;
-- int _hdftype=0;
-+ long _hdftype=0;
- int _datasetsizeEqualTosizespace = 0;
- med_access_mode _MED_ACCESS_MODE;
- med_int _nvaluesperentity=0,_nconstituentpervalue=0;
diff --git a/patch-src_2.3.6_ci_MEDequivInfo.c b/patch-src_2.3.6_ci_MEDequivInfo.c
deleted file mode 100644
index 12006a1f3227..000000000000
--- a/patch-src_2.3.6_ci_MEDequivInfo.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/2.3.6/ci/MEDequivInfo.c.orig 2014-10-09 08:12:59 UTC
-+++ src/2.3.6/ci/MEDequivInfo.c
-@@ -24,7 +24,7 @@
- #include <stdlib.h>
-
- int
--MEDequivInfo(int fid, char *maa, int ind, char *eq, char *des)
-+MEDequivInfo(med_idt fid, char *maa, int ind, char *eq, char *des)
- {
- med_idt eqid;
- med_err ret;