summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD19
1 files changed, 13 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3fa8fd8780a0..baa31efd1b85 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,14 +12,21 @@ conflicts=('mediaqbot')
makedepends=('git' 'python-setuptools')
provides=('mediaqbot')
url='https://github.com/raffomania/mediaqbot'
-source=("git+https://github.com/raffomania/mediaqbot.git")
-sha256sums=('SKIP')
+source=(
+ "git+https://github.com/raffomania/mediaqbot.git"
+ "git+https://github.com/hatzel/python-mpv.git"
+)
+sha256sums=('SKIP' 'SKIP')
-package() {
- cd "${_gitname}"
- git submodule update --init --recursive
+prepare() {
+ cd "${_gitname}"
+
+ git submodule init
+ git config submodule."client/mediaqclient/mpv".url ${srcdir}/mpv
+}
- cd client
+package() {
+ cd "${_gitname}/client"
# Install
python setup.py install --optimize=1 --root="${pkgdir}"