summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD58
2 files changed, 21 insertions, 43 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8b052a8470ac..09215ad8b652 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,8 @@
pkgbase = megaglest-git
pkgdesc = Fork of Glest, a 3D real-time strategy game in a fantastic world (git version)
- pkgver = 3.13.0.r102.ge50e4f300
+ pkgver = 3.13.0.r267.g231c639c7
pkgrel = 1
url = https://megaglest.org/
- arch = i686
arch = x86_64
license = GPL3
makedepends = git
@@ -22,7 +21,7 @@ pkgbase = megaglest-git
depends = glew
depends = libircclient
depends = miniupnpc
- depends = wxgtk3
+ depends = wxwidgets-gtk3
depends = glu
depends = libx11
depends = libminiupnpc.so
@@ -33,4 +32,3 @@ pkgbase = megaglest-git
sha256sums = SKIP
pkgname = megaglest-git
-
diff --git a/PKGBUILD b/PKGBUILD
index c8f359c841b2..34c18f2bcda0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,15 @@
-# Maintainer : Daniel Bermond < gmail-com: danielbermond >
+# Maintainer : Daniel Bermond <dbermond@archlinux.org>
pkgname=megaglest-git
-_srcname=megaglest-source
-pkgver=3.13.0.r102.ge50e4f300
+pkgver=3.13.0.r267.g231c639c7
pkgrel=1
pkgdesc='Fork of Glest, a 3D real-time strategy game in a fantastic world (git version)'
-arch=('i686' 'x86_64')
+arch=('x86_64')
url='https://megaglest.org/'
license=('GPL3')
-depends=(
- # official repositories:
- 'curl' 'xerces-c' 'sdl2' 'libvorbis' 'openal' 'libgl' 'lua51' 'icu' 'ftgl'
- 'glew' 'libircclient' 'miniupnpc' 'wxgtk3' 'glu' 'libx11' 'libminiupnpc.so'
- # AUR:
- 'megaglest-data-git'
-)
+depends=('curl' 'xerces-c' 'sdl2' 'libvorbis' 'openal' 'libgl' 'lua51' 'icu' 'ftgl' 'glew'
+ 'libircclient' 'miniupnpc' 'wxwidgets-gtk3' 'glu' 'libx11' 'libminiupnpc.so'
+ 'megaglest-data-git')
makedepends=('git' 'ftjam' 'cmake' 'mesa')
provides=('megaglest')
conflicts=('megaglest')
@@ -22,39 +17,24 @@ source=('git+https://github.com/MegaGlest/megaglest-source.git')
sha256sums=('SKIP')
pkgver() {
- cd "$_srcname"
-
- # git, tags available
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//'
+ git -C megaglest-source describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//'
}
build() {
- cd "$_srcname"
-
- # - SSE is available only from Pentium 3 onwards (i686 is way older)
- # - SSE and SSE2 are availabe on all x86_64 CPUs
- [ "$CARCH" = 'i686' ] && local _sse='0'
- [ "$CARCH" = 'x86_64' ] && local _sse='2' # (supported: 0-3)
-
- rm -rf build
- mkdir -p build
- cd build
-
- cmake .. \
+ cmake -B build -S megaglest-source \
+ -G 'Unix Makefiles' \
+ -DCMAKE_BUILD_TYPE='None' \
-DCMAKE_INSTALL_PREFIX='/usr' \
- -DCMAKE_BUILD_TYPE='Release' \
- -DCMAKE_CXX_FLAGS="-lX11 ${CXXFLAGS}" \
- -DWANT_GIT_STAMP='0' \
- -DwxWidgets_CONFIG_EXECUTABLE='/usr/bin/wx-config-gtk3' \
- -Wno-dev \
- ..
-
- # using '-j1' will prevent errors if xvfb is installed (will build manpages)
- make -j1
+ -DCMAKE_EXE_LINKER_FLAGS="${LDFLAGS} -lX11" \
+ -DWANT_GIT_STAMP='1' \
+ -DwxWidgets_CONFIG_EXECUTABLE='/usr/bin/wx-config' \
+ -DWANT_USE_VLC:BOOL='OFF' \
+ -Wno-dev
+
+ # use '-j1' if xvfb is installed on your system to prevent errors (will build manpages)
+ cmake --build build
}
package() {
- cd "${_srcname}/build"
-
- make -j1 DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" cmake --install build
}