summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD6
-rw-r--r--megamek.patch18
-rw-r--r--megameklab.patch88
4 files changed, 67 insertions, 55 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e650a46533ca..b683949578d4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = megameklab
pkgdesc = Customize mechs for a MegaMek game.
- pkgver = 0.46.1
+ pkgver = 0.48.0
pkgrel = 1
url = https://github.com/MegaMek/megamek
arch = x86_64
@@ -8,8 +8,8 @@ pkgbase = megameklab
makedepends = git
makedepends = tar
depends = java-runtime>=8
- source = megameklab::git+https://github.com/MegaMek/megameklab#tag=v0.46.1
- source = megamek::git+https://github.com/MegaMek/megamek#tag=v0.46.1
+ source = megameklab::git+https://github.com/MegaMek/megameklab#tag=v0.48.0
+ source = megamek::git+https://github.com/MegaMek/megamek#tag=v0.48.0
source = megameklab.desktop
source = megameklab.sh
source = megameklab.patch
@@ -18,8 +18,8 @@ pkgbase = megameklab
sha256sums = SKIP
sha256sums = 7b3615680c9892099ab6e7b675e8e22baf9680d12a58050d46d71537a7fe0372
sha256sums = ca4459489d3c188b7418f7b596290accec61e2b190a58f4d0fd7593911d87597
- sha256sums = 48642023e264f90a5831a9a9e91eda2bf33881d7d60f40979ff4e689c485714e
- sha256sums = f1c3fd91d5e142dc1d800a8228ac66c4bc847a2b87a70b352845a2931b7392e6
+ sha256sums = 7a5949eacb26b612b784211c5067d1042e86232b180a9f41530f2d6ecb4a4cc3
+ sha256sums = c3d19a1933b36d29caf577c31f10683f2c99c0501fe3f23de678fcedae69f373
pkgname = megameklab
diff --git a/PKGBUILD b/PKGBUILD
index 8b4ad6d806aa..357921d2220f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer:F43nd1r <support@faendir.com>
pkgname=megameklab
-pkgver=0.46.1
+pkgver=0.48.0
pkgrel=1
epoch=
pkgdesc="Customize mechs for a MegaMek game."
@@ -21,8 +21,8 @@ sha256sums=('SKIP'
'SKIP'
'7b3615680c9892099ab6e7b675e8e22baf9680d12a58050d46d71537a7fe0372'
'ca4459489d3c188b7418f7b596290accec61e2b190a58f4d0fd7593911d87597'
- '48642023e264f90a5831a9a9e91eda2bf33881d7d60f40979ff4e689c485714e'
- 'f1c3fd91d5e142dc1d800a8228ac66c4bc847a2b87a70b352845a2931b7392e6')
+ '7a5949eacb26b612b784211c5067d1042e86232b180a9f41530f2d6ecb4a4cc3'
+ 'c3d19a1933b36d29caf577c31f10683f2c99c0501fe3f23de678fcedae69f373')
pkgver() {
cd "$srcdir/${pkgname}"
diff --git a/megamek.patch b/megamek.patch
index e2707421b862..fc17183c9c40 100644
--- a/megamek.patch
+++ b/megamek.patch
@@ -1,17 +1,17 @@
-From cb58aa6c53d3c2725858292e2c94e0fbcd8f7727 Mon Sep 17 00:00:00 2001
-From: f43nd1r <lukas.morawietz@gmail.com>
-Date: Fri, 28 Feb 2020 04:42:37 +0100
-Subject: [PATCH] patch
+From fced44682cd09a83f4590253f8426eded3582458 Mon Sep 17 00:00:00 2001
+From: f43nd1r <account+github@faendir.com>
+Date: Sat, 6 Mar 2021 14:25:11 +0100
+Subject: [PATCH 1/1] patch
---
- .../src/megamek/common/MechSummaryCache.java | 24 +++++++++----------
- 1 file changed, 12 insertions(+), 12 deletions(-)
+ megamek/src/megamek/common/MechSummaryCache.java | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/megamek/src/megamek/common/MechSummaryCache.java b/megamek/src/megamek/common/MechSummaryCache.java
-index 8c71ab0106..0fee072c44 100644
+index 5332ce17e5..ee559fb3a0 100644
--- a/megamek/src/megamek/common/MechSummaryCache.java
+++ b/megamek/src/megamek/common/MechSummaryCache.java
-@@ -125,7 +125,7 @@ public class MechSummaryCache {
+@@ -112,7 +112,7 @@ public class MechSummaryCache {
* @return The path to the directory containing the unit cache.
*/
public static File getUnitCacheDir() {
@@ -20,3 +20,5 @@ index 8c71ab0106..0fee072c44 100644
}
public boolean isInitialized() {
+--
+2.30.1
diff --git a/megameklab.patch b/megameklab.patch
index 7f2827b64466..2528bfca53e3 100644
--- a/megameklab.patch
+++ b/megameklab.patch
@@ -1,30 +1,33 @@
-From 4b8c23714401e1d807d8c5646f9a0634a57736be Mon Sep 17 00:00:00 2001
-From: f43nd1r <lukas.morawietz@gmail.com>
-Date: Fri, 28 Feb 2020 03:48:19 +0100
-Subject: [PATCH] patch
+From 9463feb1f8b14650bf748863d2bcee3567c59cfb Mon Sep 17 00:00:00 2001
+From: f43nd1r <account+github@faendir.com>
+Date: Sat, 6 Mar 2021 14:37:36 +0100
+Subject: [PATCH 1/1] patch
---
- build.gradle | 2 +-
- mmconf/log4j.xml | 2 +-
- src/megameklab/com/MegaMekLab.java | 4 ++--
- src/megameklab/com/util/CConfig.java | 11 +++++++----
- 4 files changed, 11 insertions(+), 8 deletions(-)
+ build.gradle | 4 ++--
+ mmconf/log4j.xml | 4 ++--
+ src/megameklab/com/MegaMekLab.java | 6 +++---
+ src/megameklab/com/util/CConfig.java | 11 +++++++----
+ gradle/wrapper/gradle-wrapper.properties | 2 +-
+ 5 files changed, 15 insertions(+), 12 deletions(-)
diff --git a/build.gradle b/build.gradle
-index 174fa991..fd3ec200 100644
+index 769c4cfd..f3f99a03 100644
--- a/build.gradle
+++ b/build.gradle
@@ -31,7 +31,7 @@ ext {
mmlBranchTag = mmlBranch.equals('master')? '' : '-' + mmlBranch
// Allows setting a dependency on a different MM branch.
-- mmBranch = 'stable'
-+ mmBranch = 'master'
- mmBranchTag = mmBranch.equals('master')? '' : '-' + mmBranch
+- mmBranch = 'master'
+- mmBranchTag = mmBranch.equals('master')? '' : '-' + mmBranch
++ mmBranch = 'stable'
++ mmBranchTag = mmBranch.equals('stable')? '' : '-' + mmBranch
mmDir = '../megamek'
+ }
diff --git a/mmconf/log4j.xml b/mmconf/log4j.xml
-index 3e7b221b..3021859c 100644
+index 3e7b221b..d4a45eaf 100644
--- a/mmconf/log4j.xml
+++ b/mmconf/log4j.xml
@@ -5,7 +5,7 @@
@@ -37,33 +40,29 @@ index 3e7b221b..3021859c 100644
<param name="MaxFileSize" value="10MB"/>
<param name="MaxBackupIndex" value="5"/>
diff --git a/src/megameklab/com/MegaMekLab.java b/src/megameklab/com/MegaMekLab.java
-index 636ed977..01d11e6d 100644
+index 36caa504..69728a1d 100644
--- a/src/megameklab/com/MegaMekLab.java
+++ b/src/megameklab/com/MegaMekLab.java
-@@ -45,7 +45,7 @@ public class MegaMekLab {
- System.setProperty("apple.laf.useScreenMenuBar", "true");
- System.setProperty("com.apple.mrj.application.apple.menu.about.name","MegaMekLab");
-
-- String logFileName = "./logs/megameklablog.txt";
-+ String logFileName = "/var/log/megameklab/megameklab.log";
- Locale.setDefault(Locale.US);
-
- //Taharqa: I am not sure why this is here, so I am commenting it
-@@ -162,7 +162,7 @@ public class MegaMekLab {
- final String logFileName) {
- if (logs) {
- try {
-- File logPath = new File("./logs/");
-+ File logPath = new File("/var/log/megameklab/");
- if (!logPath.exists()) {
- logPath.mkdir();
- }
+@@ -70,11 +70,11 @@ public class MegaMekLab {
+ private static void redirectOutput() {
+ try {
+ System.out.println("Redirecting output to megameklablog.txt"); //$NON-NLS-1$
+- File logDir = new File("logs");
++ File logDir = new File("/var/log/megameklab/");
+ if (!logDir.exists()) {
+ logDir.mkdir();
+ }
+- final String logFilename = "logs" + File.separator + "megameklablog.txt";
++ final String logFilename = "/var/log/megameklab/megameklab.log";
+ MegaMek.resetLogFile(logFilename);
+ PrintStream ps = new PrintStream(
+ new BufferedOutputStream(
diff --git a/src/megameklab/com/util/CConfig.java b/src/megameklab/com/util/CConfig.java
-index 283b0a8d..70f9d045 100644
+index d0d7a20f..27b6744e 100644
--- a/src/megameklab/com/util/CConfig.java
+++ b/src/megameklab/com/util/CConfig.java
-@@ -31,9 +31,10 @@ import java.util.Properties;
- public class CConfig {
+@@ -61,9 +61,10 @@ public class CConfig {
+ }
// VARIABLES
- public static final String CONFIG_DIR = "./mmconf";
@@ -76,17 +75,28 @@ index 283b0a8d..70f9d045 100644
public static final String CONFIG_WEAPONS = "Weapons";
public static final String CONFIG_AMMO = "Ammo";
-@@ -84,7 +85,9 @@ public class CConfig {
+@@ -122,7 +123,9 @@ public class CConfig {
public CConfig() {
if(!new File(CONFIG_DIR).exists()) {
- new File(CONFIG_DIR).mkdir();
+ if(!new File(CONFIG_DIR).mkdirs()) {
-+ throw new RuntimeException("Failed to create directory "+ CONFIG_DIR);
++ throw new RuntimeException("Failed to create directory "+ CONFIG_DIR);
+ }
}
config = setDefaults();
+diff --git a/gradle/wrapper/gradle-wrapper.properties b/gradle/wrapper/gradle-wrapper.properties
+index ef9a9e05..442d9132 100644
+--- a/gradle/wrapper/gradle-wrapper.properties
++++ b/gradle/wrapper/gradle-wrapper.properties
+@@ -1,5 +1,5 @@
+ distributionBase=GRADLE_USER_HOME
+ distributionPath=wrapper/dists
+-distributionUrl=https\://services.gradle.org/distributions/gradle-5.6-bin.zip
++distributionUrl=https\://services.gradle.org/distributions/gradle-6.8.3-bin.zip
+ zipStoreBase=GRADLE_USER_HOME
+ zipStorePath=wrapper/dists
--
-2.25.1
+2.30.1