summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a2c5a291d868..39841ab898a5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,27 +1,23 @@
# Generated by mksrcinfo v8
-# Wed Apr 27 21:51:49 UTC 2016
+# Wed Jul 27 15:49:57 UTC 2016
pkgbase = megasync
pkgdesc = Sync your files to your Mega account. Official app
- pkgver = 2.9.1.0
+ pkgver = 2.9.5.0
pkgrel = 1
- url = https://mega.nz/#sync
+ url = https://github.com/meganz/megasync
install = megasync.install
arch = i686
arch = x86_64
license = custom:MEGA LIMITED CODE REVIEW LICENCE
makedepends = git
- depends = openssl
+ depends = curl
depends = c-ares
- depends = libgcrypt
depends = crypto++
depends = qt4
- depends = libpng
- depends = qtchooser
- depends = sqlite
depends = libuv
optdepends = sni-qt: fix systray issue on KDE and LXQt
conflicts = megatools
- source = git+https://github.com/meganz/MEGAsync.git#tag=v2_9_1_0_Linux
+ source = git+https://github.com/meganz/MEGAsync.git#tag=v2_9_5_0_Linux
source = megasync.install
md5sums = SKIP
md5sums = cf6fbb67643cc68baa8ea89bbd989fa0
diff --git a/PKGBUILD b/PKGBUILD
index f0a040469e3a..f6df57fc0052 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,15 @@
# Maintainer: Alfonso Saavedra "Son Link" <sonlink.dourden@gmail.com>
+# Maintainer: Hexchain Tong <i at hexchain dot org>
pkgname=megasync
-pkgver=2.9.1.0
+pkgver=2.9.5.0
_pkgver=${pkgver//./_}
pkgrel=1
pkgdesc="Sync your files to your Mega account. Official app"
arch=('i686' 'x86_64')
-url="https://mega.nz/#sync"
+url="https://github.com/meganz/megasync"
license=('custom:MEGA LIMITED CODE REVIEW LICENCE')
conflicts=('megatools')
-depends=('openssl' 'c-ares' 'libgcrypt' 'crypto++' 'qt4' 'libpng' 'qtchooser' 'sqlite' 'libuv')
+depends=('curl' 'c-ares' 'crypto++' 'qt4' 'libuv')
makedepends=('git')
optdepends=('sni-qt: fix systray issue on KDE and LXQt')
source=("git+https://github.com/meganz/MEGAsync.git#tag=v${_pkgver}_Linux"
@@ -27,7 +28,6 @@ build(){
./autogen.sh
./configure \
--disable-silent-rules \
- --disable-curl-checks \
--disable-megaapi \
--with-cryptopp \
--without-sodium \
@@ -38,7 +38,6 @@ build(){
--without-freeimage \
--without-readline \
--without-termcap \
- --disable-posix-threads \
--disable-examples \
--prefix=/usr