summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD21
2 files changed, 17 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5ac1dd4b6460..c519ab6ff4b6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,11 @@
pkgbase = megasync
pkgdesc = Sync your files to your Mega account. Official app
pkgver = 3.6.6.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/meganz/megasync
arch = i686
arch = x86_64
license = custom:MEGA LIMITED CODE REVIEW LICENCE
- makedepends = git
makedepends = qt5-tools
makedepends = swig
makedepends = doxygen
@@ -18,8 +17,10 @@ pkgbase = megasync
depends = qt5-svg
depends = libmediainfo
optdepends = sni-qt: fix systray issue on KDE and LXQt
- source = git+https://github.com/meganz/MEGAsync.git#tag=v3.6.6.0_Linux
- md5sums = SKIP
+ source = https://github.com/meganz/MEGAsync/archive/v3.6.6.0_Linux.tar.gz
+ source = https://github.com/meganz/sdk/archive/v3.3.8.tar.gz
+ sha256sums = 377a0b77b2506ebe0052d6366c3b5b74c3012cb4938e4df5e4b003677073f5fa
+ sha256sums = a64bf54b335ebbfc0138f4d81f3106bc4f02e9c1c8f840cd90515a7b34c01cd4
pkgname = megasync
diff --git a/PKGBUILD b/PKGBUILD
index ca8373990403..1b2bfb840f3d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,24 +6,27 @@
pkgname=megasync
pkgver=3.6.6.0
-pkgrel=1
+_sdkver=3.3.8
+pkgrel=2
pkgdesc="Sync your files to your Mega account. Official app"
arch=('i686' 'x86_64')
url="https://github.com/meganz/megasync"
license=('custom:MEGA LIMITED CODE REVIEW LICENCE')
depends=('c-ares' 'crypto++' 'libsodium' 'hicolor-icon-theme' 'libuv' 'qt5-svg' 'libmediainfo')
-makedepends=('git' 'qt5-tools' 'swig' 'doxygen')
+makedepends=('qt5-tools' 'swig' 'doxygen')
optdepends=('sni-qt: fix systray issue on KDE and LXQt')
-source=("git+https://github.com/meganz/MEGAsync.git#tag=v${pkgver}_Linux")
-md5sums=('SKIP')
+source=("https://github.com/meganz/MEGAsync/archive/v${pkgver}_Linux.tar.gz"
+ "https://github.com/meganz/sdk/archive/v${_sdkver}.tar.gz")
+sha256sums=('377a0b77b2506ebe0052d6366c3b5b74c3012cb4938e4df5e4b003677073f5fa'
+ 'a64bf54b335ebbfc0138f4d81f3106bc4f02e9c1c8f840cd90515a7b34c01cd4')
prepare(){
- cd "${srcdir}/MEGAsync"
- git submodule update --init --recursive
+ rm -rf MEGAsync-${pkgver}_Linux/src/MEGASync/mega
+ mv sdk-${_sdkver} MEGAsync-${pkgver}_Linux/src/MEGASync/mega
}
build(){
- cd "${srcdir}/MEGAsync/src/MEGASync/mega"
+ cd "MEGAsync-${pkgver}_Linux/src/MEGASync/mega"
./autogen.sh
./configure \
--prefix=/usr \
@@ -43,14 +46,14 @@ build(){
--without-termcap \
--without-ffmpeg
- cd "${srcdir}/MEGAsync/src"
+ cd "${srcdir}/MEGAsync-${pkgver}_Linux/src"
qmake-qt5 CONFIG+="release" MEGA.pro
lrelease-qt5 MEGASync/MEGASync.pro
make
}
package (){
- cd "${srcdir}/MEGAsync"
+ cd "MEGAsync-${pkgver}_Linux"
install -Dm 644 LICENCE.md "${pkgdir}/usr/share/licenses/megasync/LICENCE.md"
install -Dm 644 installer/terms.txt "${pkgdir}/usr/share/licenses/megasync/terms.txt"