summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
-rw-r--r--remove-static-tgkill.patch17
3 files changed, 27 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a7b5886b9912..a6a59a37d9c6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = megasync
pkgdesc = Easy automated syncing between your computers and your MEGA cloud drive
pkgver = 4.2.5
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/meganz/MEGAsync
arch = i686
arch = x86_64
@@ -24,8 +24,10 @@ pkgbase = megasync
optdepends = sni-qt: fix systray issue on KDE and LXQt
source = git+https://github.com/meganz/MEGAsync.git#tag=v4.2.5.0_Linux
source = meganz-sdk::git+https://github.com/meganz/sdk.git
+ source = remove-static-tgkill.patch
sha256sums = SKIP
sha256sums = SKIP
+ sha256sums = 1d100f2517f4dc2b3af38eaa4f52ffbe9fb348833384ae0befa3ec3caaac1786
pkgname = megasync
diff --git a/PKGBUILD b/PKGBUILD
index 38d916596f43..6843180640a8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgname=megasync
pkgver=4.2.5
-pkgrel=2
+pkgrel=3
pkgdesc="Easy automated syncing between your computers and your MEGA cloud drive"
arch=('i686' 'x86_64')
url="https://github.com/meganz/MEGAsync"
@@ -18,15 +18,19 @@ makedepends=('qt5-tools' 'swig' 'doxygen' 'lsb-release' 'git')
optdepends=('sni-qt: fix systray issue on KDE and LXQt')
_extname=".0_Linux"
source=("git+https://github.com/meganz/MEGAsync.git#tag=v${pkgver}${_extname}"
- "meganz-sdk::git+https://github.com/meganz/sdk.git")
+ "meganz-sdk::git+https://github.com/meganz/sdk.git"
+ "remove-static-tgkill.patch")
sha256sums=('SKIP'
- 'SKIP')
+ 'SKIP'
+ '1d100f2517f4dc2b3af38eaa4f52ffbe9fb348833384ae0befa3ec3caaac1786')
prepare() {
cd "MEGAsync"
git submodule init
git config submodule.src/MEGASync/mega.url "../meganz-sdk"
git submodule update
+
+ patch -Np1 -i "../remove-static-tgkill.patch"
}
build() {
diff --git a/remove-static-tgkill.patch b/remove-static-tgkill.patch
new file mode 100644
index 000000000000..9ae43a56f76d
--- /dev/null
+++ b/remove-static-tgkill.patch
@@ -0,0 +1,17 @@
+diff --git a/src/MEGASync/google_breakpad/client/linux/handler/exception_handler.cc b/src/MEGASync/google_breakpad/client/linux/handler/exception_handler.cc
+index 48f91682..d40de082 100644
+--- a/src/MEGASync/google_breakpad/client/linux/handler/exception_handler.cc
++++ b/src/MEGASync/google_breakpad/client/linux/handler/exception_handler.cc
+@@ -103,12 +103,6 @@
+ #define PR_SET_PTRACER 0x59616d61
+ #endif
+
+-// A wrapper for the tgkill syscall: send a signal to a specific thread.
+-static int tgkill(pid_t tgid, pid_t tid, int sig) {
+- return syscall(__NR_tgkill, tgid, tid, sig);
+- return 0;
+-}
+-
+ namespace google_breakpad {
+
+ namespace {