summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD26
2 files changed, 18 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6ff946dcf018..438b69ee5be7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Mon Jan 9 03:38:01 UTC 2017
+# Mon Feb 13 13:57:02 UTC 2017
pkgbase = megasync
pkgdesc = Sync your files to your Mega account. Official app
- pkgver = 2.9.10
+ pkgver = 3.0.1.0
pkgrel = 1
url = https://github.com/meganz/megasync
arch = i686
@@ -10,6 +10,8 @@ pkgbase = megasync
license = custom:MEGA LIMITED CODE REVIEW LICENCE
makedepends = git
makedepends = qt5-tools
+ makedepends = swig
+ makedepends = doxygen
depends = curl
depends = c-ares
depends = crypto++
@@ -18,7 +20,7 @@ pkgbase = megasync
depends = qt5-base
depends = libuv
optdepends = sni-qt: fix systray issue on KDE and LXQt
- source = git+https://github.com/meganz/MEGAsync.git#commit=2e03defad7e732afe5ffd6977eeb10558f25457b
+ source = git+https://github.com/meganz/MEGAsync.git#tag=v3.0.1.0_Linux
md5sums = SKIP
pkgname = megasync
diff --git a/PKGBUILD b/PKGBUILD
index 8bbaa0563053..f06083c145d8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,16 @@
# Maintainer: Alfonso Saavedra "Son Link" <sonlink.dourden@gmail.com>
# Maintainer: Hexchain Tong <i at hexchain dot org>
pkgname=megasync
-pkgver=2.9.10
-_pkgver=${pkgver//./_}
+pkgver=3.0.1.0
pkgrel=1
pkgdesc="Sync your files to your Mega account. Official app"
arch=('i686' 'x86_64')
url="https://github.com/meganz/megasync"
license=('custom:MEGA LIMITED CODE REVIEW LICENCE')
depends=('curl' 'c-ares' 'crypto++' 'libsodium' 'hicolor-icon-theme' 'qt5-base' 'libuv')
-makedepends=('git' 'qt5-tools')
+makedepends=('git' 'qt5-tools' 'swig' 'doxygen')
optdepends=('sni-qt: fix systray issue on KDE and LXQt')
-source=("git+https://github.com/meganz/MEGAsync.git#commit=2e03defad7e732afe5ffd6977eeb10558f25457b")
+source=("git+https://github.com/meganz/MEGAsync.git#tag=v${pkgver}_Linux")
md5sums=('SKIP')
prepare(){
@@ -23,20 +22,21 @@ build(){
cd "$srcdir/MEGAsync/src/MEGASync/mega"
./autogen.sh
./configure \
+ --prefix=/usr \
+ --disable-examples \
+ --disable-java \
+ --disable-php \
+ --disable-python \
+ --enable-chat \
--enable-gcc-hardening \
- --disable-silent-rules \
- --disable-megaapi \
+ --with-cares \
--with-cryptopp \
+ --with-curl \
--with-sodium \
- --with-zlib \
--with-sqlite \
- --with-cares \
- --with-curl \
+ --with-zlib \
--without-freeimage \
- --without-readline \
- --without-termcap \
- --disable-examples \
- --prefix=/usr
+ --without-termcap
cd "$srcdir/MEGAsync/src"
qmake-qt5 CONFIG+="release" MEGA.pro