summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD47
2 files changed, 31 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5b7a5687127b..5639207c4c63 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = megasync
- pkgdesc = Sync your files to your Mega account. Official app
+ pkgdesc = Easy automated syncing between your computers and your MEGA cloud drive
pkgver = 4.0.2.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/meganz/MEGAsync
arch = i686
arch = x86_64
@@ -20,9 +20,10 @@ pkgbase = megasync
depends = libmediainfo
depends = libraw
depends = qt5-base
+ depends = ffmpeg
optdepends = sni-qt: fix systray issue on KDE and LXQt
- source = git+https://github.com/meganz/MEGAsync.git#tag=v4.0.2.0_Linux
- source = git+https://github.com/meganz/sdk.git#commit=4dea1c5c03589655a1187dbea60dce2df1a69188
+ source = git+https://github.com/meganz/MEGAsync.git#tag=v4.0.2.0_Linux_Ubuntu_18.10build
+ source = meganz-sdk::git+https://github.com/meganz/sdk.git#commit=4dea1c5c03589655a1187dbea60dce2df1a69188
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index cdb56fa23cf4..142a509d588b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,56 +7,61 @@
pkgname=megasync
pkgver=4.0.2.0
-pkgrel=1
-pkgdesc="Sync your files to your Mega account. Official app"
+pkgrel=2
+pkgdesc="Easy automated syncing between your computers and your MEGA cloud drive"
arch=('i686' 'x86_64')
url="https://github.com/meganz/MEGAsync"
license=('custom:MEGA LIMITED CODE REVIEW LICENCE')
depends=('c-ares' 'crypto++' 'libsodium' 'hicolor-icon-theme' 'libuv'
- 'qt5-svg' 'libmediainfo' 'libraw' 'qt5-base')
+ 'qt5-svg' 'libmediainfo' 'libraw' 'qt5-base' 'ffmpeg')
makedepends=('qt5-tools' 'swig' 'doxygen' 'lsb-release' 'git')
optdepends=('sni-qt: fix systray issue on KDE and LXQt')
-_extname=Linux
+_extname="Linux_Ubuntu_18.10build"
_sdk_commit="4dea1c5c03589655a1187dbea60dce2df1a69188"
source=("git+https://github.com/meganz/MEGAsync.git#tag=v${pkgver}_${_extname}"
- "git+https://github.com/meganz/sdk.git#commit=${_sdk_commit}")
+ "meganz-sdk::git+https://github.com/meganz/sdk.git#commit=${_sdk_commit}")
sha256sums=('SKIP'
'SKIP')
-prepare(){
+prepare() {
cd "MEGAsync"
git submodule init
- git config submodule.src/MEGASync/mega.url "$srcdir/sdk"
+ git config submodule.src/MEGASync/mega.url "$srcdir/meganz-sdk"
git submodule update
}
-build(){
+build() {
+ # build sdk
cd "MEGAsync/src/MEGASync/mega"
./autogen.sh
./configure \
- --prefix=/usr \
- --disable-examples \
- --disable-java \
- --disable-php \
- --disable-python \
- --enable-chat \
- --with-cares \
+ --disable-shared \
+ --enable-static \
+ --disable-silent-rules \
+ --disable-curl-checks \
+ --disable-megaapi \
--with-cryptopp \
- --with-curl \
--with-sodium \
- --with-sqlite \
--with-zlib \
+ --with-sqlite \
+ --with-cares \
+ --with-curl \
--without-freeimage \
- --without-termcap \
- --without-ffmpeg
+ --with-libuv \
+ --disable-posix-threads \
+ --disable-examples \
+ --with-libzen \
+ --with-libmediainfo \
+ --prefix="${srcdir}/MEGAsync/src/MEGASync/mega/bindings/qt/3rdparty"
+ # build megasync
cd "../.."
- qmake-qt5 CONFIG+="release" MEGA.pro
+ qmake-qt5 "CONFIG += FULLREQUIREMENTS" MEGA.pro
lrelease-qt5 MEGASync/MEGASync.pro
make
}
-package (){
+package () {
cd "MEGAsync"
install -Dm 644 LICENCE.md "${pkgdir}/usr/share/licenses/megasync/LICENCE"
install -Dm 644 installer/terms.txt "${pkgdir}/usr/share/licenses/megasync/terms.txt"