summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rwxr-xr-xPKGBUILD7
-rw-r--r--ffmpeg.patch19
3 files changed, 16 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2ceb20e59ce9..78b2ecee550a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = megasync-nopdfium
pkgdesc = Easy automated syncing between your computers and your MEGA cloud drive(stripped of pdfium dependency)
- pkgver = 4.9.0.0
+ pkgver = 4.9.6.0
pkgrel = 1
url = https://github.com/meganz/MEGAsync
arch = i686
@@ -23,13 +23,13 @@ pkgbase = megasync-nopdfium
depends = libraw
depends = ffmpeg
depends = freeimage
- provides = megasync=4.9.0.0
+ provides = megasync=4.9.6.0
conflicts = megasync
- source = git+https://github.com/meganz/MEGAsync.git#tag=v4.9.0.0_Win
+ source = git+https://github.com/meganz/MEGAsync.git#tag=v4.9.6.0_Win
source = meganz-sdk::git+https://github.com/meganz/sdk.git
source = ffmpeg.patch
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = d5fcd4018a665e7a591ab796569777cf0a74fadc7c953f6879f37c949f82e7ae
+ sha256sums = feef2f0ff3c0f4ad29fd882fddfca038e8f6e4158fa8dc9af2248d2f83e1a083
pkgname = megasync-nopdfium
diff --git a/PKGBUILD b/PKGBUILD
index bb0495412ff4..2d9cd29833aa 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@
# Contributor : Hexchain Tong <i at hexchain dot org>
pkgname=megasync-nopdfium
-pkgver=4.9.0.0
+pkgver=4.9.6.0
pkgrel=1
pkgdesc="Easy automated syncing between your computers and your MEGA cloud drive(stripped of pdfium dependency)"
arch=('i686' 'x86_64')
@@ -26,17 +26,18 @@ source=("git+https://github.com/meganz/MEGAsync.git#tag=v${pkgver}${_extname}"
"ffmpeg.patch")
sha256sums=('SKIP'
'SKIP'
- 'd5fcd4018a665e7a591ab796569777cf0a74fadc7c953f6879f37c949f82e7ae')
+ 'feef2f0ff3c0f4ad29fd882fddfca038e8f6e4158fa8dc9af2248d2f83e1a083')
prepare() {
cd "MEGAsync"
git config submodule.src/MEGASync/mega.url "../meganz-sdk"
git -c protocol.file.allow=always submodule update --init
- git -C src/MEGASync/mega apply -v "$srcdir/ffmpeg.patch"
+ git -C src/MEGASync/mega/src/gfx apply -v "$srcdir/ffmpeg.patch"
cd "src/MEGASync"
sed -i '/DEFINES += REQUIRE_HAVE_PDFIUM/d' MEGASync.pro
sed -i '/CONFIG += USE_PDFIUM/d' MEGASync.pro
+
}
build() {
diff --git a/ffmpeg.patch b/ffmpeg.patch
index 9a1af1458e29..d9ebac2df7d3 100644
--- a/ffmpeg.patch
+++ b/ffmpeg.patch
@@ -1,8 +1,6 @@
-diff --git a/src/gfx/freeimage.cpp b/src/gfx/freeimage.cpp
-index 2f685279a..e4b0a8c4a 100644
---- a/src/gfx/freeimage.cpp
-+++ b/src/gfx/freeimage.cpp
-@@ -209,12 +209,6 @@ bool GfxProviderFreeImage::readbitmapFreeimage(FileSystemAccess*, const LocalPat
+--- freeimage.cpp.old 2023-10-10 17:44:29.522212542 -0300
++++ freeimage.cpp 2023-10-10 17:47:32.768202551 -0300
+@@ -209,11 +209,7 @@
#ifdef HAVE_FFMPEG
@@ -11,24 +9,23 @@ index 2f685279a..e4b0a8c4a 100644
-#else
-#define CAP_TRUNCATED CODEC_CAP_TRUNCATED
-#endif
--
++#define CAP_TRUNCATED 0
+
const char *GfxProviderFreeImage::supportedformatsFfmpeg()
{
- return ".264.265.3g2.3gp.3gpa.3gpp.3gpp2.mp3"
-@@ -313,7 +307,7 @@ bool GfxProviderFreeImage::readbitmapFfmpeg(FileSystemAccess* fa, const LocalPat
+@@ -313,7 +309,7 @@
// Find decoder for video stream
AVCodecID codecId = codecParm->codec_id;
-- AVCodec* decoder = avcodec_find_decoder(codecId);
+- auto decoder = avcodec_find_decoder(codecId);
+ const AVCodec* decoder = avcodec_find_decoder(codecId);
if (!decoder)
{
LOG_warn << "Codec not found: " << codecId;
-@@ -330,11 +324,6 @@ bool GfxProviderFreeImage::readbitmapFfmpeg(FileSystemAccess* fa, const LocalPat
+@@ -330,10 +326,6 @@
// Force seeking to key frames
formatContext->seek2any = false;
-- videoStream->skip_to_keyframe = true;
- if (decoder->capabilities & CAP_TRUNCATED)
- {
- codecContext->flags |= CAP_TRUNCATED;