summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD16
-rw-r--r--gif_main.patch44
3 files changed, 11 insertions, 59 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2b7087dabb5e..71b395bf3780 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,19 @@
pkgbase = meh-git
pkgdesc = A minimal image viewer using raw XLib.
- pkgver = 0.3.26.gce484db
- pkgrel = 2
+ pkgver = 0.3.56.ga8da4f8
+ pkgrel = 1
url = http://www.johnhawthorn.com/meh/
arch = i686
arch = x86_64
license = custom:MIT
+ makedepends = git
depends = libxext
depends = libjpeg
depends = giflib
depends = libpng
optdepends = imagemagick
conflicts = meh
- source = git+https://github.com/afarah1/meh.git
- source = gif_main.patch
+ source = git+https://github.com/andreasbaumann/meh.git#commit=a8da4f8a2f17e58a38777a37ddddbb1d1e941384
md5sums = SKIP
- md5sums = 38367b30851491dc818a2da365f55adc
pkgname = meh-git
-
diff --git a/PKGBUILD b/PKGBUILD
index d5c6d3257764..3d9040f3b51d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,19 @@
# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=meh-git
-pkgver=0.3.26.gce484db
-pkgrel=2
+pkgver=0.3.56.ga8da4f8
+pkgrel=1
pkgdesc="A minimal image viewer using raw XLib."
arch=('i686' 'x86_64')
url="http://www.johnhawthorn.com/meh/"
license=('custom:MIT')
depends=('libxext' 'libjpeg' 'giflib' 'libpng')
+makedepends=('git')
optdepends=('imagemagick')
conflicts=('meh')
-source=('git+https://github.com/afarah1/meh.git' gif_main.patch)
-md5sums=('SKIP' '38367b30851491dc818a2da365f55adc')
+_commit=a8da4f8a2f17e58a38777a37ddddbb1d1e941384
+source=("git+https://github.com/andreasbaumann/meh.git#commit=$_commit")
+md5sums=('SKIP')
_gitname=meh
pkgver () {
@@ -20,11 +22,6 @@ pkgver () {
git describe --tags |sed s+-+.+g | cut -c2-
}
-prepare() {
- cd "$srcdir/$_gitname"
- patch -Np1 < "$srcdir"/gif_main.patch
-}
-
build() {
cd $srcdir/$_gitname
make PREFIX=/usr
@@ -37,3 +34,4 @@ package() {
}
+
diff --git a/gif_main.patch b/gif_main.patch
deleted file mode 100644
index 63b27c4e54ff..000000000000
--- a/gif_main.patch
+++ /dev/null
@@ -1,44 +0,0 @@
-diff -Naur meh/src/gif.c meh.new/src/gif.c
---- meh/src/gif.c 2015-09-27 21:35:45.745053456 +0200
-+++ meh.new/src/gif.c 2015-10-11 00:35:49.251559414 +0200
-@@ -1,4 +1,3 @@
--
- #include <stdio.h>
- #include <stdlib.h>
- #include <string.h>
-@@ -97,14 +96,14 @@
- void gif_close(struct image *img){
- struct gif_t *g = (struct gif_t *)img;
- #if defined(GIFLIB_MAJOR) && defined(GIFLIB_MINOR) && (GIFLIB_MAJOR == 5 && GIFLIB_MINOR >= 1)
-- int ret;
-+ int ret, ErrorCode;
- #endif
-
- #if defined(GIFLIB_MAJOR) && defined(GIFLIB_MINOR) && (GIFLIB_MAJOR == 5 && GIFLIB_MINOR >= 1)
-- DGifCloseFile(g->gif,&ret);
-+ ret = DGifCloseFile(g->gif, &ErrorCode);
- if(ret != GIF_OK) {
- #if defined(GIFLIB_MAJOR) && GIFLIB_MAJOR >= 5
-- fprintf(stderr, "GIFLIB: %s\n", GifErrorString(ret));
-+ fprintf(stderr, "GIFLIB: %s\n", GifErrorString(ErrorCode));
- #elif defined(GIFLIB_MAJOR) && defined(GIFLIB_MINOR) && ((GIFLIB_MAJOR == 4 && GIFLIB_MINOR >= 2) || GIFLIB_MAJOR > 4)
- fprintf(stderr, "GIFLIB: %s\n", GifErrorString());
- #else
-@@ -123,4 +122,3 @@
- gif_read,
- gif_close
- };
--
-diff -Naur meh/src/main.c meh.new/src/main.c
---- meh/src/main.c 2015-09-27 21:35:45.745053456 +0200
-+++ meh.new/src/main.c 2015-10-11 00:33:43.315710489 +0200
-@@ -1,4 +1,3 @@
--
- #define _GNU_SOURCE
- #include <unistd.h>
-
-@@ -329,4 +328,3 @@
- return 0;
- }
-
--