summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD7
-rw-r--r--TargetRegistry.h-was-moved-to-MC-folder.patch27
3 files changed, 32 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 287983b17593..8a1dbf34bf9b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -60,6 +60,7 @@ pkgbase = mesa-git
conflicts = vulkan-swrast
source = mesa::git+https://gitlab.freedesktop.org/mesa/mesa.git#branch=main
source = LICENSE
+ source = TargetRegistry.h-was-moved-to-MC-folder.patch
md5sums = SKIP
md5sums = 5c65a0fe315dd347e09b1f2826a1df5a
sha512sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index be8eccc27aa5..38d2a8016e25 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,7 +12,7 @@
pkgname=mesa-git
pkgdesc="an open-source implementation of the OpenGL specification, git version"
-pkgver=21.3.0_devel.144808.b1eb0887922
+pkgver=21.3.0_devel.146031.6b9e12ea256
pkgrel=1
arch=('x86_64')
makedepends=('git' 'python-mako' 'xorgproto'
@@ -27,13 +27,14 @@ url="https://www.mesa3d.org"
license=('custom')
source=('mesa::git+https://gitlab.freedesktop.org/mesa/mesa.git#branch=main'
'LICENSE'
+ 'TargetRegistry.h-was-moved-to-MC-folder.patch'
)
md5sums=('SKIP'
'5c65a0fe315dd347e09b1f2826a1df5a'
-)
+ 'a18664df6502a61490d305ab32c13365')
sha512sums=('SKIP'
'25da77914dded10c1f432ebcbf29941124138824ceecaf1367b3deedafaecabc082d463abcfa3d15abff59f177491472b505bcb5ba0c4a51bb6b93b4721a23c2'
-)
+ '01e05fe2e08e2926ebb4c7e7f9f3095dbf31c706e8dab901a46300458f78df7de15d8ea5d2d11ac71d9175806194699d674e8cd1196f76e7f563eb7694f9e419')
# NINJAFLAGS is an env var used to pass commandline options to ninja
# NOTE: It's your responbility to validate the value of $NINJAFLAGS. If unsure, don't set it.
diff --git a/TargetRegistry.h-was-moved-to-MC-folder.patch b/TargetRegistry.h-was-moved-to-MC-folder.patch
new file mode 100644
index 000000000000..f903fff90944
--- /dev/null
+++ b/TargetRegistry.h-was-moved-to-MC-folder.patch
@@ -0,0 +1,27 @@
+diff --unified --recursive --text mesa.orig/src/gallium/frontends/clover/llvm/codegen/native.cpp mesa.new/src/gallium/frontends/clover/llvm/codegen/native.cpp
+--- mesa.orig/src/gallium/frontends/clover/llvm/codegen/native.cpp 2021-10-09 12:43:48.935462036 +0200
++++ mesa.new/src/gallium/frontends/clover/llvm/codegen/native.cpp 2021-10-09 13:25:54.763196300 +0200
+@@ -28,7 +28,6 @@
+ ///
+
+ #include <llvm/Target/TargetMachine.h>
+-#include <llvm/Support/TargetRegistry.h>
+ #include <llvm/Transforms/Utils/Cloning.h>
+
+ #include "llvm/codegen.hpp"
+diff --unified --recursive --text mesa.orig/src/gallium/frontends/clover/llvm/compat.hpp mesa.new/src/gallium/frontends/clover/llvm/compat.hpp
+--- mesa.orig/src/gallium/frontends/clover/llvm/compat.hpp 2021-10-09 12:43:48.935462036 +0200
++++ mesa.new/src/gallium/frontends/clover/llvm/compat.hpp 2021-10-09 13:25:16.192571949 +0200
+@@ -56,6 +56,12 @@
+ #include <llvm/Support/CodeGen.h>
+ #endif
+
++#if LLVM_VERSION_MAJOR >= 13
++#include <llvm/MC/TargetRegistry.h>
++#else
++#include <llvm/Support/TargetRegistry.h>
++#endif
++
+ namespace clover {
+ namespace llvm {
+ namespace compat {