summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
2 files changed, 4 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0b48b3840ad9..4bfc0a749280 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -28,13 +28,13 @@ pkgbase = mesa-minimal+-git
depends = libelf
depends = libglvnd
depends = wayland
- depends = libclc
depends = vulkan-icd-loader
depends = zstd
depends = llvm-libs
depends = lib32-llvm-libs=11.0.0
optdepends = opengl-man-pages: for the OpenGL API man pages
optdepends = llvm-minimal-git: opencl
+ optdepends = libclc: opencl
provides = mesa
provides = opencl-mesa
provides = vulkan-intel
diff --git a/PKGBUILD b/PKGBUILD
index 586b9b352850..dfd91121c2fa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -19,10 +19,11 @@ makedepends=('git' 'python-mako' 'xorgproto'
'libxml2' 'libx11' 'libvdpau' 'libva' 'elfutils' 'libxrandr'
'ocl-icd' 'wayland-protocols' 'meson' 'ninja' 'glslang' 'llvm')
depends=('libdrm' 'libxxf86vm' 'libxdamage' 'libxshmfence' 'libelf'
- 'libglvnd' 'wayland' 'libclc' 'vulkan-icd-loader' 'zstd' 'llvm-libs')
+ 'libglvnd' 'wayland' 'vulkan-icd-loader' 'zstd' 'llvm-libs')
# In order to keep the package simple and ease troubleshooting only use one llvm implementation
optdepends=('opengl-man-pages: for the OpenGL API man pages'
- 'llvm-minimal-git: opencl')
+ 'llvm-minimal-git: opencl'
+ 'libclc: opencl')
provides=('mesa' 'opencl-mesa' 'vulkan-intel' 'vulkan-radeon' 'vulkan-mesa-layer' 'libva-mesa-driver' 'vulkan-swrast' 'vulkan-driver' 'opengl-driver' 'opencl-driver')
conflicts=('mesa' 'opencl-mesa' 'vulkan-intel' 'vulkan-radeon' 'vulkan-mesa-layer' 'libva-mesa-driver' 'vulkan-swrast' 'mesa-vdpau')
# mixing components from different mesa versions is a bad idea, conflict with everything unique provided by extra/mesa
@@ -139,7 +140,6 @@ build () {
-D enable-glcpp-tests=false \
-D opencl-native=false
-
meson configure _build
ninja $NINJAFLAGS -C _build