summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD21
-rw-r--r--filter_measure.patch10
-rw-r--r--filter_mutualinfo.patch9
-rw-r--r--filter_sketchfab.patch10
-rw-r--r--filter_voronoi.patch9
6 files changed, 67 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9fa7a7c7e778..996a3b812325 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = meshlab
pkgdesc = System for processing and editing of unstructured 3D models arising in 3D scanning (qt5 version)
pkgver = 2016.12
- pkgrel = 5
+ pkgrel = 6
url = http://www.meshlab.net
install = meshlab.install
arch = i686
@@ -22,6 +22,10 @@ pkgbase = meshlab
provides = meshlab
source = git+https://github.com/cnr-isti-vclab/meshlab.git#tag=v2016.12
source = git+https://github.com/cnr-isti-vclab/vcglib.git#tag=v1.0.1
+ source = filter_measure.patch
+ source = filter_mutualinfo.patch
+ source = filter_sketchfab.patch
+ source = filter_voronoi.patch
source = ssynth.patch
source = screened_poisson.patch
source = plugin_dir.patch
@@ -40,6 +44,10 @@ pkgbase = meshlab
source = meshlab.desktop
md5sums = SKIP
md5sums = SKIP
+ md5sums = 4926e8a14215fc33167208d629678a18
+ md5sums = b3401d7bc450d0785ac8798abf276aca
+ md5sums = c74be839f3efa9341472357b3e238ea8
+ md5sums = 8f58bb2aee9855d7aea88a00e4186770
md5sums = fcf9148ad21706f4fef558a254bee4e2
md5sums = d9c9e9160ee16694a225819ee4598be4
md5sums = f13d58ca07fa74b3d7c8f7f9d4ee6a93
diff --git a/PKGBUILD b/PKGBUILD
index b1bec79d2d3e..a72931db18b2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: bartus <aur@bartus.33mail.com>
pkgname=meshlab
pkgver=2016.12
-pkgrel=5
+pkgrel=6
pkgdesc="System for processing and editing of unstructured 3D models arising in 3D scanning (qt5 version)"
arch=('i686' 'x86_64')
url="http://www.meshlab.net"
@@ -9,10 +9,15 @@ provides=('meshlab')
license=('GPL2')
depends=('bzip2' 'muparser' 'levmar' 'lib3ds' 'desktop-file-utils' 'glu' 'mpir' 'openssl-1.0' 'qt5-base' 'qt5-declarative' 'qt5-script')
makedepends=('git')
+#options=(debug !strip)
#also create openctm(aur) jhead-lib structuresynth-lib to handle last dep
install="${pkgname}.install"
source=("git+https://github.com/cnr-isti-vclab/meshlab.git#tag=v2016.12"
"git+https://github.com/cnr-isti-vclab/vcglib.git#tag=v1.0.1"
+ "filter_measure.patch"
+ "filter_mutualinfo.patch"
+ "filter_sketchfab.patch"
+ "filter_voronoi.patch"
"ssynth.patch"
"screened_poisson.patch"
"plugin_dir.patch"
@@ -31,6 +36,10 @@ source=("git+https://github.com/cnr-isti-vclab/meshlab.git#tag=v2016.12"
"meshlab.desktop")
md5sums=('SKIP'
'SKIP'
+ '4926e8a14215fc33167208d629678a18'
+ 'b3401d7bc450d0785ac8798abf276aca'
+ 'c74be839f3efa9341472357b3e238ea8'
+ '8f58bb2aee9855d7aea88a00e4186770'
'fcf9148ad21706f4fef558a254bee4e2'
'd9c9e9160ee16694a225819ee4598be4'
'f13d58ca07fa74b3d7c8f7f9d4ee6a93'
@@ -84,6 +93,16 @@ prepare() {
patch -Np1 -i ../screened_poisson.patch
msg "compile ssynth with -fopenmp flag"
patch -Np1 -i ../ssynth.patch
+
+ msg "fix filter measure plugin"
+ patch -Np1 -i ../filter_measure.patch
+ msg "fix filter mutualinfo plugin"
+ patch -Np1 -i ../filter_mutualinfo.patch
+ msg "fix filter skatchfab plugin"
+ patch -Np1 -i ../filter_sketchfab.patch
+ msg "fix filter voronoi.patch"
+ patch -Np1 -i ../filter_voronoi.patch
+
msg "fix bundel/nvm ReadHeader"
cd ${srcdir}/vcglib
patch -Np1 -i ../import_bundle_out.patch
diff --git a/filter_measure.patch b/filter_measure.patch
new file mode 100644
index 000000000000..bdc8da34af68
--- /dev/null
+++ b/filter_measure.patch
@@ -0,0 +1,10 @@
+diff --git a/src/meshlabplugins/filter_measure/filter_measure.pro b/src/meshlabplugins/filter_measure/filter_measure.pro
+index 3f781354..2dec69f4 100644
+--- a/src/meshlabplugins/filter_measure/filter_measure.pro
++++ b/src/meshlabplugins/filter_measure/filter_measure.pro
+@@ -6,4 +6,4 @@ TARGET = filter_measure
+ #PRE_TARGETDEPS += filter_measure.xml
+
+ macx:QMAKE_POST_LINK = "cp "$$_PRO_FILE_PWD_/$$TARGET".xml ../../distrib/plugins/"$$TARGET".xml"
+-
++linux:QMAKE_POST_LINK = "cp "$$_PRO_FILE_PWD_/$$TARGET".xml ../../distrib/plugins/"$$TARGET".xml; cd ../../distrib/plugins/ ; ln -s "$$TARGET".xml lib"$$TARGET".xml"
diff --git a/filter_mutualinfo.patch b/filter_mutualinfo.patch
new file mode 100644
index 000000000000..1671ec30d963
--- /dev/null
+++ b/filter_mutualinfo.patch
@@ -0,0 +1,9 @@
+diff --git a/src/meshlabplugins/filter_mutualinfoxml/filter_mutualinfoxml.pro b/src/meshlabplugins/filter_mutualinfoxml/filter_mutualinfoxml.pro
+index f3eabaa7..a65c0cce 100644
+--- a/src/meshlabplugins/filter_mutualinfoxml/filter_mutualinfoxml.pro
++++ b/src/meshlabplugins/filter_mutualinfoxml/filter_mutualinfoxml.pro
+@@ -21,3 +21,4 @@ SOURCES += filter_mutualinfo.cpp \
+ TARGET = filter_mutualinfo
+
+ macx:QMAKE_POST_LINK = "cp "$$_PRO_FILE_PWD_/$$TARGET".xml ../../distrib/plugins/"$$TARGET".xml"
++linux:QMAKE_POST_LINK = "cp "$$_PRO_FILE_PWD_/$$TARGET".xml ../../distrib/plugins/"$$TARGET".xml; cd ../../distrib/plugins/ ; ln -s "$$TARGET".xml lib"$$TARGET".xml"
diff --git a/filter_sketchfab.patch b/filter_sketchfab.patch
new file mode 100644
index 000000000000..e333e3d970df
--- /dev/null
+++ b/filter_sketchfab.patch
@@ -0,0 +1,10 @@
+diff --git a/src/plugins_experimental/filter_sketchfab/filter_sketchfab.pro b/src/plugins_experimental/filter_sketchfab/filter_sketchfab.pro
+index 75674cf2..9f7f0542 100644
+--- a/src/plugins_experimental/filter_sketchfab/filter_sketchfab.pro
++++ b/src/plugins_experimental/filter_sketchfab/filter_sketchfab.pro
+@@ -5,4 +5,4 @@ SOURCES += filter_sketchfab.cpp $$VCGDIR//wrap/ply/plylib.cpp
+ TARGET = filter_sketchfab
+ #PRE_TARGETDEPS += filter_sketchfab.xml
+ macx:QMAKE_POST_LINK = "cp "$$_PRO_FILE_PWD_/$$TARGET".xml ../../distrib/plugins/"$$TARGET".xml"
+-
++linux:QMAKE_POST_LINK = "cp "$$_PRO_FILE_PWD_/$$TARGET".xml ../../distrib/plugins/"$$TARGET".xml; cd ../../distrib/plugins/ ; ln -s "$$TARGET".xml lib"$$TARGET".xml"
diff --git a/filter_voronoi.patch b/filter_voronoi.patch
new file mode 100644
index 000000000000..998b15ee4f8c
--- /dev/null
+++ b/filter_voronoi.patch
@@ -0,0 +1,9 @@
+diff --git a/src/meshlabplugins/filter_voronoi/filter_voronoi.pro b/src/meshlabplugins/filter_voronoi/filter_voronoi.pro
+index 423f1573..03b83a33 100644
+--- a/src/meshlabplugins/filter_voronoi/filter_voronoi.pro
++++ b/src/meshlabplugins/filter_voronoi/filter_voronoi.pro
+@@ -8,3 +8,4 @@ TARGET = filter_voronoi
+ #PRE_TARGETDEPS += filter_voronoi.xml
+
+ macx:QMAKE_POST_LINK = "rsync -u "$$TARGET".xml ../../distrib/plugins/"$$TARGET".xml; rsync -u ../../distrib/plugins/"$$TARGET".xml "$$TARGET".xml"
++linux:QMAKE_POST_LINK = "cp "$$_PRO_FILE_PWD_/$$TARGET".xml ../../distrib/plugins/"$$TARGET".xml; cd ../../distrib/plugins/ ; ln -s "$$TARGET".xml lib"$$TARGET".xml"