summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD39
-rw-r--r--ssynth.patch26
3 files changed, 51 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8b9aa0720b19..ff2d3654798a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -14,13 +14,14 @@ pkgbase = meshlab
depends = desktop-file-utils
depends = glu
depends = mpir
- depends = openssl
+ depends = openssl-1.0
depends = qt5-base
depends = qt5-declarative
depends = qt5-script
provides = meshlab
source = git+https://github.com/cnr-isti-vclab/meshlab.git#tag=v2016.12
source = git+https://github.com/cnr-isti-vclab/vcglib.git#tag=v1.0.1
+ source = ssynth.patch
source = screened_poisson.patch
source = plugin_dir.patch
source = shaders_dir.patch
@@ -37,6 +38,7 @@ pkgbase = meshlab
source = meshlab.desktop
md5sums = SKIP
md5sums = SKIP
+ md5sums = fcf9148ad21706f4fef558a254bee4e2
md5sums = d9c9e9160ee16694a225819ee4598be4
md5sums = f13d58ca07fa74b3d7c8f7f9d4ee6a93
md5sums = 753dd4753081ddb428f4db8eaefe9009
diff --git a/PKGBUILD b/PKGBUILD
index b15a14a2f963..10a5fb8fc551 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,11 +7,13 @@ arch=('i686' 'x86_64')
url="http://www.meshlab.net"
provides=('meshlab')
license=('GPL2')
-depends=('bzip2' 'muparser' 'levmar' 'lib3ds' 'desktop-file-utils' 'glu' 'mpir' 'openssl' 'qt5-base' 'qt5-declarative' 'qt5-script')
+depends=('bzip2' 'muparser' 'levmar' 'lib3ds' 'desktop-file-utils' 'glu' 'mpir' 'openssl-1.0' 'qt5-base' 'qt5-declarative' 'qt5-script')
+makedepends=('git')
#also create openctm(aur) jhead-lib structuresynth-lib to handle last dep
install="${pkgname}.install"
source=("git+https://github.com/cnr-isti-vclab/meshlab.git#tag=v2016.12"
"git+https://github.com/cnr-isti-vclab/vcglib.git#tag=v1.0.1"
+ "ssynth.patch"
"screened_poisson.patch"
"plugin_dir.patch"
"shaders_dir.patch"
@@ -28,6 +30,7 @@ source=("git+https://github.com/cnr-isti-vclab/meshlab.git#tag=v2016.12"
"meshlab.desktop")
md5sums=('SKIP'
'SKIP'
+ 'fcf9148ad21706f4fef558a254bee4e2'
'd9c9e9160ee16694a225819ee4598be4'
'f13d58ca07fa74b3d7c8f7f9d4ee6a93'
'753dd4753081ddb428f4db8eaefe9009'
@@ -44,39 +47,41 @@ md5sums=('SKIP'
'18aed0a21276a22325bf8c32166fb110')
prepare() {
- cd "${srcdir}"
+ cd ${srcdir}/${pkgname}
# remove bundled headers and libraries
- rm -fr meshlab/src/external/{inc,lib}
+ rm -fr src/external/{inc,lib}
msg "truncate external lib"
- patch -Np0 -i external.patch
+ patch -Np1 -i ../external.patch
msg "fix rpath"
- patch -Np0 -i rpath.patch
+ patch -Np1 -i ../rpath.patch
msg "fix meshlab/src/plugins_experimental/io_TXT/ case sensitive path"
- mv meshlab/src/plugins_experimental/io_TXT/io_txt.pro meshlab/src/plugins_experimental/io_TXT/io_TXT.pro
+ mv src/plugins_experimental/io_TXT/io_txt.pro src/plugins_experimental/io_TXT/io_TXT.pro
msg "fix meshalbserver missing -lGLU"
- patch -Np0 -i meshlabserver_GLU.patch
+ patch -Np1 -i ../meshlabserver_GLU.patch
msg "fix cpp11 abs()"
- patch -Np0 -i cpp11_abs.patch
+ patch -Np1 -i ../cpp11_abs.patch
msg "fix decimal separator problem"
- patch -Np0 -i fix_locale.patch
+ patch -Np1 -i ../fix_locale.patch
msg "using system mpir lib"
- patch -Np0 -i mpir.patch
+ patch -Np1 -i ../mpir.patch
msg "using system bzip2 lib"
- patch -Np0 -i bzip2.patch
+ patch -Np1 -i ../bzip2.patch
msg "using system muparser lib"
- patch -Np0 -i muparser.patch
+ patch -Np1 -i ../muparser.patch
msg "using system levmar lib"
- patch -Np0 -i levmar.patch
+ patch -Np1 -i ../levmar.patch
msg "using system 3ds lib"
- patch -Np0 -i 3ds.patch
+ patch -Np1 -i ../3ds.patch
msg "move plugins to /usr/lib/plugins"
- patch -Np0 -i plugin_dir.patch
+ patch -Np1 -i ../plugin_dir.patch
msg "move shaders to /usr/share/meshlab/shaders"
- patch -Np0 -i shaders_dir.patch
+ patch -Np1 -i ../shaders_dir.patch
msg "fix screened poisson linux compilation"
- patch -Np0 -i screened_poisson.patch
+ patch -Np1 -i ../screened_poisson.patch
+ msg "compile ssynth with -fopenmp flag"
+ patch -Np1 -i ../ssynth.patch
}
build() {
diff --git a/ssynth.patch b/ssynth.patch
new file mode 100644
index 000000000000..459c0f411e27
--- /dev/null
+++ b/ssynth.patch
@@ -0,0 +1,26 @@
+diff --git a/src/external/structuresynth-1.5/structuresynth.pro b/src/external/structuresynth-1.5/structuresynth.pro
+index b946f88b..a019ba48 100644
+--- a/src/external/structuresynth-1.5/structuresynth.pro
++++ b/src/external/structuresynth-1.5/structuresynth.pro
+@@ -2,6 +2,8 @@ TEMPLATE = lib
+ TARGET = ssynth
+ CONFIG += staticlib
+
++QMAKE_CXXFLAGS+=-fopenmp
++
+ DEPENDPATH += . \
+ ssynth \
+ ssynth/StructureSynth/Model \
+diff --git a/src/meshlabplugins/filter_ssynth/filter_ssynth.pro b/src/meshlabplugins/filter_ssynth/filter_ssynth.pro
+index 5ab0cd36..dd5506a7 100644
+--- a/src/meshlabplugins/filter_ssynth/filter_ssynth.pro
++++ b/src/meshlabplugins/filter_ssynth/filter_ssynth.pro
+@@ -18,6 +18,8 @@ win32-msvc2012:LIBS += ../../external/lib/win32-msvc2012/ssynth.lib
+ win32-msvc2015:LIBS += ../../external/lib/win32-msvc2015/ssynth.lib
+ win32-g++:LIBS += ../../external/lib/win32-gcc/libssynth.a
+ linux-g++:LIBS += ../../external/lib/linux-g++/libssynth.a
++linux-g++:LIBS += -lgomp
++QMAKE_CXXFLAGS+=-fopenmp
+ macx:LIBS += ../../external/lib/macx64/libssynth.a
+ TARGET = filter_ssynth
+ TEMPLATE = lib