summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
-rw-r--r--nullptr.patch24
3 files changed, 34 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0b4a5dd1272a..0338344f7070 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
+# Generated by mksrcinfo v8
+# Mon May 23 02:57:46 UTC 2016
pkgbase = meshlab
pkgdesc = System for processing and editing triangular meshes
pkgver = 1.3.3
- pkgrel = 4
+ pkgrel = 5
url = http://meshlab.sourceforge.net/
install = meshlab.install
arch = i686
@@ -19,6 +21,7 @@ pkgbase = meshlab
source = gcc-4.7.patch
source = lapack.patch
source = mpir.patch
+ source = nullptr.patch
source = rpath.patch
source = qt-4.8.patch
source = meshlab.1
@@ -28,6 +31,7 @@ pkgbase = meshlab
md5sums = 65d7ff92ad2d6e74119af9c0e377bb37
md5sums = 4139d3217f1540c67306545213126391
md5sums = 308f1b90f7de56f9df1485808713ed53
+ md5sums = c8689554179380947a118a493a564715
md5sums = 2cc1246fc1b01029ae762c82a7dbf364
md5sums = 1df4ee299f4ad996a05e80d9cf5e5389
md5sums = 32a52b0a8dab1b4816b028b463e7fd9c
diff --git a/PKGBUILD b/PKGBUILD
index ac4ca484d0b4..ca39eaa443fb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Jonathan Liu <net147@gmail.com>
pkgname=meshlab
pkgver=1.3.3
-pkgrel=4
+pkgrel=5
pkgdesc="System for processing and editing triangular meshes"
arch=('i686' 'x86_64')
url="http://meshlab.sourceforge.net/"
@@ -12,6 +12,7 @@ source=("http://downloads.sourceforge.net/project/meshlab/meshlab/MeshLab%20v${p
"gcc-4.7.patch"
"lapack.patch"
"mpir.patch"
+ "nullptr.patch"
"rpath.patch"
"qt-4.8.patch"
"meshlab.1"
@@ -22,6 +23,7 @@ md5sums=('cbdd83d4f3ed69e7a9837c34ebae307a'
'65d7ff92ad2d6e74119af9c0e377bb37'
'4139d3217f1540c67306545213126391'
'308f1b90f7de56f9df1485808713ed53'
+ 'c8689554179380947a118a493a564715'
'2cc1246fc1b01029ae762c82a7dbf364'
'1df4ee299f4ad996a05e80d9cf5e5389'
'32a52b0a8dab1b4816b028b463e7fd9c'
@@ -46,6 +48,8 @@ prepare() {
patch -Np2 -i "${srcdir}/lapack.patch"
# use system mpir
patch -Np2 -i "${srcdir}/mpir.patch"
+ # fix use of bool to return null pointer
+ patch -Np2 -i "${srcdir}/nullptr.patch"
# fix rpath
patch -Np2 -i "${srcdir}/rpath.patch"
}
diff --git a/nullptr.patch b/nullptr.patch
new file mode 100644
index 000000000000..f212f30fc00d
--- /dev/null
+++ b/nullptr.patch
@@ -0,0 +1,24 @@
+diff -Nur meshlab.orig/src/external/structuresynth/ssynth/SyntopiaCore/GLEngine/Raytracer/VoxelStepper.cpp meshlab/src/external/structuresynth/ssynth/SyntopiaCore/GLEngine/Raytracer/VoxelStepper.cpp
+--- meshlab.orig/src/external/structuresynth/ssynth/SyntopiaCore/GLEngine/Raytracer/VoxelStepper.cpp 2013-05-23 01:09:58.000000000 +1000
++++ meshlab/src/external/structuresynth/ssynth/SyntopiaCore/GLEngine/Raytracer/VoxelStepper.cpp 2016-05-23 12:55:48.495725226 +1000
+@@ -122,7 +122,7 @@
+ currentT = p;
+
+ // We do not intersect grid.
+- if (!found) return false;
++ if (!found) return 0;
+ }
+
+ stepX = (dir.x() > 0) ? 1 : -1;
+diff -Nur meshlab.orig/src/external/structuresynth-1.5/ssynth/SyntopiaCore/GLEngine/Raytracer/VoxelStepper.cpp meshlab/src/external/structuresynth-1.5/ssynth/SyntopiaCore/GLEngine/Raytracer/VoxelStepper.cpp
+--- meshlab.orig/src/external/structuresynth-1.5/ssynth/SyntopiaCore/GLEngine/Raytracer/VoxelStepper.cpp 2014-02-07 20:38:23.000000000 +1100
++++ meshlab/src/external/structuresynth-1.5/ssynth/SyntopiaCore/GLEngine/Raytracer/VoxelStepper.cpp 2016-05-23 12:55:58.752439956 +1000
+@@ -122,7 +122,7 @@
+ currentT = p;
+
+ // We do not intersect grid.
+- if (!found) return false;
++ if (!found) return 0;
+ }
+
+ stepX = (dir.x() > 0) ? 1 : -1;