summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
-rw-r--r--screened_poisson.patch18
3 files changed, 26 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index db9532909e60..8b9aa0720b19 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = meshlab
pkgdesc = System for processing and editing of unstructured 3D models arising in 3D scanning (qt5 version)
pkgver = 2016.12
- pkgrel = 2
+ pkgrel = 3
url = http://www.meshlab.net
install = meshlab.install
arch = i686
@@ -21,6 +21,7 @@ pkgbase = meshlab
provides = meshlab
source = git+https://github.com/cnr-isti-vclab/meshlab.git#tag=v2016.12
source = git+https://github.com/cnr-isti-vclab/vcglib.git#tag=v1.0.1
+ source = screened_poisson.patch
source = plugin_dir.patch
source = shaders_dir.patch
source = external.patch
@@ -36,6 +37,7 @@ pkgbase = meshlab
source = meshlab.desktop
md5sums = SKIP
md5sums = SKIP
+ md5sums = d9c9e9160ee16694a225819ee4598be4
md5sums = f13d58ca07fa74b3d7c8f7f9d4ee6a93
md5sums = 753dd4753081ddb428f4db8eaefe9009
md5sums = 038494125d7bd422074fc5635c5579ca
diff --git a/PKGBUILD b/PKGBUILD
index 3080c4f665da..b15a14a2f963 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: bartus <aur@bartus.33mail.com>
pkgname=meshlab
pkgver=2016.12
-pkgrel=2
+pkgrel=3
pkgdesc="System for processing and editing of unstructured 3D models arising in 3D scanning (qt5 version)"
arch=('i686' 'x86_64')
url="http://www.meshlab.net"
@@ -12,6 +12,7 @@ depends=('bzip2' 'muparser' 'levmar' 'lib3ds' 'desktop-file-utils' 'glu' 'mpir'
install="${pkgname}.install"
source=("git+https://github.com/cnr-isti-vclab/meshlab.git#tag=v2016.12"
"git+https://github.com/cnr-isti-vclab/vcglib.git#tag=v1.0.1"
+ "screened_poisson.patch"
"plugin_dir.patch"
"shaders_dir.patch"
"external.patch"
@@ -27,6 +28,7 @@ source=("git+https://github.com/cnr-isti-vclab/meshlab.git#tag=v2016.12"
"meshlab.desktop")
md5sums=('SKIP'
'SKIP'
+ 'd9c9e9160ee16694a225819ee4598be4'
'f13d58ca07fa74b3d7c8f7f9d4ee6a93'
'753dd4753081ddb428f4db8eaefe9009'
'038494125d7bd422074fc5635c5579ca'
@@ -73,6 +75,8 @@ prepare() {
patch -Np0 -i plugin_dir.patch
msg "move shaders to /usr/share/meshlab/shaders"
patch -Np0 -i shaders_dir.patch
+ msg "fix screened poisson linux compilation"
+ patch -Np0 -i screened_poisson.patch
}
build() {
diff --git a/screened_poisson.patch b/screened_poisson.patch
new file mode 100644
index 000000000000..fdda483d4cad
--- /dev/null
+++ b/screened_poisson.patch
@@ -0,0 +1,18 @@
+diff --git a/src/meshlabplugins/filter_screened_poisson/filter_screened_poisson.pro b/src/meshlabplugins/filter_screened_poisson/filter_screened_poisson.pro
+index 814bd31f..e04ad802 100644
+--- a/src/meshlabplugins/filter_screened_poisson/filter_screened_poisson.pro
++++ meshlab/src/meshlabplugins/filter_screened_poisson/filter_screened_poisson.pro
+@@ -2,6 +2,7 @@ include (../../shared.pri)
+
+ macx:QMAKE_CXX = clang++-mp-3.9
+ macx:QMAKE_LFLAGS += -L/opt/local/lib/libomp -lomp
++linux:QMAKE_LFLAGS += -lgomp
+ macx:QMAKE_CXXFLAGS_RELEASE+= -O3 -DRELEASE -funroll-loops -ffast-math -Wno-sign-compare -Wno-unused-parameter
+
+ QMAKE_CXXFLAGS+=-fopenmp
+@@ -22,4 +23,5 @@ DEFINES += FOR_RELEASE
+
+ #PRE_TARGETDEPS += ./filter_screened_poisson.xml
+ macx:QMAKE_POST_LINK = "cp "$$_PRO_FILE_PWD_/$$TARGET".xml ../../distrib/plugins/"$$TARGET".xml"
++linux:QMAKE_POST_LINK = "cp "$$_PRO_FILE_PWD_/$$TARGET".xml ../../distrib/plugins/"$$TARGET".xml; cd ../../distrib/plugins/ ; ln -s "$$TARGET".xml lib"$$TARGET".xml"
+