summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
-rw-r--r--qt5.11.patch53
3 files changed, 61 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 996a3b812325..0afc758c16f4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = meshlab
pkgdesc = System for processing and editing of unstructured 3D models arising in 3D scanning (qt5 version)
pkgver = 2016.12
- pkgrel = 6
+ pkgrel = 7
url = http://www.meshlab.net
install = meshlab.install
arch = i686
@@ -41,6 +41,7 @@ pkgbase = meshlab
source = mpir.patch
source = rpath.patch
source = import_bundle_out.patch
+ source = qt5.11.patch
source = meshlab.desktop
md5sums = SKIP
md5sums = SKIP
@@ -63,6 +64,7 @@ pkgbase = meshlab
md5sums = 5df295c21de5bac8d6073528823d975a
md5sums = 78bf780b3353fe212a77eb91db6f6b6c
md5sums = 765a59b64dd05b74f6a4bdf3962a1d93
+ md5sums = 819d54d1b5e0f6b4dfbe13bbee8d9dac
md5sums = 18aed0a21276a22325bf8c32166fb110
pkgname = meshlab
diff --git a/PKGBUILD b/PKGBUILD
index a72931db18b2..9e192ffc1882 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: bartus <aur@bartus.33mail.com>
pkgname=meshlab
pkgver=2016.12
-pkgrel=6
+pkgrel=7
pkgdesc="System for processing and editing of unstructured 3D models arising in 3D scanning (qt5 version)"
arch=('i686' 'x86_64')
url="http://www.meshlab.net"
@@ -33,6 +33,7 @@ source=("git+https://github.com/cnr-isti-vclab/meshlab.git#tag=v2016.12"
"mpir.patch"
"rpath.patch"
"import_bundle_out.patch"
+ "qt5.11.patch"
"meshlab.desktop")
md5sums=('SKIP'
'SKIP'
@@ -55,6 +56,7 @@ md5sums=('SKIP'
'5df295c21de5bac8d6073528823d975a'
'78bf780b3353fe212a77eb91db6f6b6c'
'765a59b64dd05b74f6a4bdf3962a1d93'
+ '819d54d1b5e0f6b4dfbe13bbee8d9dac'
'18aed0a21276a22325bf8c32166fb110')
prepare() {
@@ -102,6 +104,8 @@ prepare() {
patch -Np1 -i ../filter_sketchfab.patch
msg "fix filter voronoi.patch"
patch -Np1 -i ../filter_voronoi.patch
+ msg "fix qt5.11 compatibility"
+ patch -Np1 -i ../qt5.11.patch
msg "fix bundel/nvm ReadHeader"
cd ${srcdir}/vcglib
diff --git a/qt5.11.patch b/qt5.11.patch
new file mode 100644
index 000000000000..ea7d1fab880f
--- /dev/null
+++ b/qt5.11.patch
@@ -0,0 +1,53 @@
+diff --git a/src/meshlabserver/mainserver.cpp b/src/meshlabserver/mainserver.cpp
+index ab9a7c08..5bbd859a 100644
+--- a/src/meshlabserver/mainserver.cpp
++++ b/src/meshlabserver/mainserver.cpp
+@@ -897,7 +897,7 @@ int main(int argc, char *argv[])
+ }
+
+ if (meshDocument.size() < outmeshlist.size())
+- fprintf(logfp, "Error: trying to save %i meshes, but only %i available in the project\n", qPrintable(outmeshlist.size()), qPrintable(meshDocument.size()));
++ fprintf(logfp, "Error: trying to save %i meshes, but only %i available in the project\n", outmeshlist.size(), meshDocument.size());
+ else
+ {
+ for (int ii = 0; ii < outmeshlist.size(); ++ii)
+@@ -911,7 +911,7 @@ int main(int argc, char *argv[])
+ fprintf(logfp, "Output mesh %s has NOT been saved\n", qPrintable(outmeshlist[ii].filename));
+ }
+ else
+- fprintf(logfp, "Invalid layer %i. Output mesh %s will not be saved\n", qPrintable(ii), qPrintable(outmeshlist[ii].filename));
++ fprintf(logfp, "Invalid layer %i. Output mesh %s will not be saved\n", ii, qPrintable(outmeshlist[ii].filename));
+ }
+
+ }
+diff --git a/src/meshlabplugins/edit_paint/paintbox.cpp b/src/meshlabplugins/edit_paint/paintbox.cpp
+index 2097a5ba..09cce489 100644
+--- a/src/meshlabplugins/edit_paint/paintbox.cpp
++++ b/src/meshlabplugins/edit_paint/paintbox.cpp
+@@ -32,11 +32,11 @@ Paintbox::Paintbox(QWidget * parent, Qt::WindowFlags flags) : QWidget(parent, fl
+
+ QIcon undo = undo_button->icon();
+ undo_button->setDefaultAction(stacks->createUndoAction(undo_button));
+- undo_button->defaultAction()->setIcon(undo);
++ undo_button->setIcon(undo);
+
+ QIcon redo = redo_button->icon();
+ redo_button->setDefaultAction(stacks->createRedoAction(redo_button));
+- redo_button->defaultAction()->setIcon(redo);
++ redo_button->setIcon(redo);
+
+ setUndoStack(parent);
+
+diff --git a/src/meshlabplugins/render_gdp/shaderDialog.h b/src/meshlabplugins/render_gdp/shaderDialog.h
+index a62d3b51..9ff9e5a5 100644
+--- a/src/meshlabplugins/render_gdp/shaderDialog.h
++++ b/src/meshlabplugins/render_gdp/shaderDialog.h
+@@ -29,6 +29,8 @@
+ #include <common/meshmodel.h>
+ #include <QLabel>
+ #include <QDockWidget>
++#include <QSlider>
++#include <QLineEdit>
+ #include "shaderStructs.h"
+ #include "ui_shaderDialog.h"
+ #include <QMap>