summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--Fix-incompatibility-with-recent-cx_Freeze.patch36
-rw-r--r--PKGBUILD10
3 files changed, 47 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fadb9eae6977..a014a265d877 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = meshroom
pkgdesc = Meshroom is a free, open-source 3D Reconstruction Software based on the AliceVision framework.
pkgver = 2021.1.0
- pkgrel = 5
+ pkgrel = 6
url = https://alicevision.github.io/
arch = i686
arch = x86_64
license = MPL2
makedepends = git
makedepends = cmake
- makedepends = python-cx_freeze
+ makedepends = python-cx-freeze-qfix
makedepends = python-idna
makedepends = python-setuptools
makedepends = patchelf
@@ -31,10 +31,12 @@ pkgbase = meshroom
source = git+https://github.com/alicevision/QtOIIO.git
source = git+https://github.com/alicevision/qmlAlembic.git
source = pyside_property_error.patch
+ source = Fix-incompatibility-with-recent-cx_Freeze.patch
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = e211783ead22d388c72f60bac7ab95d670a4d6ae196225c15038b5c9e7c80fdc
+ sha256sums = 40ee489604627e5be1b8ce5f3fdd4b1828a5588427fda298b61aa37beb9125c5
pkgname = meshroom
diff --git a/Fix-incompatibility-with-recent-cx_Freeze.patch b/Fix-incompatibility-with-recent-cx_Freeze.patch
new file mode 100644
index 000000000000..243ffcf67cc4
--- /dev/null
+++ b/Fix-incompatibility-with-recent-cx_Freeze.patch
@@ -0,0 +1,36 @@
+From b9a7174886d7a215818f382f9d5c05226f86a3ff Mon Sep 17 00:00:00 2001
+From: Mikko Rasa <tdb@tdb.fi>
+Date: Sun, 18 Jul 2021 12:09:00 +0300
+Subject: [PATCH] Fix incompatibility with recent cx_Freeze
+
+The run() function of the startup script now gets the main module name
+as a parameter.
+---
+ setupInitScriptUnix.py | 9 ++++++---
+ 1 file changed, 6 insertions(+), 3 deletions(-)
+
+diff --git a/setupInitScriptUnix.py b/setupInitScriptUnix.py
+index 049680d4..75e1844c 100755
+--- a/setupInitScriptUnix.py
++++ b/setupInitScriptUnix.py
+@@ -30,11 +30,14 @@ sys.frozen = True
+ sys.path = sys.path[:4]
+
+
+-def run():
++def run(*args):
+ m = __import__("__main__")
+ importer = zipimport.zipimporter(os.path.dirname(os.__file__))
+- name, ext = os.path.splitext(os.path.basename(os.path.normcase(FILE_NAME)))
+- moduleName = "%s__main__" % name
++ if len(args) == 0:
++ name, ext = os.path.splitext(os.path.basename(os.path.normcase(FILE_NAME)))
++ moduleName = "%s__main__" % name
++ else:
++ moduleName = args[0]
+ code = importer.get_code(moduleName)
+ exec(code, m.__dict__)
+
+--
+2.32.0
+
diff --git a/PKGBUILD b/PKGBUILD
index a86726003120..7862a9aa44df 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ name=meshroom
fragment="#tag=v2021.1.0"
pkgname=${name}
pkgver=${fragment#\#tag=v}
-pkgrel=5
+pkgrel=6
pkgdesc="Meshroom is a free, open-source 3D Reconstruction Software based on the AliceVision framework."
arch=('i686' 'x86_64')
url="https://alicevision.github.io/"
@@ -14,18 +14,20 @@ groups=()
_depends_qt=(python-pyside2 qt5-quickcontrols{,2} qt5-3d qt5-graphicaleffects qt5-imageformats qt5-location qt5-svg qt5-charts)
#_depends_qt+=(qt5-datavis3d qt5-scxml)
depends=(alice-vision alembic openimageio python python-psutil "${_depends_qt[@]}")
-makedepends=(git cmake python-{cx_freeze,idna,setuptools} patchelf)
+makedepends=(git cmake python-{cx-freeze-qfix,idna,setuptools} patchelf)
source=("${pkgname}::git+https://github.com/alicevision/meshroom.git${fragment}"
"voctree::git+https://gitlab.com/alicevision/trainedVocabularyTreeData.git"
"git+https://github.com/alicevision/QtOIIO.git"
"git+https://github.com/alicevision/qmlAlembic.git"
"pyside_property_error.patch"
+ "Fix-incompatibility-with-recent-cx_Freeze.patch"
)
sha256sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
- 'e211783ead22d388c72f60bac7ab95d670a4d6ae196225c15038b5c9e7c80fdc')
+ 'e211783ead22d388c72f60bac7ab95d670a4d6ae196225c15038b5c9e7c80fdc'
+ '40ee489604627e5be1b8ce5f3fdd4b1828a5588427fda298b61aa37beb9125c5')
prepare() {
cd "${srcdir}"/${pkgname}
@@ -42,6 +44,8 @@ prepare() {
# avoid bug in pyside 5.15.2 (https://bugreports.qt.io/browse/PYSIDE-1426)
patch -Np1 -i "$srcdir"/pyside_property_error.patch
+ # back port b9a7174886d7a215818f382f9d5c05226f86a3ff
+ patch -Np1 -i "$srcdir"/Fix-incompatibility-with-recent-cx_Freeze.patch
}
build() {