summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
-rw-r--r--freezer.patch14
3 files changed, 4 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 78aa5b6d86fb..3547e280e5ea 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = meshroom
pkgdesc = Meshroom is a free, open-source 3D Reconstruction Software based on the AliceVision framework.
- pkgver = r781.ef591dd
+ pkgver = r783.80412d5
pkgrel = 1
url = http://alicevision.github.io/
arch = i686
@@ -22,10 +22,8 @@ pkgbase = meshroom
depends = qt5-svg
source = meshroom::git+https://github.com/alicevision/meshroom.git#branch=develop
source = voctree::git+https://gitlab.com/alicevision/trainedVocabularyTreeData.git
- source = freezer.patch
md5sums = SKIP
md5sums = SKIP
- md5sums = b11eb0ff4db95d1130e324f408b6702e
pkgname = meshroom
diff --git a/PKGBUILD b/PKGBUILD
index dfd9db2b1c97..826b173550d6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ name=meshroom
#fragment="#commit=9bd70ed8ace83c6dde174178e17c5147bb50248f"
fragment="#branch=develop"
pkgname=${name}
-pkgver=r781.ef591dd
+pkgver=r783.80412d5
pkgrel=1
pkgdesc="Meshroom is a free, open-source 3D Reconstruction Software based on the AliceVision framework."
arch=('i686' 'x86_64')
@@ -12,15 +12,14 @@ url="http://alicevision.github.io/"
license=('MPL2')
groups=()
_depends_qt=(python-pyside2 qt5-quickcontrols{,2} qt5-3d qt5-graphicaleffects qt5-imageformats qt5-location qt5-svg)
+#_depends_qt+=(qt5-datavis3d qt5-scxml)
depends=(alice-vision python python-psutil ${_depends_qt[@]})
makedepends=(git python-setuptools python-cx_freeze)
source=("${pkgname}::git+https://github.com/alicevision/meshroom.git${fragment}"
"voctree::git+https://gitlab.com/alicevision/trainedVocabularyTreeData.git"
- "freezer.patch"
)
md5sums=('SKIP'
- 'SKIP'
- 'b11eb0ff4db95d1130e324f408b6702e')
+ 'SKIP')
pkgver() {
cd "$pkgname"
@@ -32,7 +31,6 @@ prepare() {
msg2 "Hardcode camera_database and voctree default value"
sed -i "s:'ALICEVISION_VOCTREE', '':'ALICEVISION_VOCTREE', '/usr/share/${pkgname}/vlfeat_K80L3.SIFT.tree':g" meshroom/nodes/aliceVision/*.py
sed -i "s:'ALICEVISION_SENSOR_DB', '':'ALICEVISION_SENSOR_DB', '/usr/share/aliceVision/sensor_width_camera_database.txt':g" meshroom/nodes/aliceVision/*.py
- git apply ${srcdir}/freezer.patch
}
build() {
diff --git a/freezer.patch b/freezer.patch
deleted file mode 100644
index 0763e8959b22..000000000000
--- a/freezer.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-diff --git a/setup.py b/setup.py
-index 77afbe2..17d9363 100644
---- a/setup.py
-+++ b/setup.py
-@@ -16,7 +16,8 @@ meshroomExe = Executable(
- )
-
- meshroomPhotog = Executable(
-- "bin/meshroom_photogrammetry"
-+ "bin/meshroom_photogrammetry",
-+ targetName="meshroomPhotog",
- )
-
- # Customize executable for each target platform