summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD33
2 files changed, 33 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3547e280e5ea..a2bf98f9c1c0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,18 @@
pkgbase = meshroom
pkgdesc = Meshroom is a free, open-source 3D Reconstruction Software based on the AliceVision framework.
- pkgver = r783.80412d5
+ pkgver = 2018.1.0
pkgrel = 1
url = http://alicevision.github.io/
arch = i686
arch = x86_64
license = MPL2
makedepends = git
+ makedepends = cmake
makedepends = python-setuptools
makedepends = python-cx_freeze
depends = alice-vision
+ depends = alembic
+ depends = openimageio
depends = python
depends = python-psutil
depends = python-pyside2
@@ -20,8 +23,12 @@ pkgbase = meshroom
depends = qt5-imageformats
depends = qt5-location
depends = qt5-svg
- source = meshroom::git+https://github.com/alicevision/meshroom.git#branch=develop
+ source = meshroom::git+https://github.com/alicevision/meshroom.git#tag=v2018.1.0
source = voctree::git+https://gitlab.com/alicevision/trainedVocabularyTreeData.git
+ source = git+https://github.com/alicevision/QtOIIO.git
+ source = git+https://github.com/alicevision/qmlAlembic.git
+ md5sums = SKIP
+ md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 826b173550d6..27346941b655 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,9 +2,9 @@
name=meshroom
#fragment="#commit=9bd70ed8ace83c6dde174178e17c5147bb50248f"
-fragment="#branch=develop"
+fragment="#tag=v2018.1.0"
pkgname=${name}
-pkgver=r783.80412d5
+pkgver=2018.1.0
pkgrel=1
pkgdesc="Meshroom is a free, open-source 3D Reconstruction Software based on the AliceVision framework."
arch=('i686' 'x86_64')
@@ -13,33 +13,48 @@ license=('MPL2')
groups=()
_depends_qt=(python-pyside2 qt5-quickcontrols{,2} qt5-3d qt5-graphicaleffects qt5-imageformats qt5-location qt5-svg)
#_depends_qt+=(qt5-datavis3d qt5-scxml)
-depends=(alice-vision python python-psutil ${_depends_qt[@]})
-makedepends=(git python-setuptools python-cx_freeze)
+depends=(alice-vision alembic openimageio python python-psutil ${_depends_qt[@]})
+makedepends=(git cmake python-setuptools python-cx_freeze)
source=("${pkgname}::git+https://github.com/alicevision/meshroom.git${fragment}"
"voctree::git+https://gitlab.com/alicevision/trainedVocabularyTreeData.git"
+ "git+https://github.com/alicevision/QtOIIO.git"
+ "git+https://github.com/alicevision/qmlAlembic.git"
)
md5sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
'SKIP')
-pkgver() {
- cd "$pkgname"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
-}
-
prepare() {
cd ${srcdir}/${pkgname}
msg2 "Hardcode camera_database and voctree default value"
sed -i "s:'ALICEVISION_VOCTREE', '':'ALICEVISION_VOCTREE', '/usr/share/${pkgname}/vlfeat_K80L3.SIFT.tree':g" meshroom/nodes/aliceVision/*.py
sed -i "s:'ALICEVISION_SENSOR_DB', '':'ALICEVISION_SENSOR_DB', '/usr/share/aliceVision/sensor_width_camera_database.txt':g" meshroom/nodes/aliceVision/*.py
+ sed -i '1 i\#include <cmath>' ${srcdir}/QtOIIO/src/jetColorMap.hpp
+ sed -i 's|imageformats|plugins/imageformats|' ${srcdir}/QtOIIO/src/imageIOHandler/CMakeLists.txt
}
build() {
+ cd ${srcdir}/QtOIIO
+ cmake -DCMAKE_INSTALL_PREFIX="/usr/lib/qt/" -DCMAKE_BUILD_TYPE=Release .
+ make
+
+ cd ${srcdir}/qmlAlembic
+ cmake -DCMAKE_INSTALL_PREFIX="/usr/lib/qt/" -DCMAKE_BUILD_TYPE=Release .
+ make
+
cd ${srcdir}/${pkgname}
python setup.py build
}
package() {
+ cd ${srcdir}/QtOIIO
+ make DESTDIR=${pkgdir} install
+
+ cd ${srcdir}/qmlAlembic
+ make DESTDIR=${pkgdir} install
+
cd ${srcdir}/${pkgname}
python setup.py install --root=${pkgdir} --optimize=1 --skip-build
install -Dm644 -t ${pkgdir}/usr/share/${pkgname} ${srcdir}/voctree/vlfeat_K80L3.SIFT.tree