summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD18
-rwxr-xr-xmeshroom_compute3
3 files changed, 16 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 89b5aa7f2c55..2a2f63eaf3b4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,20 @@
pkgbase = meshroom-bin
pkgdesc = Meshroom is a free, open-source 3D Reconstruction Software based on the AliceVision framework.
- pkgver = 2019.1.0
- pkgrel = 2
+ pkgver = 2019.2.0
+ pkgrel = 1
url = https://github.com/alicevision/meshroom
arch = i686
arch = x86_64
license = MPL2
depends = libgl
provides = meshroom
- source = https://github.com/alicevision/meshroom/releases/download/v2019.1.0/Meshroom-2019.1.0-linux.tar.gz
+ options = !strip
+ source = https://github.com/alicevision/meshroom/releases/download/v2019.2.0/Meshroom-2019.2.0-linux.tar.gz
source = Meshroom
source = meshroom_photogrammetry
source = Meshroom.png
source = Meshroom.desktop
- sha256sums = 3455c785282a8836a5dd5e5f404a5876de7b9619d0567a476a2d5e79bf449fab
+ sha256sums = bdd741692161c234d27b3a8ce7109071c99bbe6c30b04d8108675a19f160a93a
sha256sums = ccfc665d6df6bb1b1d3f0490d7e83297c0ae2b7f7a90fb4cb28fdecd85a03feb
sha256sums = a80575135fa438321dc743c95f64defb2c0ed664e30e76d43d42c14366e15eca
sha256sums = a24e45c707c8e0689f2f1b7952f652e824b7c55e159f4c4a0421fabd428cdf5e
diff --git a/PKGBUILD b/PKGBUILD
index 922d7bada3f6..87c6ded7ee6b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Contributor : bartus <arch-user-repoᘓbartus.33mail.com>
pkgname=meshroom-bin
-pkgver=2019.1.0
-pkgrel=2
+pkgver=2019.2.0
+pkgrel=1
pkgdesc="Meshroom is a free, open-source 3D Reconstruction Software based on the AliceVision framework."
arch=('i686' 'x86_64')
url="https://github.com/alicevision/meshroom"
@@ -15,20 +15,18 @@ provides=('meshroom')
options=('!strip')
source=(
- 'https://github.com/alicevision/meshroom/releases/download/v2019.1.0/Meshroom-2019.1.0-linux.tar.gz'
+ 'https://github.com/alicevision/meshroom/releases/download/v2019.2.0/Meshroom-2019.2.0-linux.tar.gz'
'Meshroom'
'meshroom_photogrammetry'
'Meshroom.png'
'Meshroom.desktop'
)
-sha256sums=(
- '3455c785282a8836a5dd5e5f404a5876de7b9619d0567a476a2d5e79bf449fab'
- 'ccfc665d6df6bb1b1d3f0490d7e83297c0ae2b7f7a90fb4cb28fdecd85a03feb'
- 'a80575135fa438321dc743c95f64defb2c0ed664e30e76d43d42c14366e15eca'
- 'a24e45c707c8e0689f2f1b7952f652e824b7c55e159f4c4a0421fabd428cdf5e'
- 'b3c1a11f6fa397a0f7303272692999809df69e9c1d83ddac95d88243b3eff6a3'
-)
+sha256sums=('bdd741692161c234d27b3a8ce7109071c99bbe6c30b04d8108675a19f160a93a'
+ 'ccfc665d6df6bb1b1d3f0490d7e83297c0ae2b7f7a90fb4cb28fdecd85a03feb'
+ 'a80575135fa438321dc743c95f64defb2c0ed664e30e76d43d42c14366e15eca'
+ 'a24e45c707c8e0689f2f1b7952f652e824b7c55e159f4c4a0421fabd428cdf5e'
+ 'b3c1a11f6fa397a0f7303272692999809df69e9c1d83ddac95d88243b3eff6a3')
package() {
mkdir -p ${pkgdir}/usr/share/${pkgname}
diff --git a/meshroom_compute b/meshroom_compute
new file mode 100755
index 000000000000..23006ff733b1
--- /dev/null
+++ b/meshroom_compute
@@ -0,0 +1,3 @@
+#!/usr/bin/env sh
+
+/usr/share/meshroom-bin/meshroom_compute $@