summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD27
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fa5888d881fc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = meshup
+ pkgdesc = Visualization tool for multibody systems based on skeletal animation and magic.
+ pkgver = 0.6.0
+ pkgrel = 1
+ url = https://github.com/ORB-HD/MeshUp
+ arch = x86_64
+ license = MIT
+ makedepends = cmake
+ makedepends = boost
+ depends = ffmpeg
+ depends = boost-libs
+ depends = qt5-base
+ source = https://github.com/ORB-HD/MeshUp/archive/v0.6.0.tar.gz
+ sha256sums = 0110feddfd66d06173288931c00ffbc3b8cfbcaff45d3bd92a8895c04af9db3d
+
+pkgname = meshup
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..227c1c204577
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Jonas 'cherti' Große Sundrup <aur@letopolis.de>
+pkgname=meshup
+_pkgname=MeshUp
+pkgver=0.6.0
+pkgrel=1
+pkgdesc="Visualization tool for multibody systems based on skeletal animation and magic."
+arch=(x86_64)
+url="https://github.com/ORB-HD/MeshUp"
+license=('MIT')
+depends=('ffmpeg' 'boost-libs' 'qt5-base')
+makedepends=('cmake' 'boost')
+source=("https://github.com/ORB-HD/MeshUp/archive/v0.6.0.tar.gz")
+sha256sums=('0110feddfd66d06173288931c00ffbc3b8cfbcaff45d3bd92a8895c04af9db3d')
+
+build() {
+ cd "$_pkgname-$pkgver"
+ mkdir build
+ cd build
+ cmake .. -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+package() {
+ cd "$_pkgname-$pkgver"
+ cd build
+ make DESTDIR="$pkgdir/" install
+}